Bug 3143 - After update system in Gnome log i see error
: After update system in Gnome log i see error
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: GNOME edition
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Denis Silakov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 10:43 MSK by Postnikov Dmitry
Modified: 2013-11-14 13:28 MSK (History)
1 user (show)

See Also:
RPM Package: python-sip-4.15.3-1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-11-14 10:43:24 MSK
Description of problem:
After update system in Gnome log i see error.

=============
[root@mindlife2efiG pastordi]# cat /var/log/messages | grep -i -E "sip"
Nov 14 01:13:46 mindlife2efiG gnome-session[4556]: RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2
Nov 14 01:34:48 mindlife2efiG gnome-session[21406]: RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2
Nov 14 01:37:43 mindlife2efiG gnome-session[23494]: RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2
Nov 14 01:48:52 mindlife2efiG gnome-session[4559]: RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2
Nov 14 01:55:16 mindlife2efiG gnome-session[4597]: RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2
Nov 14 10:31:30 mindlife2efiG gnome-session[6684]: RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2
[root@mindlife2efiG pastordi]#
=============
Comment 1 Denis Silakov 2013-11-14 10:51:23 MSK
Oops. we should rebuild python-qt4 to work with new python-sip.
Comment 2 Denis Silakov 2013-11-14 11:00:14 MSK
... not just rebuild, but also update - the latest version is 4.10.3, we currently have 4.9.6 which possibly won't build with newer sip. But we need newer python-sip for new versions of several packages (e.g., hplip, if i remember correctly).
Comment 3 Denis Silakov 2013-11-14 12:13:06 MSK
For now, I have reverted python-sip to previous version - actually this doesn't seem to break anything. I have increased "Epoch" of this package, so you can just update your system 

Update of python-sip may touch quite a few packages, and I think it makes sense to wait with such update for some time.
Comment 4 Postnikov Dmitry 2013-11-14 13:28:25 MSK
After update, no error in log.