Bug 3109 - kftpgrabber shows garbage instead of russian symbols from remote ftp
: kftpgrabber shows garbage instead of russian symbols from remote ftp
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 10:55 MSK by FirstLevel
Modified: 2014-01-17 14:37 MSK (History)
0 users

See Also:
RPM Package: kftpgrabber-0.8.99-0.1323046.1-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
kftpgrabber - selection of server encoding (44.35 KB, image/png)
2014-01-13 12:25 MSK, Denis Silakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-11-11 10:55:02 MSK
Description of problem:
I have installed ROSA 2012.1 Fresh and used kftpgrabber.
For ftp server based on Internet Information Service kftpgrabber shows garbage instead of russian symbols.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-11-11 10:55:37 MSK
I could not find any codepage parameter for kftpgrabber.
Comment 2 Denis Silakov 2014-01-13 12:25:26 MSK
Created attachment 2511 [details]
kftpgrabber - selection of server encoding

Code page is set during connection, on the "Advanced" tab.

I can't reproduce the problem with Linux servers, maybe the problem is specific to IIS? Or maybe user just selects wrong encoding? E.g., if I choose "cp1251" when connecting to UTF8 Linux server, I also see garbage instead of Cyrillic names.
Comment 3 FirstLevel 2014-01-17 14:37:37 MSK
(In reply to comment #2)
> Created attachment 2511 [details]
> kftpgrabber - selection of server encoding
> 
> Code page is set during connection, on the "Advanced" tab.
> 
> I can't reproduce the problem with Linux servers, maybe the problem is
> specific to IIS? Or maybe user just selects wrong encoding? E.g., if I
> choose "cp1251" when connecting to UTF8 Linux server, I also see garbage
> instead of Cyrillic names.

User has approved this solution.