Bug 3103 - [UPDATE REQUEST]: openjdk: problem with main menu of GUI Java-applications
: [UPDATE REQUEST]: openjdk: problem with main menu of GUI Java-applications
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Vladimir Potapov
: ROSA Linux Bugs
:
Depends on:
Blocks: 3085
  Show dependency treegraph
 
Reported: 2013-11-08 10:19 MSK by Dmitry
Modified: 2013-11-18 10:10 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2013-11-08 10:19:55 MSK
If GUI Java-based application is maximazed then main menu closes immediately after it is opened.
Comment 1 Dmitry 2013-11-08 12:55:10 MSK
- https://abf.rosalinux.ru/build_lists/1381426
- https://abf.rosalinux.ru/build_lists/1381421

Advisory:
- Fixed main menu of Java-based GUI Applications
Comment 2 Dmitry 2013-11-08 12:58:37 MSK
How to test:

1. Install openjdk
2. Install any Java-based GUI application, like freeplane
3. Open freeplane and *maximize* its window
4. Try to click on any item of main menu. Main menu must not hide.

// Blocked bug contains several video explaining problem.
Comment 3 Postnikov Dmitry 2013-11-09 01:33:56 MSK
All work for me.
http://cdn.2safe.com/315169033758/screen-jdk1.avi
Comment 4 Alexander Petryakov 2013-11-10 01:09:51 MSK
I also can confirm all work
Comment 5 Vladimir Potapov 2013-11-14 13:46:18 MSK
(In reply to comment #3)
> All work for me.
> http://cdn.2safe.com/315169033758/screen-jdk1.avi
I can't reproduce the bug. All work for me without update...
Comment 6 Dmitry 2013-11-14 14:33:05 MSK
(In reply to comment #5)
> I can't reproduce the bug. All work for me without update...

What DE do you use? This bug is Gnome-shell specific and arises only for maximized window. Do you use OpenJDK or version from Oracle? What version of openjdk have you got installed (rpm -qa | grep openjdk)?
Comment 7 Vladimir Potapov 2013-11-14 14:44:49 MSK
(In reply to comment #6)
> (In reply to comment #5)
> > I can't reproduce the bug. All work for me without update...
> 
> What DE do you use? This bug is Gnome-shell specific and arises only for
> maximized window. Do you use OpenJDK or version from Oracle? What version of
> openjdk have you got installed (rpm -qa | grep openjdk)?
Dmitry, in advisory is written nothing about gnome-shell... I test in KDE.
Ok, I check again.
Comment 8 Dmitry 2013-11-14 16:38:30 MSK
Build list:
- https://abf.rosalinux.ru/build_lists/1381426
- https://abf.rosalinux.ru/build_lists/1381421

Advisory:
- Main menu of maximized windows of Java-based GUI applications in Gnome desktop environment has been fixed
Comment 9 Vladimir Potapov 2013-11-14 18:28:54 MSK
java-1.7.0-openjdk-1.7.0.1-2.0.5-rosa2012.1
*************************** Advisory ****************************
- Fixed main menu of Java-based GUI Applications
*****************************************************************
QA Verified