Bug 3099 - [UPDATE REQUEST] gdm
: [UPDATE REQUEST] gdm
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest blocker
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 3161
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 20:48 MSK by Arkady L. Shane
Modified: 2013-11-28 18:04 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
log (21.42 KB, text/x-log)
2013-11-11 06:37 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Vladimir Potapov 2013-11-08 18:45:05 MSK
(In reply to comment #0)
> Advisory:
> 
> Resolve: http://bugs.rosalinux.ru/show_bug.cgi?id=2688
The bug was not corrected (tested on x64 FRESH Updated KDE + task-gnome + enabled GDM)
***************************
QA Denied
Comment 2 Aleksandr Kazantcev 2013-11-08 23:33:17 MSK
*** Bug 2889 has been marked as a duplicate of this bug. ***
Comment 3 Arkady L. Shane 2013-11-09 11:12:19 MSK
(In reply to comment #1)
> (In reply to comment #0)
> > Advisory:
> > 
> > Resolve: http://bugs.rosalinux.ru/show_bug.cgi?id=2688
> The bug was not corrected (tested on x64 FRESH Updated KDE + task-gnome +
> enabled GDM)
> ***************************
> QA Denied

What's the problem?
Comment 4 Aleksandr Kazantcev 2013-11-09 11:25:57 MSK
Please provide from failed machines 

journald | grep gdm

and

cat /etc/log/syslog | grep gdm
Comment 5 Arkady L. Shane 2013-11-09 11:41:38 MSK
and $HOME/.cache/gdm/session.log
Comment 6 Vladimir Potapov 2013-11-11 06:20:07 MSK
(In reply to comment #3)
> (In reply to comment #1)
> > (In reply to comment #0)
> > > Advisory:
> > > 
> > > Resolve: http://bugs.rosalinux.ru/show_bug.cgi?id=2688
> > The bug was not corrected (tested on x64 FRESH Updated KDE + task-gnome +
> > enabled GDM)
> > ***************************
> > QA Denied
> 
> What's the problem?

If I create user from KDE center, it's entered ok
If I create user from GNOME, I can't enter to system by the user.
Comment 7 Vladimir Potapov 2013-11-11 06:24:39 MSK
(In reply to comment #4)
> Please provide from failed machines 
> 
> journald | grep gdm
# journald | grep gdm
bash: journald: команда не найдена

 
> and
> 
> cat /etc/log/syslog | grep gdm
cat /etc/log/syslog | grep gdm
cat: /etc/log/syslog: Нет такого файла или каталога

cat /var/log/syslog | grep gdm
Nov 11 11:02:09 ROSAx64 gdm[5355]: GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
Nov 11 11:02:09 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
Nov 11 11:02:09 ROSAx64 gdm[5355]: GdmDisplay: display lasted 2,974142 seconds
Nov 11 11:02:09 ROSAx64 dbus-daemon[3456]: dbus[3456]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.35" (uid=0 pid=5355 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.153" (uid=0 pid=2074 comm="/usr/lib64/gdm-simple-slave --display-id /org/gnom")
Nov 11 11:02:27 ROSAx64 gdm[5355]: GLib-GIO: g_dbus_method_invocation_return_value_internal: assertion `G_IS_DBUS_METHOD_INVOCATION (invocation)' failed
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib-GIO: g_dbus_connection_unregister_object: assertion `G_IS_DBUS_CONNECTION (connection)' failed
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib-GIO: (gdbusinterfaceskeleton.c:735):remove_connection_locked: runtime check failed: (g_dbus_connection_unregister_object (data->connection, data->registration_id))
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
Nov 11 11:11:38 ROSAx64 dbus-daemon[3456]: dbus[3456]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.35" (uid=0 pid=5355 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.204" (uid=0 pid=20290 comm="/usr/lib64/gdm-simple-slave --display-id /org/gnom")
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:11:38 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:11:45 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:11:45 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:11:45 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:12:20 ROSAx64 gdm[5355]: GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
Nov 11 11:12:20 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
Nov 11 11:12:20 ROSAx64 dbus-daemon[3456]: dbus[3456]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.35" (uid=0 pid=5355 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.253" (uid=0 pid=22505 comm="/usr/lib64/gdm-simple-slave --display-id /org/gnom")
Nov 11 11:12:38 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:12:38 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:12:38 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:14:42 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:14:45 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:14:53 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:15:12 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:15:21 ROSAx64 gdm[5355]: GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
Nov 11 11:15:21 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
Nov 11 11:15:21 ROSAx64 gdm[5355]: GdmDisplay: display lasted 0,001187 seconds
Nov 11 11:15:21 ROSAx64 dbus-daemon[3456]: dbus[3456]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.35" (uid=0 pid=5355 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.320" (uid=0 pid=30007 comm="/usr/lib64/gdm-simple-slave --display-id /org/gnom")
Nov 11 11:15:22 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:15:22 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:15:36 ROSAx64 gdm[5355]: GLib-GIO: g_dbus_method_invocation_return_value_internal: assertion `G_IS_DBUS_METHOD_INVOCATION (invocation)' failed
Nov 11 11:16:01 ROSAx64 gdm[5355]: GLib-GIO: g_dbus_connection_unregister_object: assertion `G_IS_DBUS_CONNECTION (connection)' failed
Nov 11 11:16:01 ROSAx64 gdm[5355]: GLib-GIO: (gdbusinterfaceskeleton.c:735):remove_connection_locked: runtime check failed: (g_dbus_connection_unregister_object (data->connection, data->registration_id))
Nov 11 11:16:01 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Nov 11 11:16:01 ROSAx64 gdm[5355]: GLib-GObject: g_object_ref: assertion `object->ref_count > 0' failed
Nov 11 11:16:01 ROSAx64 gdm[5355]: GLib-GObject: g_object_unref: assertion `object->ref_count > 0' failed
Nov 11 11:16:01 ROSAx64 dbus-daemon[3456]: dbus[3456]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.35" (uid=0 pid=5355 comm="/usr/sbin/gdm ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.385" (uid=0 pid=32035 comm="/usr/lib64/gdm-simple-slave --display-id /org/gnom")
Nov 11 11:17:40 ROSAx64 gdm[5355]: GdmManager: could not fetch uid of session '14': Нет такого файла или каталога
Nov 11 11:17:46 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:17:46 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Nov 11 11:17:46 ROSAx64 gdm[5355]: GLib: g_variant_compare: assertion `!g_variant_is_container (a)' failed
Comment 8 Vladimir Potapov 2013-11-11 06:37:20 MSK
Created attachment 2210 [details]
log

I create two user  - test1 from KDE (drak) and test2 from GNOME
For test1 log file exist. I can't entered by test2, in it's $HOME folder .cache don't exist.
Comment 9 Arkady L. Shane 2013-11-11 16:44:18 MSK
I think you try test another bug. This hack fix only "Stas Fomin bash completion" bugs:)

Add him to CC.
Comment 10 Denis Silakov 2013-11-11 16:47:03 MSK
(In reply to comment #8)
> Created attachment 2210 [details]
> log
> 
> I create two user  - test1 from KDE (drak) and test2 from GNOME
> For test1 log file exist. I can't entered by test2, in it's $HOME folder
> .cache don't exist.

Likely because you created user using Gnome utilities? We already have a separate bug for this.
Comment 11 Arkady L. Shane 2013-11-22 15:48:27 MSK
Updated version. ROSA logo changed to English one.

https://abf.rosalinux.ru/build_lists/1393491
https://abf.rosalinux.ru/build_lists/1393484
Comment 12 Vladimir Potapov 2013-11-28 18:04:19 MSK
This update is tested in Testing, without QA.