Bug 3096 - [UPDATE REQUEST] drakxtools-14.39-1
: [UPDATE REQUEST] drakxtools-14.39-1
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 3105
Blocks: 3115
  Show dependency treegraph
 
Reported: 2013-11-07 10:35 MSK by Aleksandr Kazantcev
Modified: 2013-11-12 14:28 MSK (History)
3 users (show)

See Also:
RPM Package: drakxtools-14.39-1
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
d1.png (151.62 KB, image/png)
2013-11-09 01:08 MSK, Postnikov Dmitry
Details
d2.png (293.38 KB, image/png)
2013-11-09 01:24 MSK, Postnikov Dmitry
Details
hh1.png (252.29 KB, image/png)
2013-11-09 02:05 MSK, Postnikov Dmitry
Details
harddrake2.txt (42.69 KB, text/plain)
2013-11-09 02:08 MSK, Postnikov Dmitry
Details
vv1.png (220.59 KB, image/png)
2013-11-09 02:22 MSK, Postnikov Dmitry
Details
mm1.png (220.94 KB, image/png)
2013-11-09 02:26 MSK, Postnikov Dmitry
Details
jj1.png (127.48 KB, image/png)
2013-11-09 03:45 MSK, Postnikov Dmitry
Details
jj2.png (149.12 KB, image/png)
2013-11-09 03:48 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-11-07 10:35:18 MSK
Update drakxtools
Comment 1 Aleksandr Kazantcev 2013-11-07 10:39:03 MSK
ldetect
https://abf.rosalinux.ru/build_lists/1380727
https://abf.rosalinux.ru/build_lists/1380728

drakxtools
https://abf.rosalinux.ru/build_lists/1380739
https://abf.rosalinux.ru/build_lists/1380740


Advisory: Drakxtools updated to add new feature and fix some bugs:

- fix drakedm for use alternatives in lightdm and gdm
- fix laptop mode in hardrake detect
- (install,check_mntpoint) forbid having /boot as btrfs
- point detect from /proc/bus/usb/ to /sys/kernel/debug/usb/devices
- fix displayed PCI/USB ids
- skip comments in /etc/crypttab
- only allow 'acl' option for extX & reiserfs
- allow to choose btrfs in normal mode
- tag btrfs & nilfs2 as Journalised FS
- actually preserve UUID when formatting
- (really_all_fstab) do not put entry for CD/DVD in /etc/fstab
- (call_blkid) do not bypass blkid cache
- if a partition has been manually formated, don't offer to reformat it again
- adapt to latest btrfs utils for resizing
- fix a crash when reloading partition table
- fix a crash when trying to create a encrypted LVM partition
- ensure LVMs on top of dmcrypt are activated after unlocking
- fix loosing crypt key when re-reading partition tables
- win AD connection update
- Installer: suggest default hostname by computer model. Implementation based on Ubuntu/elementaryOS funtionality.
- Added first user to group wheel (allowing 'sudo')
- Set default timezone from GeoIP (requires perl-Geo-IP)
- Changed default computer name to "<login>-computer"
- Fixed installer not exiting on Exit (before partitioning)

Ldetect build without uclibc support and need for this version drakxtools.
Comment 2 Vladimir Potapov 2013-11-08 15:11:12 MSK
The update route to extended testing.
Comment 3 Postnikov Dmitry 2013-11-09 00:50:38 MSK
1. I load in LiveCD mode
2. Connect this container with drakxtools & ldetect
3. Update
4. Install ROSA Gnome in hard drive.
5. After reboot, in drakx-finish-install where checked services - english label. And in GDM i see TWO users: "Rosa-Live User" and my first user.
Comment 4 Aleksandr Kazantcev 2013-11-09 00:56:14 MSK
This is not problem for drakxtools. We don't touch install parts. Also GDM is not drakxtools part.

And.. Install drakxtools in Live mode may change some presets, that changed in Live build. This is wrong test - you will need request for Arcady Shaine new install ISO with this package builded.
Comment 5 Postnikov Dmitry 2013-11-09 01:03:42 MSK
Err in log after install with new drakx-finish-install:
===========
Nov  8 23:53:25 localhost finish-install[5081]: ask_glx failed: Can't locate Xconfig/glx.pm in @INC (@INC contains: /usr/lib/libDrakX /usr/lib/perl5/site_perl/5.14.2/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.14.2 /usr/lib/perl5/vendor_perl/5.14.2/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.14.2 /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi /usr/lib/perl5/5.14.2 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl .) at /usr/sbin/finish-install line 359

Nov  9 00:13:43 localhost finish-install[5102]: ask_glx failed: Can't locate Xconfig/glx.pm in @INC (@INC contains: /usr/lib/libDrakX /usr/lib/perl5/site_perl/5.14.2/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.14.2 /usr/lib/perl5/vendor_perl/5.14.2/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.14.2 /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi /usr/lib/perl5/5.14.2 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl .) at /usr/sbin/finish-install line 476. 
===========
Comment 6 Postnikov Dmitry 2013-11-09 01:08:50 MSK
Created attachment 2197 [details]
d1.png

The "hieroglyphics" show draklog.
Comment 7 Aleksandr Kazantcev 2013-11-09 01:21:39 MSK
Is error with finish install appear previously?

We did not have Xconfig/glx.pm previously too.See for example

ls /usr/lib/libDrakX/Xconfig/

This is not regress.

Is draklog in previous version on Gnome work without problem?
Comment 8 Postnikov Dmitry 2013-11-09 01:24:48 MSK
Created attachment 2198 [details]
d2.png

drakhardware show error.
Comment 9 Aleksandr Kazantcev 2013-11-09 01:27:20 MSK
If you not seen programm in /usr/bin, so this program NOT RUNNING from simple user. This is not error - many program in /usr/sbin will run only from root. This is rule, not a bug!!!
Comment 10 Postnikov Dmitry 2013-11-09 01:39:12 MSK
(In reply to comment #7)
> Is error with finish install appear previously?
> 
> 
> Is draklog in previous version on Gnome work without problem?

In previous version the same.
Comment 11 Postnikov Dmitry 2013-11-09 02:05:58 MSK
Created attachment 2199 [details]
hh1.png

No "fix laptop mode in hardrake detect".
Comment 12 Postnikov Dmitry 2013-11-09 02:08:39 MSK
Created attachment 2200 [details]
harddrake2.txt

When i press "Yes" for instal laptop-mode-tools, i see install 63 packages i586!!! But for me installed x86_64!
Comment 13 Postnikov Dmitry 2013-11-09 02:22:47 MSK
Created attachment 2201 [details]
vv1.png

Harddrake2 not correctly detects your video card.

I have Intel HD 4000, but harddrake2 show 3000.
Comment 14 Postnikov Dmitry 2013-11-09 02:26:48 MSK
Created attachment 2202 [details]
mm1.png

Harddrake2 show doubled Memory Module (DIMM1) and doubled Cache (L1 Cache)
Comment 15 Postnikov Dmitry 2013-11-09 03:45:21 MSK
Created attachment 2204 [details]
jj1.png

In Kinfocenter not detect all network card. (In old ldetect the same)
Comment 16 Postnikov Dmitry 2013-11-09 03:48:46 MSK
Created attachment 2205 [details]
jj2.png

In part "Video hardware" not show Video card, only webcam. And not text label for "button".
Comment 17 Aleksandr Kazantcev 2013-11-09 09:05:18 MSK
What! How kinfocenter join with drakxtools? This is different programs?

Hardrake show information, that card say. See lspci for example - this is similar.
Comment 18 Postnikov Dmitry 2013-11-11 11:22:21 MSK
(In reply to comment #17)
> What! How kinfocenter join with drakxtools? This is different programs?

Kinfocenter used ldetect.

(In reply to comment #17)
> 
> Hardrake show information, that card say. See lspci for example - this is
> similar.

Yes, in harddrake2 show all info network card.
Comment 19 Aleksandr Kazantcev 2013-11-11 11:25:32 MSK
Create separate bug for kinfocenter. We drop ldetect from all parts...
Comment 20 Postnikov Dmitry 2013-11-11 11:27:00 MSK
Result:

1. See "Memory" on a single computer shows and doubles memory, and the other just only "Cash" shown.
2. No fixed "laptop-mode-tools"
3. Always asks about how to install nspluginwrapper. If its install... then install 32bit package in 64bit system. Although nspluginwrapper 64 bit stands in the system.
Comment 21 Vladimir Potapov 2013-11-11 11:35:37 MSK
(In reply to comment #20)

> 3. Always asks about how to install nspluginwrapper. If its install... then
> install 32bit package in 64bit system. Although nspluginwrapper 64 bit
> stands in the system.
In my system too (+gnome-phone-manager with 32x libs)
Comment 22 Aleksandr Kazantcev 2013-11-11 11:39:40 MSK
Error in hardrake present in previous drakxtools. We plan drop hardrake, and we do not fix it because we stoped update ldetect and plan drop it.

And we will not fix this error in future time, but strongly need all other fix from drakxtools.
Comment 23 Postnikov Dmitry 2013-11-12 13:12:11 MSK
***********************
Extended testing report
***********************
>- fix drakedm for use alternatives in lightdm and gdm
OK
>- fix laptop mode in hardrake detect
Not fixed
>- (install,check_mntpoint) forbid having /boot as btrfs
No testing
>- point detect from /proc/bus/usb/ to /sys/kernel/debug/usb/devices
OK
>- fix displayed PCI/USB ids
OK
>- skip comments in /etc/crypttab
>- only allow 'acl' option for extX & reiserfs
>- allow to choose btrfs in normal mode
>- tag btrfs & nilfs2 as Journalised FS
No testing (4)
>- actually preserve UUID when formatting
OK
>- (really_all_fstab) do not put entry for CD/DVD in /etc/fstab
OK
>- (call_blkid) do not bypass blkid cache
OK
>- if a partition has been manually formated, don't offer to reformat it again
OK
>- adapt to latest btrfs utils for resizing
No testing
>- fix a crash when reloading partition table
OK
>- fix a crash when trying to create a encrypted LVM partition
>- ensure LVMs on top of dmcrypt are activated after unlocking
>- fix loosing crypt key when re-reading partition tables
>- win AD connection update
No testing (4)
>- Installer: suggest default hostname by computer model. Implementation based on Ubuntu/elementaryOS funtionality.
OK
>- Added first user to group wheel (allowing 'sudo')
OK
>- Set default timezone from GeoIP (requires perl-Geo-IP)
OK
>- Changed default computer name to "<login>-computer"
OK
>- Fixed installer not exiting on Exit (before partitioning)
OK

lcdetect - work OK.
Comment 24 Aleksandr Kazantcev 2013-11-12 13:35:53 MSK
hardrake need more investigate, becouse code for install ndiswrapper and laptop-mode-tools not present in code of drakxtools. I think this is ldetect or another programm. But.. I suggests use instead harddrake programm 'hardinfo'. And then add to it needing parts for us.
Comment 25 Vladimir Potapov 2013-11-12 14:01:55 MSK
ldetect-0.12.6-5-rosa2012.1
drakxtools-14.39-1-rosa2012.1
*********************** Advisory *****************
Drakxtools updated to add new feature and fix some bugs

+ fix drakedm for use alternatives in lightdm and gdm
+ point detect from /proc/bus/usb/ to /sys/kernel/debug/usb/devices
+ actually preserve UUID when formatting

+ (really_all_fstab) do not put entry for CD/DVD in /etc/fstab
+ (call_blkid) do not bypass blkid cache
+ if a partition has been manually formated, don't offer to reformat it again
+ fix a crash when reloading partition table
+ Installer: suggest default hostname by computer model. Implementation based on + Added first user to group wheel (allowing 'sudo')
+ Set default timezone from GeoIP (requires perl-Geo-IP)
+ Changed default computer name to "<login>-computer"
+ Fixed installer not exiting on Exit (before partitioning)
******************************************************
QA Verified