Bug 3055 - Broken os recognition and os names due to recent update of os-prober.
: Broken os recognition and os names due to recent update of os-prober.
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 3105
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 19:18 MSK by Vladimir Testov
Modified: 2013-11-13 08:12 MSK (History)
3 users (show)

See Also:
RPM Package: os-prober-1.58-1-rosa2012.1.x86_64.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Testov 2013-10-31 19:18:48 MSK
Description of problem:
Broken os recognition and os names due to recent update of os-prober.

Version-Release number of selected component (if applicable):
1.58-1

How reproducible:
Always if there are at least two systems installed on the computer.

Steps to Reproduce:
1. run update-grub2
2. reboot
3. you will see "OS" instead of os name (if you're lucky) or won't see the os

Suggested rollback to the working state.
Comment 1 Postnikov Dmitry 2013-10-31 19:37:22 MSK
If run: os-prober
What show?
Comment 3 Vladimir Testov 2013-10-31 20:31:31 MSK
as I said
you will see "OS" instead of os name (if you're lucky) or won't see the os
Comment 4 Vladimir Testov 2013-10-31 21:09:50 MSK
I'll see what I can do tomorrow.
Comment 5 Vladimir Testov 2013-11-12 17:36:05 MSK
Advisory:
Fixed OS recognition after recent update.

Build lists:
https://abf.rosalinux.ru/build_lists/1386195
https://abf.rosalinux.ru/build_lists/1386196

Enjoy. :)
Comment 6 Vladimir Potapov 2013-11-12 18:52:49 MSK
I can't reproduce the bug. After update-grub2 run in grub menu all OK.
Comment 7 Postnikov Dmitry 2013-11-12 19:22:03 MSK
Now we will check...
Comment 8 Postnikov Dmitry 2013-11-12 19:27:34 MSK
(In reply to comment #5)
> Advisory:
> Fixed OS recognition after recent update.
> 
> Build lists:
> https://abf.rosalinux.ru/build_lists/1386195
> https://abf.rosalinux.ru/build_lists/1386196
> 
> Enjoy. :)

Yes! All show another linux.
(Verified)
Comment 9 Vladimir Potapov 2013-11-13 03:15:08 MSK
The update send to repo without QA
Comment 10 Aleksandr Kazantcev 2013-11-13 08:11:32 MSK
Update send via resolution release manager
Comment 11 Aleksandr Kazantcev 2013-11-13 08:12:28 MSK
Update send with the approval of release manager