Bug 3054 - No lib[64]gphoto6-2.5.2-4?
: No lib[64]gphoto6-2.5.2-4?
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-31 17:58 MSK by Rolf Pedersen
Modified: 2013-11-06 22:31 MSK (History)
3 users (show)

See Also:
RPM Package: libgphoto-2.5.2-4.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Pedersen 2013-10-31 17:58:20 MSK
I get this:

A requested package cannot be installed:
lib64gphoto6-2.5.0-3-rosa2012.1.x86_64 (due to unsatisfied libgphoto-common-2.5.0-3-rosa2012.1.x86_64)

Looks like something needs lib64gphoto6 but a newer version of libgphoto-common has been built and is installed:

[rolf@localhost ~]$ rpm -q libgphoto6 libgphoto-common
package libgphoto6 is not installed
libgphoto-common-2.5.2-4-rosa2012.1.x86_64
[rolf@localhost ~]$ urpmq --sources libgphoto-common
ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/release/libgphoto-common-2.5.0-3-rosa2012.1.x86_64.rpm
ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/updates/libgphoto-common-2.5.2-4-rosa2012.1.x86_64.rpm
[rolf@localhost ~]$ urpmq --sources libgphoto6
http://mirror.rosalab.ru/rosa2012.1/repository/i586/media/main/release/libgphoto6-2.5.0-3-rosa2012.1.i586.rpm

Thanks.
Comment 1 Aleksandr Kazantcev 2013-10-31 18:13:02 MSK
I think problem with mirror. Please try remove all mirrors and add it again.
Comment 2 Denis Silakov 2013-10-31 22:07:16 MSK
When you get this error?

In general, lib[64]gphoto6 was renamed to lib[64]gphoto2_6 to follow ROSA packaging policies. So if you need this lib, install lib[64]gphoto2_6.
Comment 3 Rolf Pedersen 2013-11-04 07:06:18 MSK
I see this error when the update applet has packages to update, or when doing --auto-update on the command line.

I did

urpmi.removedmedia -a
urpmi.addmedia --distrib --mirrorlist
urpmi --auto-select
[..]
A requested package cannot be installed:
lib64gphoto6-2.5.0-3-rosa2012.1.x86_64 (due to unsatisfied libgphoto-common-2.5.0-3-rosa2012.1.x86_64)

I have

[rolf@localhost ~]$ rpm -qa|grep libgphoto
libgphoto-common-2.5.2-4-rosa2012.1.x86_64
[rolf@localhost ~]$ rpm -qa|grep lib64gphoto
lib64gphoto2-2.4.11-1-mdv2011.0.x86_64
lib64gphoto2_port10-2.5.2-4-rosa2012.1.x86_64
lib64gphoto2_6-2.5.2-4-rosa2012.1.x86_64
[rolf@localhost ~]$ rpm -qa|grep lib64gphoto6
[rolf@localhost ~]$ rpm -qa|grep libgphoto6

[rolf@localhost ~]$ urpmq --sources libgphoto-common
ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/release/libgphoto-common-2.5.0-3-rosa2012.1.x86_64.rpm
ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/updates/libgphoto-common-2.5.2-4-rosa2012.1.x86_64.rpm
[rolf@localhost ~]$ urpmq --sources lib64gphoto6
ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/release/lib64gphoto6-2.5.0-3-rosa2012.1.x86_64.rpm

Most importantly, I use gtkam, which requires
..
libgphoto2.so.6()(64bit)
libgphoto2_port.so.10()(64bit)
libgphoto2_port.so.10(LIBGPHOTO2_5_0)(64bit)
..
and it works so I guess some unnecessary old package(s) got stuck, here.
Thanks.
Comment 4 Denis Silakov 2013-11-04 12:21:06 MSK
What happens if you try to explicitly install "lib64gphoto2_6" (with "_6" at the end of the name, not just lib64gphoto2")?
Comment 5 Rolf Pedersen 2013-11-04 23:50:25 MSK
# urpmi lib64gphoto2_6
Package lib64gphoto2_6-2.5.2-4-rosa2012.1.x86_64 is already installed

^^^it is installed.
Comment 6 Denis Silakov 2013-11-05 10:22:51 MSK
Please also check "urpmi lib64gphoto2_port10".

Meanwhile, where did you get gtkam? As far as I can see, it is not built for Desktop Fresh, so maybe this package causes issues with dependencies...
Comment 7 Denis Silakov 2013-11-05 10:55:22 MSK
And indeed, the problem is with gtkam (if you use the package from Marathon) - it requires libgphoto-hotplug which was provided by old libgphoto-common package but was dropped from the new one.

I have built gtkam for contrib repo of ROSA Desktop Fresh and replace "libgphoto-hotplug" with more general "gphoto2" requirement. Please wait a little while the new version (gtkam-0.1.18-3) appears on mirrors, then try to install it and update your system again.
Comment 8 Rolf Pedersen 2013-11-05 15:56:35 MSK
Looks like I found gtkam at pbone.net or rpmfind.net

$ rpm -q gtkam -i
Name        : gtkam                        Relocations: (not relocatable)
Version     : 0.2.0                             Vendor: openSUSE
Release     : 3.1                           Build Date: Wed 13 Feb 2013 10:33:03 PM PST
Install Date: Thu 23 May 2013 10:50:13 PM   Build Host: build02
Group       : Hardware/Camera               Source RPM: gtkam-0.2.0-3.1.src.rpm
Size        : 444165                           License: GPL-2.0+
Signature   : RSA/8, Wed 13 Feb 2013 10:36:36 PM PST, Key ID b88b2fd43dbdc284
Packager    : http://bugs.opensuse.org
URL         : http://gphoto.org
Summary     : A GTK Digital Camera Tool
Architecture: x86_64
Description :
GTKam is a GTK and GNOME based tool for accessing a digital camera,
viewing thumbnails, and downloading pictures from the camera.

Thanks for your help and sorry to make your job difficult!
Comment 9 Denis Silakov 2013-11-05 15:59:54 MSK
Ok, hopefully gtkam from our repos will work fine:)
Comment 10 Rolf Pedersen 2013-11-06 03:34:56 MSK
(In reply to comment #9)
> Ok, hopefully gtkam from our repos will work fine:)

I removed the Suse gtkam and its dependency,
# urpme gtkam gtkam-lang
installed gtkam from $MIRRORLIST: media/contrib/updates/gtkam-0.1.18-3-rosa2012.1.x86_64.rpm
and

$ gtkam 
Segmentation fault (core dumped)

also, after removing lib64gphoto2-2.4.11-1-mdv2011.0.x86_64, there is no more error like:

A requested package cannot be installed:
lib64gphoto6-2.5.0-3-rosa2012.1.x86_64 (due to unsatisfied libgphoto-common-2.5.0-3-rosa2012.1.x86_64)
Comment 11 Denis Silakov 2013-11-06 11:32:15 MSK
(In reply to comment #10)
> 
> $ gtkam 
> Segmentation fault (core dumped)

I confirm this issue.

I have updated gtkam to 0.2.0, this version seems to work.
Comment 12 Rolf Pedersen 2013-11-06 22:31:06 MSK
Yes, this last one seems to work fine, thank you.