Bug 305 - Network connection stops working and cannot be reconnected
: Network connection stops working and cannot be reconnected
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 12:15 MSD by Dmitry
Modified: 2013-11-08 11:19 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
A piece of log (3.01 KB, text/plain)
2012-05-29 12:15 MSD, Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2012-05-29 12:15:04 MSD
Created attachment 211 [details]
A piece of log

Description of problem:

Sometimes network connection breaks (stops working) and cannot be resurrected (reconnected)! Any attempt of reconnection fails. Router works fine, wire is OK. Wifi connection also fails. So, I have to reboot laptop.     

How reproducible:
Every day (2 or more times per day)

Steps to Reproduce:
1. Start ROSA, run many application and work, work, work
2. Connection is lost
3. Don't worry, be annoyed
Comment 1 Dmitry 2012-06-20 17:26:02 MSD
Switching AC-Power on/off leads to the fact that  network stops working
Comment 2 Denis Silakov 2012-06-20 17:45:56 MSD
Which network adapter do you use and which drive is loaded for it? If not sure, just attach the output of `lspci` and 'lsmod` commands.
Comment 3 Dmitry 2012-06-20 17:58:55 MSD
(In reply to comment #2)
> Which network adapter do you use and which drive is loaded for it? If not
> sure, just attach the output of `lspci` and 'lsmod` commands.

The problem is dhcpclient. I have found temporary solution from console:
# dhcpclient eth0

If I unplug AC, I'll have to type "dhcpclient eth0" in console.

lspci:
Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)

the same ethernet controller is installed in Denis's () thinkpad T420s
Comment 4 Dmitry 2012-07-02 15:48:45 MSD
As for now «#dhcpclient eth0» doesn't work ((( I have to restart my computer to enable network...
Comment 5 Aleksandr Kazantcev 2012-07-26 17:00:31 MSD
Try using

 systemctl restart NetworkManager.service
Comment 6 Dmitry 2012-08-09 11:31:32 MSD
There is no problem for a long time => I think this bug may be closed for now
Comment 7 Dmitry 2012-08-20 17:20:52 MSD
(In reply to comment #6)
> There is no problem for a long time => I think this bug may be closed for now

Hmmm... Sometimes problem arises (: but rarely
Comment 8 Dmitry 2013-11-08 11:19:49 MSK
It seems like it is fixed.