Bug 2982 - update-grub2 reports xfs corruption
: update-grub2 reports xfs corruption
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Low minor
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 01:40 MSD by Rolf Pedersen
Modified: 2013-11-02 14:06 MSK (History)
2 users (show)

See Also:
RPM Package: grub2-2.00-29.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
output of inxi -v4 -c6 (1.94 KB, text/plain)
2013-10-25 01:40 MSD, Rolf Pedersen
Details
grub2 reports corruption (638.61 KB, image/jpeg)
2013-10-25 01:45 MSD, Rolf Pedersen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Pedersen 2013-10-25 01:40:03 MSD
Created attachment 2133 [details]
output of inxi -v4 -c6

This is on up-to-date Desktop 2012.1  Attached file shows inxi output for some hardware info at the time the screen picture was taken.  I've since changed video cards but the message is still occurring.

Recently, I've started to see, when I update-grub2 or some package installation calls it, I believe.

The message contains something like:

XFS (sdb4): Corruption detected.  Unmount and run xfs_repair.

I see this for two partitions that are extended partitions.  The rest of many linux partitions on this machine are mostly reiserfs.  Some more discussion is here: http://mib.pianetalinux.org/forum/viewtopic.php?f=53&t=4227&p=23142#p23142

A picture of one screen where I saw this is attached.
Comment 1 Alexander Burmashev 2013-10-25 01:44:25 MSD
since it does not break nothing, priority is set to lowest.
Comment 2 Rolf Pedersen 2013-10-25 01:45:07 MSD
Created attachment 2134 [details]
grub2 reports corruption
Comment 3 Aleksandr Kazantcev 2013-10-25 13:02:26 MSD
Are you install nothin from non-official repo?

I see this error after latest update, but after reboot problem solved.
Comment 4 Aleksandr Kazantcev 2013-10-25 13:02:59 MSD
Are you install nothing from non-official repo?

I see this error after latest update, but after reboot problem solved.
Comment 5 Rolf Pedersen 2013-11-02 14:06:42 MSK
Sorry for a late reply.  I'm not getting email notifications for some reason.

From time to time, I'll try to install something that isn't in --distrib repos or build something.  Just now, I ran 'update-grub2', without any configuration being changed.  I didn't see any error.  In /etc/default/grub, I removed 'nouveau.modeset=1' from the default kernel commands, ran 'grub2-mkconfig', then 'update-grub2'.  I didn't see any error, so I'll change to resolved.
Thanks.