Bug 2968 - ntfs-config error with x32 repo enabled
: ntfs-config error with x32 repo enabled
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 17:48 MSD by Vladimir Potapov
Modified: 2013-10-24 20:37 MSD (History)
2 users (show)

See Also:
RPM Package: urpmi
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2013-10-23 17:48:14 MSD
search_packages: skip ntfs-config-1.1-2-rosa2012.1.x86_64 matching ntfs-config since newer version of the pakcage exists in repositories
search_packages: found ntfs-config-1.1-4-rosa2012.1.x86_64 matching ntfs-config
found package(s): ntfs-config-1.1-2-rosa2012.1.x86_64 ntfs-config-1.1-4-rosa2012.1.x86_64
opening rpmdb (root=, write=)
chosen ntfs-config-1.1-4-rosa2012.1.x86_64 for ntfs-config|ntfs-config
selecting ntfs-config-1.1-4-rosa2012.1.x86_64
requiring gksu,ntfs-3g,pygtk2.0-libglade,python(abi)[== 2.7],usermode for ntfs-config-1.1-4-rosa2012.1.x86_64
not selecting pygtk2.0-libglade-2.24.0-4-rosa2012.1.x86_64 since the more recent pygtk2.0-libglade-2.24.0-4-rosa2012.1.x86_64 is installed
not selecting usermode-1.111-4-rosa2012.1.x86_64 since the more recent usermode-1.111-4-rosa2012.1.x86_64 is installed
not selecting ntfs-3g-2013.1.13-1-rosa2012.1.x86_64 since the more recent ntfs-3g-2013.1.13-1-rosa2012.1.x86_64 is installed
Skipping python-2.7.4-7-rosa2012.1.x86_64 since newer version of the package exists in repositories
no packages match python(abi)[== 2.7] (it is either in skip.list or already rejected)
Skipping python-2.7.3-6-rosa2012.1.x86_64 since newer version of the package exists in repositories
no packages match python (it is either in skip.list or already rejected)
unselecting ntfs-config-1.1-4-rosa2012.1.x86_64
adding a reason to already rejected package ntfs-config-1.1-4-rosa2012.1.x86_64: unsatisfied 5174
Пакеты usermode-1.111-4-rosa2012.1.x86_64, ntfs-3g-2013.1.13-1-rosa2012.1.x86_64, pygtk2.0-libglade-2.24.0-4-rosa2012.1.x86_64 уже установлен
Не удаётся установить запрошенный пакет:
ntfs-config-1.1-4-rosa2012.1.x86_64 (из-за неудовлетворённости python-2.7.3-6-rosa2012.1.x86_64)
Comment 1 Denis Silakov 2013-10-23 22:39:43 MSD
Advisory:
Fixed perl-URPM to take package architecture into account before reporting that "newer package exists in repository".

A typical situation with both 32bit and 64bit repos enabled in the 64bit system is that you add a 32bit container. So you can have foo-2.i586 from container and foo-1.x86-64 from usual repository. If you will try to install 'urpmi foo', it will actually install nothing - first, foo-2 will be rejected since we have 64 bit foo, but foo-1.x86-64 will be rejected since there is a newer foo-2. Moreover, some collisions may arise when resolving dependencies for foo-2 - it seems that the situation described in this bug is from this series.

Build lists:
https://abf.rosalinux.ru/build_lists/1365417
https://abf.rosalinux.ru/build_lists/1365416

How to test:
A recent example is ntfs-config in 64bit system with both 32bit and 64bit repos enabled. Remove ntfs-config if it is installed. Add 32bit container from bug #2952 and try to install 'urpmi ntfs-config'. Expected behavior: urpmi should install 64bit ntfs-config-1.1-4 from usual repositories. If you add 64bit container, urpmi should install ntfs-config-1.1-5 from that container.
Comment 2 Vladimir Potapov 2013-10-24 20:34:53 MSD
perl-URPM-4.43-22-rosa2012.1
******************** Advisory *******************
Fixed perl-URPM to take package architecture into account before reporting that "newer package exists in repository
*************************************************
QA Verified