Bug 2960 - Could not print to canon lbp3010
: Could not print to canon lbp3010
Status: RESOLVED DUPLICATE of bug 3117
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 17:17 MSD by FirstLevel
Modified: 2013-11-15 14:43 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2013-10-21 17:17:27 MSD
Description of problem:
I have installes ROSA 2012 X1 and tried to use my printer canon lbp3010.
I have downloaded and installed vendor drivers (http://www.canon.ru/Support/Consumer_Products/products/printers/Laser/i-SENSYS_LBP3010.aspx?type=download&page=1
Canon CAPT Printer Driver for Linux
CAPT_Printer_Driver_for_Linux_V220_uk_EN.tar.gz 

\CAPT_Printer_Driver_for_Linux_V220_uk_EN.tar\CAPT_Printer_Driver_for_Linux_V220_uk_EN\32-bit_Driver\RPM\cndvcups-capt-2.20-1.i386

\CAPT_Printer_Driver_for_Linux_V220_uk_EN.tar\CAPT_Printer_Driver_for_Linux_V220_uk_EN\32-bit_Driver\RPM\cndrvcups-common-2.20-1.i386)
Printer was installed successfully but if I print - nothing is happened. Print job just hanging. I could not print from any program (kwriter, libreoffice, etc).
I have attached some diagnostic information and lpq command after sending print job.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2013-10-21 17:17:34 MSD
# uname -a
Linux Uchet-kpp 3.0.69-desktop-2rosa.lts #1 SMP Wed Sep 25 13:59:46 MSK 2013 i686 i686 i386 GNU/Linux

# cat /etc/release
ROSA release 2012.0 (LTS) for i586

# cat /etc/cups/printers.conf
# Printer configuration file for CUPS v1.4.8
# Written by cupsd on 2013-10-18 11:58
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<DefaultPrinter Canon-LBP3010-LBP3018-LBP3050>
Info Canon LBP3010/LBP3018/LBP3050
Location Uchet-kpp
MakeModel Canon LBP3010/LBP3018/LBP3050 CAPT (UK)
DeviceURI usb://Canon/LBP3010/LBP3018/LBP3050?serial=0000A291OE6b
State Idle
StateTime 1382083096
Type 8392836
Filter application/vnd.cups-raw 0 -
Filter application/vnd.cups-postscript 0 pstocapt3
Filter application/vnd.cups-command 0 commandtops
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

# lpq
Canon-LBP3010-LBP3018-LBP3050 готов и печатает
Ранг    Владелец   Задание     Файл(ы)                         Общий размер
active  root    9       Test Page                       1024 байт
1st     user    10      Безымянный1           7168 байт
Comment 2 FirstLevel 2013-10-21 17:18:57 MSD
Also some output of rpm command
# rpm -qa | grep cndrv
cndrvcups-capt-2.20-1.i386
cndrvcups-common-2.50-1-rosa.lts2012.0.i586

# rpm -qa | grep capt
cndrvcups-capt-2.20-1.i386
Comment 3 Denis Silakov 2013-10-22 14:22:22 MSD
For Marathon, you can try drivers from ROSA repositories, not upstream.

More particular, you can try cndrvcups-lb or cups-drivers-capt packages.
Comment 4 FirstLevel 2013-10-28 10:19:34 MSK
(In reply to comment #3)
> For Marathon, you can try drivers from ROSA repositories, not upstream.
> 
> More particular, you can try cndrvcups-lb or cups-drivers-capt packages.

User has said that he could not print with these packages too. Should I request some additional information?
Comment 5 Denis Silakov 2013-10-28 19:01:25 MSK
It can also make sense to try the latest version (2.60) from canon site:

http://www.canon-europe.com/Support/Consumer_Products/products/printers/Laser/i-SENSYS_LBP3010.aspx?DLtcmuri=tcm:13-1060371&page=1&type=download

Note that before trying this user should remove all canon-* packages, it is possible that different versions of cndrvcups-capt and cndrvcups-common can lead to conflicts (and in first report, user has cndrvcups-capt-2.20 and cndrvcups-common-2.50).

In general, it seems that this printer is not well supported under Linux:

http://www.openprinting.org/printer/Canon/Canon-LBP-3010
Comment 6 FirstLevel 2013-10-29 14:02:34 MSK
(In reply to comment #5)
> It can also make sense to try the latest version (2.60) from canon site:
> 
> http://www.canon-europe.com/Support/Consumer_Products/products/printers/
> Laser/i-SENSYS_LBP3010.aspx?DLtcmuri=tcm:13-1060371&page=1&type=download
> 
> Note that before trying this user should remove all canon-* packages, it is
> possible that different versions of cndrvcups-capt and cndrvcups-common can
> lead to conflicts (and in first report, user has cndrvcups-capt-2.20 and
> cndrvcups-common-2.50).
> 
> In general, it seems that this printer is not well supported under Linux:
> 
> http://www.openprinting.org/printer/Canon/Canon-LBP-3010

No. User could not print with new drivers. And he has changed the printer to HP (hp works well)
Comment 7 Denis Silakov 2013-11-15 14:43:48 MSK
Symptoms are the same as in bug #3117 and they also seem to be caused by incorrect canon drivers.

But replacing printer with HP is a good solution:)

*** This bug has been marked as a duplicate of bug 3117 ***