Bug 2958 - urpmi --auto-req doesn't perform smart selection
: urpmi --auto-req doesn't perform smart selection
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 2830
  Show dependency treegraph
 
Reported: 2013-10-21 10:44 MSD by Denis Silakov
Modified: 2013-10-22 10:10 MSD (History)
2 users (show)

See Also:
RPM Package: urpmi
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-10-21 10:44:40 MSD
It turned out (see bug #2830) that the new "--auto-req" option in urpmi (enabled by default) chooses the first available alternatives, while usual '--auto' behaves smarter and chooses a package with highest version.
Comment 1 Denis Silakov 2013-10-21 10:49:57 MSD
Advisory:
Improve '--auto-req' option in urpmi to choose a package with highest version (like in case of usual '--auto').

Build lists:
https://abf.rosalinux.ru/build_lists/1362474
https://abf.rosalinux.ru/build_lists/1362473
Comment 2 Vladimir Potapov 2013-10-21 12:14:34 MSD
For x64 system with x32 repos added and new compix repo added:

[root@ROSAx64 keleg]# urpmi compiz
[root@ROSAx64 keleg]#
Comment 3 Denis Silakov 2013-10-21 12:17:26 MSD
Can you provide output of "urpmi --debug compiz"?
Comment 4 Vladimir Potapov 2013-10-21 12:37:44 MSD
search_packages: found compiz-0.9.8.2-3-rosa2012.1.x86_64 matching compiz
found package(s): compiz-0.9.8.2-3-rosa2012.1.x86_64
opening rpmdb (root=, write=)
Skipping compiz-0.9.8.2-3-rosa2012.1.x86_64 since newer version of the package exists in repositories
no packages match compiz (it is either in skip.list or already rejected)
Skipping compiz-0.9.8.2-3-rosa2012.1.x86_64 since newer version of the package exists in repositories
no packages match compiz (it is either in skip.list or already rejected)
scheduled sets of transactions:
unlocking urpmi database
unlocking rpm database
EXITING (pid=6049)
Comment 5 Denis Silakov 2013-10-21 12:42:22 MSD
Hm, maybe you have added containers with 32bit compiz from bug #2830?
Comment 6 Vladimir Potapov 2013-10-21 12:47:29 MSD
Yes! 
But the exit without an error message is bad practice.
Comment 7 Denis Silakov 2013-10-21 12:50:06 MSD
I agree, but unfortunately it is a common practice for current urpmi... Maybe create a separate bug for this and push this particular update?
Comment 8 Vladimir Potapov 2013-10-21 16:19:30 MSD
urpmi-6.71-41-rosa2012.1
******************** Advisory *********************
Improve '--auto-req' option in urpmi to choose a package with highest version (like in case of usual '--auto')
***************************************************
QA Verified