Bug 2896 - After update grub2 in loading window show "Loading initial ramdisk...", instead russian words
: After update grub2 in loading window show "Loading initial ramdisk...", inste...
Status: RESOLVED DUPLICATE of bug 2899
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 01:52 MSD by Postnikov Dmitry
Modified: 2013-10-16 14:58 MSD (History)
1 user (show)

See Also:
RPM Package: microcode_ctl and linux-firmware
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Postnikov Dmitry 2013-10-15 01:52:48 MSD
Description of problem:
After update grub2 in loading widow show "Loading initial ramdisk...", instead russian words. 

Version-Release number of selected component (if applicable):
grub2-2.00-28-rosa2012.1.x86_64
grub2-theme-rosa-2.00-28-rosa2012.1.noarch
Comment 1 Vladimir Testov 2013-10-15 10:27:22 MSD
The locale of the grub2 is dependent on the system locale. So if system locale was "English" than grub2 messages will be in English. You can set needed locale just before grub2 update. Otherwise you can set the locale you want, run "update-grub2". Also you can use Grub Customizer to change grub2 language (Configure your desktop -> startup and shutdown -> grub2 bootloader -> appearance -> Language)

So. You have 3 way to get needed locale in grub2. English words appear because of the English system locale.
Comment 2 Postnikov Dmitry 2013-10-15 10:40:27 MSD
In grub2 at the bottom is written in Russian, English menus. And after the start of boot is also in English.
Comment 3 Vladimir Testov 2013-10-15 11:43:51 MSD
Did you read my previous message?
Comment 4 Vladimir Testov 2013-10-15 11:58:45 MSD
Please, send results of two operations:

locale
env | grep LANGUAGE
Comment 5 Vladimir Testov 2013-10-15 15:41:23 MSD
Bug appears on GNOME version and while using urpmi --auto-update
Comment 6 Vladimir Testov 2013-10-15 16:42:15 MSD
The bug related to packages microcode_ctl and linux-firmware. While they are beeing installed, they call update-grub2 in inappropriate environment.
Comment 7 Vladimir Testov 2013-10-15 16:55:17 MSD
To be precise I'll post detailed information.

 linux-firmware                 20131001     6.gitb8ac7c7e rosa  2012.1 noarch 
 microcode_ctl                  2.1          2             rosa  2012.1 x86_64 


The same goes for kde as well.
Comment 8 Vladimir Testov 2013-10-16 14:57:24 MSD

*** This bug has been marked as a duplicate of bug 2899 ***
Comment 9 Vladimir Testov 2013-10-16 14:58:47 MSD
The problem is solved in 2899.
Still the grub2 locale can broke during the update. If this has happened - run update-grub2 after the update.