Bug 2890 - [UPDATE REQUEST] KDE 4.10.5 -> 4.11.2
: [UPDATE REQUEST] KDE 4.10.5 -> 4.11.2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 13:50 MSD by Andrey Bondrov
Modified: 2013-10-29 13:36 MSK (History)
3 users (show)

See Also:
RPM Package: various
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
left panel localization issue (118.38 KB, image/png)
2013-10-22 15:28 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-10-14 13:50:53 MSD
We plan to switch from KDE 4.10 to 4.11 when 4.11 is mature enough for that (= no critical bugs and major regressions).

Please update from KDE4 backports repository and test KDE 4.11.2: http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/
Comment 2 Postnikov Dmitry 2013-10-20 22:01:32 MSD
****************************
Extended testing report
***************************
Report: http://cdn.2safe.com/185314033760/Postnikov-all(kde4.11.2).odt
Comment 3 Andrey Bondrov 2013-10-21 02:17:42 MSD
(In reply to comment #2)
> ****************************
> Extended testing report
> ***************************
> Report: http://cdn.2safe.com/185314033760/Postnikov-all(kde4.11.2).odt

Looks like there are no regressions in KDE 4.11.2 since 4.10.5. Just many old minor bugs.
Comment 4 Andrey Bondrov 2013-10-21 14:38:25 MSD
I'll just leave it here:

- kamoso
- kphotoalbum

must be rebuilt as soon as KDE 4.11 hits Main/Updates.
Comment 5 Vladimir Potapov 2013-10-22 15:28:43 MSD
Created attachment 2099 [details]
left panel localization issue
Comment 6 Vladimir Potapov 2013-10-22 15:43:33 MSD
The are one major (for me) regression  with rocketBar insert (#27)
Comment 7 Vladimir Potapov 2013-10-22 15:45:04 MSD
(In reply to comment #5)
> Created attachment 2099 [details]
> left panel localization issue
Only for first dolphin run.
Comment 8 Andrey Bondrov 2013-10-22 17:03:55 MSD
(In reply to comment #6)
> The are one major (for me) regression  with rocketBar insert (#27)

It looks ugly indeed but it's not critical. I'd like to fix it but I cannot find yet what causes this issue. :-/
Comment 9 Postnikov Dmitry 2013-10-22 18:10:46 MSD
(In reply to comment #5)
> Created attachment 2099 [details]
> left panel localization issue

It's necessary to watch the localization of Nepomuk. As it appears in Dolphin only when Nepomuk is ON.
Comment 10 Andrey Bondrov 2013-10-22 20:12:52 MSD
(In reply to comment #8)
> (In reply to comment #6)
> > The are one major (for me) regression  with rocketBar insert (#27)
> 
> It looks ugly indeed but it's not critical. I'd like to fix it but I cannot
> find yet what causes this issue. :-/

Ok, I found that it's caused by this commit: http://quickgit.kde.org/?p=kdelibs.git&a=commitdiff&h=8d4f958586ab29bcfa9c70bb919540839c9bd2ac

Perhaps I should just revert it.
Comment 11 Andrey Bondrov 2013-10-23 02:24:48 MSD
(In reply to comment #10)
> (In reply to comment #8)
> > (In reply to comment #6)
> > > The are one major (for me) regression  with rocketBar insert (#27)
> > 
> > It looks ugly indeed but it's not critical. I'd like to fix it but I cannot
> > find yet what causes this issue. :-/
> 
> Ok, I found that it's caused by this commit:
> http://quickgit.kde.org/?p=kdelibs.
> git&a=commitdiff&h=8d4f958586ab29bcfa9c70bb919540839c9bd2ac
> 
> Perhaps I should just revert it.

Done. Please update and test.
Comment 12 Vladimir Potapov 2013-10-23 12:02:28 MSD
Следующие пакеты будут удалены для обновления остальных:
digikam-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit))
kamoso-2.0.2-3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit))
kipi-plugins-acquireimages-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-advancedslideshow-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-batchprocess-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-calendar-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-debianscreenshot-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-dlna-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-dngconverter-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-expoblending-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-facebook-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-flashexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-flickr-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-galleryexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-gpssync-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-htmlexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-imageviewer-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-ipodexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-jalbumexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-jpeglossless-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-kioexportimport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-kmlexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-kopete-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit))
kipi-plugins-metadataedit-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-panorama-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-picasa-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-piwigoexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-printimages-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-rajceexport-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-rawconverter-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-removeredeyes-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-sendimages-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-shwup-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-smug-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-timeadjust-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-videoslideshow-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-vkontakte-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
kipi-plugins-yandexfotki-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit),
  из-за отсутствия libkipiplugins.so.3()(64bit))
lib64digikamcore3-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkgeomap.so.1()(64bit))
lib64digikamdatabase3-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libdigikamcore.so.3()(64bit))
lib64kgeomap1-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libmarblewidget.so.15()(64bit))
lib64kipiplugins3-3.5.0-1.3-rosa2012.1.x86_64
 (из-за отсутствия libkipi.so.10()(64bit))
Comment 13 Andrey Bondrov 2013-10-23 12:39:24 MSD
(In reply to comment #12)
> Следующие пакеты будут удалены для обновления остальных:
> digikam-3.5.0-1.3-rosa2012.1.x86_64
>  (из-за отсутствия libkipi.so.10()(64bit))

That's bad. Looks like this happened due to ABF publishing issues during last week. I'll rebuild Digikam now for x86_64.
Comment 14 Andrey Bondrov 2013-10-23 15:04:17 MSD
(In reply to comment #13)
> (In reply to comment #12)
> > Следующие пакеты будут удалены для обновления остальных:
> > digikam-3.5.0-1.3-rosa2012.1.x86_64
> >  (из-за отсутствия libkipi.so.10()(64bit))
> 
> That's bad. Looks like this happened due to ABF publishing issues during
> last week. I'll rebuild Digikam now for x86_64.

Done. Please try again.
Comment 15 Andrey Bondrov 2013-10-23 15:54:15 MSD
BTW, it's better to have 4.11.2 approved until Friday because it's better to push it to Main Updates on weekends, when ABF is not overloaded by other tasks.
Comment 16 Vladimir Potapov 2013-10-24 10:43:12 MSD
Следующие пакеты будут удалены для обновления остальных:
kdeartwork4-kscreensaver-4.10.5-1-rosa2012.1.i586
 (из-за отсутствия libkexiv2.so.11)
kdegraphics-thumbnailers-4.10.5-1-rosa2012.1.i586
 (из-за отсутствия libkexiv2.so.11)
libkexiv2_11-4.10.5-1-rosa2012.1.i586
 (из-за неудовлетворённости libkexiv2 == 2:4.10.5-1:2012.1)
Comment 17 Andrey Bondrov 2013-10-24 11:06:57 MSD
(In reply to comment #16)
> Следующие пакеты будут удалены для обновления остальных:
> kdeartwork4-kscreensaver-4.10.5-1-rosa2012.1.i586
>  (из-за отсутствия libkexiv2.so.11)
> kdegraphics-thumbnailers-4.10.5-1-rosa2012.1.i586
>  (из-за отсутствия libkexiv2.so.11)
> libkexiv2_11-4.10.5-1-rosa2012.1.i586
>  (из-за неудовлетворённости libkexiv2 == 2:4.10.5-1:2012.1)

Are you sure you have 32 bit system? Or you have 64 bit system with some old 32 bit KDE packages installed?
Comment 18 Vladimir Potapov 2013-10-24 11:19:25 MSD
32 bit system
Comment 19 Andrey Bondrov 2013-10-24 11:25:52 MSD
(In reply to comment #18)
> 32 bit system

I don't confirm this issue, updated some 32 bit systems recently and everything was smooth.

And I see packages in KDE Backports repository:

http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/i586/main/release/libkexiv2-4.11.2-1-rosa2012.1.i586.rpm

http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/i586/main/release/libkexiv2_11-4.11.2-1-rosa2012.1.i586.rpm

So unless metadata got corrupted today, there should be no issues with libkexiv2-4.11.2.
Comment 20 Vladimir Potapov 2013-10-24 15:03:38 MSD
Ok, KDE 4.11.2
********************
QA Verified