Bug 2889 - [UPDATE REQUEST] gdm
: [UPDATE REQUEST] gdm
Status: RESOLVED DUPLICATE of bug 3099
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 13:02 MSD by Arkady L. Shane
Modified: 2013-11-08 23:33 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments
gdm1.png (219.29 KB, image/png)
2013-10-23 19:07 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arkady L. Shane 2013-10-14 13:02:36 MSD
Advisory:

# Fix freeze while booting on some systems
# added ROSA logo to the login screen

Buildlists:
https://abf.rosalinux.ru/build_lists/1346758
https://abf.rosalinux.ru/build_lists/1346759
Comment 1 Postnikov Dmitry 2013-10-14 23:07:20 MSD
Works perfectly gdm on two computers.  	
smartly boot has become. Logo Rosa liked. Only it's unnecessary (IMHO).
Comment 2 Vladimir Potapov 2013-10-21 17:20:14 MSD
The update route to extended testing
Comment 3 Postnikov Dmitry 2013-10-23 19:03:09 MSD
*****************************
Extended testing report
****************************
1. gdm have DOUBLED menu for classic mod:
-- GNOME
-- GNOME Classic
-- Классический GNOME
-- GNOME fallback

2. If to start the second user, and try to log in, you will constantly error "Not correctly entered the password".
Comment 4 Postnikov Dmitry 2013-10-23 19:07:35 MSD
Created attachment 2107 [details]
gdm1.png
Comment 5 Arkady L. Shane 2013-10-23 19:19:09 MSD
If to start the second user - А как понимать эту фразу?
Comment 6 Postnikov Dmitry 2013-10-23 19:22:36 MSD
(In reply to comment #5)
> If to start the second user - А как понимать эту фразу?

Заводим второго пользователя. Перелогиниваемся. Пытаемся ввести пароль ПРАВИЛЬНЫЙ. А gdm ругается что пароль не правильный.
Comment 7 Arkady L. Shane 2013-10-23 19:45:00 MSD
Ok. Всё с чистого листа и на великом могучем.

Новый GDM.

https://abf.rosalinux.ru/build_lists/1365461
https://abf.rosalinux.ru/build_lists/1365460

Там удалена генерация дополнительных файлов в /etc/X11/dm/Sessions и сам каталог /etc/X11/dm должен удаляться. Он больше не нужен gdm'у. Всё должно читаться из /usr/share/xsessions.

Новый gnome-session.

https://abf.rosalinux.ru/build_lists/1365443
https://abf.rosalinux.ru/build_lists/1365444

Там добавлена сессия в /usr/share/xsessions


Обновлять нужно 2 пакета сразу иначе либо будет на одну сессию больше, либо сессия GNOME исчезнет:)
Comment 8 Postnikov Dmitry 2013-10-23 20:17:29 MSD
(In reply to comment #7)
> Ok. Всё с чистого листа и на великом могучем.
> 
> Новый GDM.
> 
> https://abf.rosalinux.ru/build_lists/1365461
> https://abf.rosalinux.ru/build_lists/1365460
> 
> Там удалена генерация дополнительных файлов в /etc/X11/dm/Sessions и сам
> каталог /etc/X11/dm должен удаляться. Он больше не нужен gdm'у. Всё должно
> читаться из /usr/share/xsessions.
> 
> Новый gnome-session.
> 
> https://abf.rosalinux.ru/build_lists/1365443
> https://abf.rosalinux.ru/build_lists/1365444
> 
> Там добавлена сессия в /usr/share/xsessions
> 
> 
> Обновлять нужно 2 пакета сразу иначе либо будет на одну сессию больше, либо
> сессия GNOME исчезнет:)

1. В gdm теперь еще больше пунктов:
-- GNOME
-- GNOME classic
-- GNOME
-- Классический GNOME
-- GNOME fallback

2. Куча ошибок gnome-session идет при каждом действии в системе

========================
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!   Invalid work id 7
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     message = '"Invalid work id 7"'
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     lineNumber = '787'
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     stack = '"queueDeferredWork("7")@/usr/share/gnome-shell/js/ui/main.js:787
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!   Invalid work id 8
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     message = '"Invalid work id 8"'
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     lineNumber = '787'
Oct 23 20:14:41 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     stack = '"queueDeferredWork("8")@/usr/share/gnome-shell/js/ui/main.js:787
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!   Invalid work id 7
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     message = '"Invalid work id 7"'
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     lineNumber = '787'
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     stack = '"queueDeferredWork("7")@/usr/share/gnome-shell/js/ui/main.js:787
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!   Invalid work id 8
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     message = '"Invalid work id 8"'
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     lineNumber = '787'
Oct 23 20:14:42 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     stack = '"queueDeferredWork("8")@/usr/share/gnome-shell/js/ui/main.js:787
Oct 23 20:15:25 mindlife2-efi-gnome gnome-session[5472]: (process:7500): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!   Invalid work id 7
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     message = '"Invalid work id 7"'
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     lineNumber = '787'
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     stack = '"queueDeferredWork("7")@/usr/share/gnome-shell/js/ui/main.js:787
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!   Invalid work id 8
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     message = '"Invalid work id 8"'
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/main.js"'
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     lineNumber = '787'
Oct 23 20:15:26 mindlife2-efi-gnome gnome-session[5472]: JS ERROR: !!!     stack = '"queueDeferredWork("8")@/usr/share/gnome-shell/js/ui/main.js:787
[root@mindlife2-efi-gnome pastordi]# 
=======================
Comment 9 Vladimir Potapov 2013-10-24 03:38:26 MSD
I close the bug. After fix the bug reopen it.
Comment 10 Aleksandr Kazantcev 2013-11-08 23:33:17 MSK

*** This bug has been marked as a duplicate of bug 3099 ***