Bug 2860 - emacs24 update
: emacs24 update
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 16:54 MSD by ra oeai
Modified: 2013-12-16 11:21 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
install error (313.94 KB, image/png)
2013-10-18 13:47 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ra oeai 2013-10-12 16:54:10 MSD
24.3 version is stable 
http://www.gnu.org/software/emacs/

+color-theme support package for emacs23
http://www.nongnu.org/color-theme/#sec7

+bug:
emacs-cedet - cannot be installed without any explanation
Comment 1 Denis Silakov 2013-10-14 16:08:18 MSD
(In reply to comment #0)
> +bug:
> emacs-cedet - cannot be installed without any explanation

The thing is that cedet is included in emacs-common which is likely already installed in your system.

There is no need in separate cedet package in ROSA, I think we can safely drop it.
Comment 2 Denis Silakov 2013-10-14 16:28:56 MSD
As for emacs update, we should update giflib first - new emacs doesn't want to compile with giflib4. But new giflib has significant ABI changes and has a new major number in its soname. So we should either rebuild all packages that depend on giflib with the new version or carefully package two versions in parallel.
Comment 3 ra oeai 2013-10-14 20:46:45 MSD
well i've made it --with-gif=no
got it in abf/oeai well it works and there are color-themes
that's just an issue for me i can't work with with background
and since it's using gtk i think it's mainly takes gtk-colors as well
Comment 4 Denis Silakov 2013-10-16 14:29:40 MSD
Ok, I have successfully built new emacs with current libgif.

Advisory:
Updated Emacs to version 24.3 with a lot of changes and new features - see http://www.gnu.org/software/emacs/news/NEWS.24.3 for details.

Build lists:
https://abf.rosalinux.ru/build_lists/1354555
https://abf.rosalinux.ru/build_lists/1354554
Comment 5 ra oeai 2013-10-17 17:47:47 MSD
nice 
thanks
Comment 6 Vladimir Potapov 2013-10-18 13:47:07 MSD
Created attachment 2070 [details]
install error
Comment 7 Denis Silakov 2013-10-18 14:38:46 MSD
Hm, is this regression? If I remember correctly, we always had emacs conflicting with xemacs; can you try to install old emacs (from official repos)?

Note that xorg-x11 is a meta-package. You can safely uninstall xorg-x11, x11-apps and other packages from your screenshot, this won't break the system.
Comment 8 Denis Silakov 2013-10-18 16:14:38 MSD
On the other hand, I think there is a way to avoid installation of xemacs for xorg-x11. xedit actually requires ctags, not the whole xemacs, and we have a separate ctags package. Let's try to force urpmi to select ctags package itself instead of xemacs.

Please try to use these containers:

(emacs)
https://abf.rosalinux.ru/build_lists/1354555
https://abf.rosalinux.ru/build_lists/1354554

(ctags)
https://abf.rosalinux.ru/build_lists/1361298
https://abf.rosalinux.ru/build_lists/1361299
Comment 9 Vladimir Potapov 2013-10-18 17:22:48 MSD
1 установочных транзакций не удались

Во время установки возникла ошибка:

файл /usr/share/info/cl.info.xz из устанавливаемого пакета emacs-common-24.3-2.i586 конфликтует с файлом из пакета xemacs-21.4.22-9.i586

файл /usr/share/info/widget.info.xz из устанавливаемого пакета emacs-common-24.3-2.i586 конфликтует с файлом из пакета xemacs-21.4.22-9.i586


The bug only for i586. X64 - ok.
Comment 10 Vladimir Potapov 2013-10-18 17:36:43 MSD
http://bugs.rosalinux.ru/show_bug.cgi?id=2948
Comment 11 Vladimir Potapov 2013-10-18 17:38:39 MSD
I don't correct check the update while not fix #2948
*****************
QA Denied
Comment 12 Denis Silakov 2013-12-04 16:26:34 MSK
Ok, in R2 images neither emacs nor xemacs are installed by default. In addition, I have added explicit conflict with xemacs for emacs package.

Advisory:
Updated Emacs to version 24.3 with a lot of changes and new features - see http://www.gnu.org/software/emacs/news/NEWS.24.3 for details.

(emacs)
https://abf.rosalinux.ru/build_lists/1456038
https://abf.rosalinux.ru/build_lists/1456037

(ctags)
https://abf.rosalinux.ru/build_lists/1361298
https://abf.rosalinux.ru/build_lists/1361299
Comment 13 Vladimir Potapov 2013-12-06 13:00:26 MSK
emacs-24.3-3
ctags-5.8-6
******************************* Advisory *************************
Updated Emacs to version 24.3 with a lot of changes and new features
******************************************************************
QA Verified