Bug 279 - Full-size pictures open very slooooooow on wiki
: Full-size pictures open very slooooooow on wiki
Status: RESOLVED FIXED
Product: Websites
Classification: ROSA Infrastructure
Component: Wiki
: unspecified
: All Linux
: Normal enhancement
: ---
Assigned To: Stanislav Fomin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 16:40 MSD by JDronova
Modified: 2013-07-09 15:55 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
where the link to /pool/ wiki resides (88.52 KB, image/png)
2012-06-04 18:53 MSD, Pavel Shved
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JDronova 2012-05-24 16:40:41 MSD
Full-size pictures open very slooooooow on wiki
Steps:
Open any page with small resized illustration
Click on it
The big picture opens very slow.
Comment 1 Pavel Shved 2012-05-24 16:44:25 MSD
How often is it reproduced?
Comment 2 Postnikov Dmitry 2012-05-24 16:46:16 MSD
Constantly. It all started with the transition to the new version of the wiki.
Comment 3 Pavel Shved 2012-05-24 16:49:06 MSD
Hmm... say, when I made the wiki multilingual, right?

Then the hypothesys would be that Apache had been serving images directly from disk, and now it fails to do so because URLs changed.

Could you please provide a sample picture so I can benchmark it?
Comment 5 Pavel Shved 2012-05-24 18:19:45 MSD
No, it's not Apache.  The image itself is stored on disk, and is loaded at once.  It's the wiki engine what slows down by some reason.
Comment 6 Pavel Shved 2012-05-24 18:20:32 MSD
I'll try to figure what's wrong with it, and, if I find nothing, I'll ask Vladimir to check it from his perspective.
Comment 7 Postnikov Dmitry 2012-06-01 16:21:58 MSD
Please. You can spend more time on this bug? And then the wiki is not convenient to work, much time is spent.
Comment 8 rugyada 2012-06-04 10:50:20 MSD
Please fix, if possible
Thank you.
Comment 9 Pavel Shved 2012-06-04 12:15:10 MSD
Ok, will try to spend some time on it today.
Comment 10 Pavel Shved 2012-06-04 15:20:56 MSD
So far I found out that links from "en" and "ru" wiki to images are slow (takes 20 seconds to load) while links from "pool" wiki (that accumulates all pictures) are fast.

Compare:
http://wiki.rosalab.ru/en/index.php/File:Hpd-1.png  (takes 20 sec)
http://wiki.rosalab.ru/pool/index.php/File:Hpd-1.png (takes <1 sec)

Maybe, a simple redirect could solve the problem?  Please, could you check please if you specifically need the /en/ or /ru/ page and can't do something from the /pool/ page of an image?

(Note: the /pool/ page can be accessed from the "en" or "ru" page via a link below the image, where something about "shared repository" is said).
Comment 11 JDronova 2012-06-04 17:12:06 MSD
(In reply to comment #10)
> below the image, where something about "shared repository" is said).
Sorry, I don't see it :(
Comment 12 Pavel Shved 2012-06-04 18:53:58 MSD
Created attachment 226 [details]
where the link to /pool/ wiki resides

This screenshot explains where to find the link to /pool/ wiki from the regular File: page at a "generic" wiki.
Comment 13 Pavel Shved 2012-06-14 18:30:57 MSD
Ok, since there was no feedback, I assume that the /en/, and /pool/ pages are the same.

Vladimir, may I ask you to set up redirects on wiki.rosalab.ru from

http://wiki.rosalab.ru/en/index.php/File:***
and
http://wiki.rosalab.ru/ru/index.php/%D0%A4%D0%B0%D0%B9%D0%BB:***

to

http://wiki.rosalab.ru/pool/index.php/File:***
Comment 14 rugyada 2012-06-14 18:47:56 MSD
(In reply to comment #13)
(In reply to comment #10)
> Ok, since there was no feedback, I assume that the /en/, and /pool/ pages
> are the same.
> 

All what I can say, is to confirm the different behaviour, opening full images either from http://wiki.rosalab.ru/en (slow) or from http://wiki.rosalab.ru/pool (fast)
But don't know how to fix.
Unfortunately, I can't be of some help, here.
Comment 15 Pavel Shved 2012-06-14 18:57:00 MSD
(In reply to comment #14)
> (In reply to comment #13)
> (In reply to comment #10)
> > Ok, since there was no feedback, I assume that the /en/, and /pool/ pages
> > are the same.
> > 
> 
> All what I can say, is to confirm the different behaviour, opening full
> images either from http://wiki.rosalab.ru/en (slow) or from
> http://wiki.rosalab.ru/pool (fast)
> But don't know how to fix.
> Unfortunately, I can't be of some help, here.

If the opening speed is the only difference (is it?), then our system administrator can just set up a redirect from the slower page to the faster in the underlying HTTP server, which will "solve" the problem.

By the way, I forgot to specify the Italian redirect:

http://wiki.rosalab.ru/it/index.php/File:***
Comment 16 Pavel Shved 2012-06-22 16:29:13 MSD
The issue is resolved now.

During the processing of file pages, the "language-specific" wiki requested file description from the /pool/ wiki, and the request did not resolve to the host where the wiki was actually located.  The wiki waited until the request times out, which took 20 seconds, and only then rendered the picture page.  Please, verify if it works well now.

Thanks to Vladimir for collaboration!
Comment 17 rugyada 2012-06-22 16:36:02 MSD
(In reply to comment #16)
> The issue is resolved now.
> 
> During the processing of file pages, the "language-specific" wiki requested
> file description from the /pool/ wiki, and the request did not resolve to
> the host where the wiki was actually located.  The wiki waited until the
> request times out, which took 20 seconds, and only then rendered the picture
> page.  Please, verify if it works well now.
> 
> Thanks to Vladimir for collaboration!

Yes, now it seems ok!
Thank you.
Comment 18 Postnikov Dmitry 2012-10-16 16:49:30 MSD
Again the same thing. In Russian part Wiki.
Error 504 - Time out. And all the pages with pictures open normally.
Comment 19 Stanislav Fomin 2013-07-08 16:23:26 MSD
I has upgrade MediaWiki installation.

Now I checked 
links (such as http://wiki.rosalab.ru/ru/index.php/%D0%9A%D0%B0%D0%BA_%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%B0%D1%82%D1%8C_%D1%81_helpdesk )
and can not see these problems.

Also all images in all pages can be "slideshowed" — and I do not see any time  lags.

So, please, check the bug, do you see any problems?
Comment 20 JDronova 2013-07-09 14:08:37 MSD
It's OK now, works for me. Thank you!