Bug 2755 - rpmdrake should compare package versions in '--auto' mode
: rpmdrake should compare package versions in '--auto' mode
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 2723
  Show dependency treegraph
 
Reported: 2013-10-09 11:19 MSD by Denis Silakov
Modified: 2013-10-10 11:32 MSD (History)
2 users (show)

See Also:
RPM Package: rpmdrake
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-10-09 11:19:10 MSD
When working on bug #2723 we discovered that rpmdrake sometimes incorrectly chooses dependencies by itself (if 'select dependencies automatically' option is enabled), while 'urpmi --auto'. The thing is that rpmdrake has its own code for such dependency resolution, so we should port improvements from urpmi to rpmdrake.
Comment 1 Denis Silakov 2013-10-09 11:20:17 MSD
Advisory:

Rpmdrake was patched to choose packages with highest versions when selecting dependencies automatically.

Build lists:
https://abf.rosalinux.ru/build_lists/1340276
https://abf.rosalinux.ru/build_lists/1340277
Comment 2 Vladimir Potapov 2013-10-09 17:36:06 MSD
rpmdrake-5.26.12-32-rosa2012.1
********************* Advisory **********************
Rpmdrake was patched to choose packages with highest versions when selecting dependencies automatically.
*****************************************************
QA Verified