Bug 2750 - freeradius-web is not compatible with Apache 2.4
: freeradius-web is not compatible with Apache 2.4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 13:20 MSD by Denis Silakov
Modified: 2014-10-01 11:34 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-10-08 13:20:22 MSD
Currently if you install freeradius-web package, apache fails to restart ("sytemctl restart httpd" fails).
Comment 1 Denis Silakov 2013-10-08 13:20:33 MSD
Advisory:
Adapted freeradius-web for Apache 2.4

Build lists:
https://abf.rosalinux.ru/build_lists/1339822
https://abf.rosalinux.ru/build_lists/1339821
Comment 2 Alexander Petryakov 2013-10-13 21:18:51 MSD
Php not work
i guess  freeradius-web.conf should contain 
AddType application/x-httpd-php .php

cat /etc/httpd/conf/webapps.d/freeradius-web.conf 
# freeradius Apache configuration
Alias /freeradius-web /usr/share/freeradius-web

<Directory /usr/share/freeradius-web>
    Require all granted
    AddType application/x-httpd-php .php 
</Directory>
Comment 3 Denis Silakov 2014-10-01 11:34:24 MSD
The reason is that freeraius-web in its current shape is not compatible with php 5.4.x - I created a separate bug #4468 for this.

As for this particular bug, its purpose was to fix freeradius configs to be compatible with moder Apache. This was done successfully, so closing the bug.