Bug 2747 - [UPDATE REQUEST] x11-driver-input-evdev and x11-driver-input-synaptic
: [UPDATE REQUEST] x11-driver-input-evdev and x11-driver-input-synaptic
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 08:28 MSD by Aleksandr Kazantcev
Modified: 2013-10-21 12:21 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-10-08 08:28:50 MSD
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Aleksandr Kazantcev 2013-10-08 08:36:58 MSD
x11-driver-input-evdev
https://abf.rosalinux.ru/build_lists/1339425
https://abf.rosalinux.ru/build_lists/1339426

x11-driver-input-synaptic
https://abf.rosalinux.ru/build_lists/1339449
https://abf.rosalinux.ru/build_lists/1339450

Advisory: This update for input subsystem of X-server provide new version of evdev and synaptic package - 2.8.1 and 1.7.1. Common fixes and features are:

- Two fixes, one for a set of MT devices without legacy axes, one for a misconfiguration (inertia of 0 should be no inertia).
- soft button areas may overlap on the edge, so a configuration of e.g.middle button 33%-66% and right button 66%-0 is now valid.
- fixing a stack smash caused by the Apple Magic Trackpad
- full changlog fo 1.7 branch of synaptic (http://www.spinics.net/lists/xorg/msg55259.html)
- use upstream config file for synaptic
Comment 2 Vladimir Potapov 2013-10-11 16:52:33 MSD
The update route to extended testing
Comment 3 Aleksandr Kazantcev 2013-10-14 23:53:43 MSD
Please install new fixed version of evdev - 2.8.2 instead 2.8.1

https://abf.rosalinux.ru/build_lists/1352804
https://abf.rosalinux.ru/build_lists/1352801
Comment 4 Aleksandr Kazantcev 2013-10-15 22:01:48 MSD
As we found solution for non-working touchpads, please install and test new packages - libevdev and x11-driver-input-evdev builded with this library:

libevdev

https://abf.rosalinux.ru/build_lists/1353400
https://abf.rosalinux.ru/build_lists/1353393

x11-driver-input-evdev

https://abf.rosalinux.ru/build_lists/1353413
https://abf.rosalinux.ru/build_lists/1353414
Comment 5 Postnikov Dmitry 2013-10-16 12:21:23 MSD
(In reply to comment #4)
> As we found solution for non-working touchpads, please install and test new
> packages - libevdev and x11-driver-input-evdev builded with this library:
> 
> libevdev
> 
> https://abf.rosalinux.ru/build_lists/1353400
> https://abf.rosalinux.ru/build_lists/1353393
> 
> x11-driver-input-evdev
> 
> https://abf.rosalinux.ru/build_lists/1353413
> https://abf.rosalinux.ru/build_lists/1353414

(In reply to comment #1)
> x11-driver-input-synaptic
> https://abf.rosalinux.ru/build_lists/1339449
> https://abf.rosalinux.ru/build_lists/1339450
> 

**************************
Extended testing report
*************************
Now all works on 5 computers without problems.
(KDE 32/64 & Gnome 64)
Comment 6 Vladimir Potapov 2013-10-16 14:34:47 MSD
libevdev1-0.4-1-rosa2012.1
x11-driver-input-evdev-2.8.2-2-rosa2012.1
x11-driver-input-synaptics-1.7.1-1-rosa2012.1
******************** Advisory ***********************
This update for input subsystem of X-server provide new version of evdev and synaptic package - 2.8.1 and 1.7.1. 
*********************** changelog *******************
- Two fixes, one for a set of MT devices without legacy axes, one for a misconfiguration (inertia of 0 should be no inertia).
- soft button areas may overlap on the edge, so a configuration of e.g.middle button 33%-66% and right button 66%-0 is now valid.
- fixing a stack smash caused by the Apple Magic Trackpad
- full changlog fo 1.7 branch of synaptic (http://www.spinics.net/lists/xorg/msg55259.html)
- use upstream config file for synaptic
******************************************************
QA Verified