Bug 2739 - dotproject broken dependencies (since apache 2.4)
: dotproject broken dependencies (since apache 2.4)
Status: RESOLVED FIXED
Product: Server Bugs
Classification: ROSA Server
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: Andrew Lukoshko
: ROSA Server Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 22:01 MSD by Egor Kochetoff
Modified: 2013-10-08 16:43 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Kochetoff 2013-10-03 22:01:43 MSD
After I install dotproject and run `apachctl start`, I get:

# apachectl restart
AH00526: Syntax error on line 77 of /etc/httpd/conf/extra/httpd-ssl.conf:
SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?).

After I install `mod_socache_shmcb`, the problem is solved. Either default config file for dokuwiki should be changed, or mod_socache_shmcb should be listed in its dependencies.

The reason is stated here: http://httpd.apache.org/docs/2.4/upgrading.html#comments_section

# cat /etc/issue
ROSA Desktop Fresh R1 release 2012.1 for x86_64
Kernel 3.10.9-nrj-desktop-1rosa on a 4-processor x86_64 / \l
# uname -rp
3.10.9-nrj-desktop-1rosa x86_64
Comment 1 Egor Kochetoff 2013-10-03 22:03:28 MSD
Sorry, copypaste is evil. Solution proposal should read:

Either default config file for **dotproject** should be changed, or mod_socache_shmcb should be listed in its dependencies.
Comment 2 Egor Kochetoff 2013-10-03 23:14:11 MSD
fixed it, added pull request.

Cannot paste a working direct link to the pull request here, since this link generates 404 error x_x

https://abf.rosalinux.ru/openmandriva/dotproject/blob/95875c6f9bcd699e31946c86c3e4bf6457eac19e/dotproject.spec
Comment 3 Denis Silakov 2013-10-08 16:43:33 MSD
Thanks, dotproject has been rebuilt.