Bug 2738 - dokuwiki broken dependencies
: dokuwiki broken dependencies
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: 2012 Desktop Final
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 21:37 MSD by Egor Kochetoff
Modified: 2013-10-08 16:42 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Kochetoff 2013-10-03 21:37:17 MSD
After I install dokuwiki and run `apachctl start`, I get:

# apachectl restart
AH00526: Syntax error on line 77 of /etc/httpd/conf/extra/httpd-ssl.conf:
SSLSessionCache: 'shmcb' session cache not supported (known names: ). Maybe you need to load the appropriate socache module (mod_socache_shmcb?).

After I install `mod_socache_shmcb`, the problem is solved. Either default config file for dokuwiki should be changed, or mod_socache_shmcb should be listed in its dependencies.

# cat /etc/issue
ROSA Desktop Fresh R1 release 2012.1 for x86_64
Kernel 3.10.9-nrj-desktop-1rosa on a 4-processor x86_64 / \l
# uname -rp
3.10.9-nrj-desktop-1rosa x86_64
Comment 1 Egor Kochetoff 2013-10-03 23:19:24 MSD
Submitted a pull request
Comment 2 Alexander Burmashev 2013-10-04 02:19:17 MSD
Thanks a lot, but as far as i can see, you submitted a pull request to project in openmandriva group. In ROSA we generally use "import". Was that on purpose, or you just do not have sufficient access to import group ( in such case we can easily "fix" it :) ) ?
Comment 3 Egor Kochetoff 2013-10-04 10:48:05 MSD
I just did not know that I should use «import» :)
I found that in openmandriva this package was the most up-to-date and modified it there. Is it possible to automatically update version in the import group to the latest that is in openmandriva and then fork it?
Comment 4 Denis Silakov 2013-10-04 11:43:22 MSD
It's not a problem, I backport all changes made by Egor from omv to import.
Comment 5 Denis Silakov 2013-10-08 16:42:25 MSD
Dokuwiki package has been rebuilt.