Bug 273 - Filters in KMail do not work by default
: Filters in KMail do not work by default
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 23:00 MSD by Pavel Shved
Modified: 2014-06-09 08:36 MSD (History)
4 users (show)

See Also:
RPM Package: kdepim4
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Shved 2012-05-23 23:00:41 MSD
Description of problem:

I installed KMail, added some mail filters, but they did not work.

To make filters work, I had to install akonadi-mailfilter-agent package via rpmdrake.  After that, I restarted my PC (actually, I killed Akonadi services), and kmail filters started to work.

Version-Release number of selected component (if applicable):

kdepim4-4.8.2-2.src.rpm

Steps to Reproduce:
1. Get a clean ISO, install kmail only.
2. Set up a mail account, and try to use a mail filter.
3. See that it doesn't work even if you apply manual filtering with Ctrl+J.
Comment 1 Pavel Shved 2012-05-23 23:01:46 MSD
A fix would be obvious: add this filter package as a Requires for the kmail package.  I wanted to try to create a fixed package, but could not find the ABF project to clone. :-(
Comment 2 Aleksandr Kazantcev 2012-05-23 23:07:30 MSD
tigro/kdepim4
Comment 3 Alexander Burmashev 2012-05-23 23:09:06 MSD
I added the fix to the current kdepim.
The project that had to be fixed is
https://abf.rosalinux.ru/tigro/kdepim4
If your user on ABF is not in import group there is fair chance that you will not be able to access it.

Please note that the latest version of KDE is 4.8.3, so i applied this small fix to it. And this means that this kdepim fix will be available to all users only after KDE 4.8.3 is checked and verified by QA, which may take some time.
Comment 4 Pavel Shved 2012-05-23 23:25:15 MSD
The project didn't contain the rosa2012lts branch, so I thought it's not the production project...

It doesn't build anyway.  Marking as in-progress.
Comment 5 Alexander Burmashev 2012-05-23 23:28:43 MSD
Some comments in order to have all this written in one more place
1) Kdepim ( and the whole kde stack ) indeed does not have rosa2012lts branch - 
this will be "fixed" ( actually all changes will be moved to import/package/rosa2012lts ) after the KDE 4.8.3 approval and publishing.

2) It does not built because there is no kde 4.8.3 libs and etc in the main repo, i press new built absolutely automatically
Comment 6 Pavel Shved 2012-05-23 23:33:45 MSD
uh oh
sorry
I just can't get all these quirks into my head...
Comment 7 Alexander Burmashev 2012-05-23 23:36:59 MSD
That was just some flood from me and i am sorry for that =)
Fix is in the git, it will hit the repo soon ( not today ).
Comment 8 Denis Silakov 2012-06-27 11:02:25 MSD
It seems that the issue is still in place and akonadi-mailfilter-agent is not included in kmail dependencies...
Comment 9 Alexander Burmashev 2012-06-27 13:25:53 MSD
This "fix" ( one string in the spec file ) is applied to the kdepim package, which is the part of the KDE stack. When KDE stack will be updated, the fix will hit the repo.
Comment 10 FirstLevel 2014-06-09 08:36:45 MSD
I have LTS with actual updates.
[sergei@ltsx32 ~]$ rpm -qa | grep kdebase4
kdebase4-runtime-4.8.3-3-rosa.lts2012.0.i586
kdebase4-workspace-4.8.3-4-rosa.lts2012.0.i586

All required packages are presented.
[sergei@ltsx32 ~]$ rpm -qa | grep kdepim
kdepimlibs4-core-4.8.3-1-rosa.lts2012.0.i586
libkdepim-copy4-4.8.3-1-rosa.lts2012.0.i586
libkdepim4-4.8.3-3-rosa.lts2012.0.i586
kdepim4-core-4.8.3-3-rosa.lts2012.0.i586
libkdepimdbusinterfaces4-4.8.3-3-rosa.lts2012.0.i586
kdepim4-kresources-4.8.3-3-rosa.lts2012.0.i586
[sergei@ltsx32 ~]$ rpm -qa | grep mailfilter
akonadi-mailfilter-agent-4.8.3-3-rosa.lts2012.0.i586

I think bug is solved