Bug 2728 - 3.10 Kernel loading problem
: 3.10 Kernel loading problem
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 12:11 MSD by Dmitry
Modified: 2013-10-07 12:06 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
lspci output (7.51 KB, text/plain)
2013-10-01 12:13 MSD, Dmitry
Details
mei_me problem kernel at startup (134.85 KB, image/jpeg)
2013-10-01 12:48 MSD, Dmitry
Details
Loading freezes (436.66 KB, image/jpeg)
2013-10-01 13:56 MSD, Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2013-10-01 12:11:17 MSD
Description of problem:

3.10.9 kernel doesn't work. After suspend I can't boot my system. At the same time 3.8 works fine. I'll investigate problem and provide more info later.
Comment 1 Dmitry 2013-10-01 12:12:36 MSD
$ uname -a
Linux work 3.8.12-nrj-desktop-2rosa #1 SMP PREEMPT Thu May 16 21:53:13 MSK 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 2 Dmitry 2013-10-01 12:13:52 MSD
Created attachment 1941 [details]
lspci output
Comment 3 Dmitry 2013-10-01 12:48:00 MSD
Created attachment 1942 [details]
mei_me problem kernel at startup

For 3.10 kernel there is mei_me problem at startup. It delays loading of systemd, but maybe it freezes loading during systemd stage. For 3.8 kernel there is no such mei_me problem.
Comment 4 Alexander Burmashev 2013-10-01 12:50:12 MSD
This problem is known and fixed in all kernels, starting from 3.10.10.
We expect 3.10.14 to be pushed to official repo as soon as it is released.
To fix this issue immediately you can install any kernel >= 3.10.10 from this repo
http://abf-downloads.rosalinux.ru/kernels_3_10x_personal/repository/rosa2012.1/i586/main/release/
http://abf-downloads.rosalinux.ru/kernels_3_10x_personal/repository/rosa2012.1/x86_64/main/release/
Comment 5 Dmitry 2013-10-01 13:56:26 MSD
Created attachment 1943 [details]
Loading freezes

I've updates kernel. mei_me has disappeared, but the problem not. With 3.10.12 kernel my computer freezes during systemd loading. Last systemd messages may be different from one boot to another (because systemd may have time to load some services). I don't know how collect more information because logs are empty (like I don't ever started 3.10 kernel (: )
Comment 6 Alexander Burmashev 2013-10-01 14:09:51 MSD
This problem appears only when you try to resume from sleep/hybernate ?
Comment 7 Dmitry 2013-10-01 14:10:47 MSD
No, then I try to start 3.10 kernel.
Comment 8 Eugene Shatokhin 2013-10-01 14:11:36 MSD
(In reply to comment #5)
> I don't know how collect more information
> because logs are empty (like I don't ever started 3.10 kernel (: )

First of all, let us make the logs persistent. By default, journald stores them in memory, so they disappear each time the system restarts.

Your system can boot with lernel 3.8.12, right? If so, boot the system with it and then check if /var/log/journal/ directory exists. If it does not, create it than reboot the system using kernel 3.10. 

When the system hangs again, wait a little, just in case (1-2 minutes would be OK). 

To make sure the next boot does not overwrite the logs, you can boot from a USB stick or DVD in Live mode, mount the HDD partition contaning /var somewhere, say, to /mnt/root_part/

Then get the logs in the readable format with
journalctl -a -D /mnt/root_part/var/log/journal/

Let's see if this gives us anything.
Comment 9 Dmitry 2013-10-01 14:56:15 MSD
First of all, journald isn't started so I've created required folder /var/log/journal but it was empty after fail of 3.10 (:. 


Hmmmmm... interesting, after boot to 3.8 I checked folder and it was non-empty. Then I tried to reboot to 3.10 and ........ and ....... and ......... it started!!! I don't understand what it was!

I'll try to reboot several times later and then remove /var/log/journal and try to boot to 3.10.
Comment 10 Dmitry 2013-10-02 13:36:14 MSD
It doesn't matter a folder '/var/log/journal' does exist or not, my computer doesn't want to boot with 3.10 kernel again.
Comment 11 Eugene Shatokhin 2013-10-02 15:31:14 MSD
(In reply to comment #10)
> It doesn't matter a folder '/var/log/journal' does exist or not, my computer
> doesn't want to boot with 3.10 kernel again.

Which kernel version have you tried now? 3.10.13-nrj-desktop?

Certainly, '/var/log/journal' should not affect if the system is bootable or not. 

But now, you might have the logs there that could help identify the problem. Please collect them as I described in the comment #8 and post the relevant part here.
Comment 12 Eugene Shatokhin 2013-10-02 15:37:23 MSD
If you used 3.10.9 or an earlier kernel, please try newer versions first as Alexander suggested.
Comment 13 Dmitry 2013-10-02 19:27:52 MSD
First of all, I have next kernels' versions:

$ ls /boot | grep vml
vmlinuz-3.10.12-nrj-desktop-1rosa
vmlinuz-3.10.9-nrj-desktop-1rosa
vmlinuz-3.8.12-nrj-desktop-2rosa
vmlinuz-nrj-desktop@

And 3.10.9, 3.10.12 don't want to work (:

I've tried several times to do steps described in comment #8 but every time I saw empty /var/log/journal.