Bug 2723 - libwxgtku2.8 was split into individual library packages according to our policy
: libwxgtku2.8 was split into individual library packages according to our policy
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 2755
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 19:02 MSD by Andrey Bondrov
Modified: 2013-10-14 10:52 MSD (History)
4 users (show)

See Also:
RPM Package: wxgtk2.8
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
log (17.13 KB, text/plain)
2013-10-03 12:10 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-09-30 19:02:35 MSD
libwxgtku2.8 was split into individual library packages according to our policy. 

Instead of libwxgtku2.8 and libwxgtkglu2.8 we have now:

libwx_baseu2.8_0
libwx_baseu_net2.8_0
libwx_baseu_xml2.8_0
libwx_gtk2u_adv2.8_0
libwx_gtk2u_aui2.8_0
libwx_gtk2u_core2.8_0
libwx_gtk2u_fl2.8_0
libwx_gtk2u_gizmos2.8_0
libwx_gtk2u_gizmos_xrc2.8_0
libwx_gtk2u_gl2.8_0
libwx_gtk2u_html2.8_0
libwx_gtk2u_media2.8_0
libwx_gtk2u_ogl2.8_0
libwx_gtk2u_plot2.8_0
libwx_gtk2u_qa2.8_0
libwx_gtk2u_richtext2.8_0
libwx_gtk2u_stc2.8_0
libwx_gtk2u_svg2.8_0
libwx_gtk2u_xrc2.8_0

Please test if there are any issues with system update or packages installation.

1. Make sure you have some wxGTK-based package (and therefore libwxgtku2.8) installed. Then add containters and try to update your system.
2. Remove all wxGTK libraries and packages. Try to install any wxGTK-based package and see if it installs with no issues.
Comment 1 Andrey Bondrov 2013-09-30 19:04:11 MSD
Advisory: "libwxgtku2.8 was split into individual library packages according to ROSA policy"

https://abf.rosalinux.ru/build_lists/1337381
https://abf.rosalinux.ru/build_lists/1337382
Comment 2 Vladimir Potapov 2013-10-02 16:04:11 MSD
Do you know an application that would use the library?
Comment 3 Andrey Bondrov 2013-10-02 16:49:14 MSD
(In reply to comment #2)
> Do you know an application that would use the library?

I suggest to use audacity for tests.

But you can see the whole list with "urpmq --whatrequires libwxgtku2.8"
Comment 4 Vladimir Potapov 2013-10-02 16:59:29 MSD
(In reply to comment #3)
> > Do you know an application that would use the library?
> 
> I suggest to use audacity for tests.
> 
> But you can see the whole list with "urpmq --whatrequires libwxgtku2.8"
Thank you!
Comment 5 Vladimir Potapov 2013-10-03 12:04:41 MSD
urpmi audacity
Пакеты libgtk+2.0_0-2.24.20-1-rosa2012.1.i586, libgcc1-4.7.3_2012.10-3.1-rosa2012.1.i586, libexpat1-2.1.0-2-rosa2012.1.i586, libglib2.0_0-2.36.3-3-rosa2012.1.i586, libstdc++6-4.7.3_2012.10-3.1-rosa2012.1.i586, libz1-1.2.7-3-rosa2012.1.i586, libgstreamer0.10_0-0.10.36-4-rosa2012.1.i586, libjpeg8-1.2.1-1-rosa2012.1.i586, glibc-2.15-8-rosa2012.1.i586, libgstreamer-plugins-base0.10-0.10.36-2-rosa2012.1.i586 уже установлен
Не удаётся установить запрошенный пакет:
libwxgtku2.8-2.8.12-7-rosa2012.1.i586 (из-за неудовлетворённости wxgtk2.8-2.8.12-7-rosa2012.1.i586)
Comment 6 Andrey Bondrov 2013-10-03 12:07:46 MSD
(In reply to comment #5)
> urpmi audacity

Can you please run urpmi with --debug? And make sure you have latest urpmi installed.
Comment 7 Vladimir Potapov 2013-10-03 12:10:31 MSD
urpmi urpmi
Пакет urpmi-6.71-37-rosa2012.1.noarch уже установлен
Comment 8 Vladimir Potapov 2013-10-03 12:10:44 MSD
Created attachment 1945 [details]
log
Comment 9 Andrey Bondrov 2013-10-03 12:21:08 MSD
1. Is your system updated?
2. Can you please run & paste: urpmq libwx_gtk2u_html2.8_0 --provides
Comment 10 Denis Silakov 2013-10-03 12:24:34 MSD
Vladimir, why are you trying to install libwxgtku2.8-2.8.12-7? This is the old lib which should be replaced by libs from container. If you use urpmi without '--auto', then select packages with '2.8.12-8' version-release.

Or just launch 'urpmi --auto audacity', I hope it should select the proper packages.
Comment 11 Vladimir Potapov 2013-10-03 12:31:45 MSD
(In reply to comment #9)
> 1. Is your system updated?
> 2. Can you please run & paste: urpmq libwx_gtk2u_html2.8_0 --provides
1. Yes!
2 urpmq libwx_gtk2u_html2.8_0 --provides
Нет пакета с названием libwx_gtk2u_html2.8_0


I test on new, updated i586 system without installed libwxgtku2.8 with container http://abf-downloads.rosalinux.ru/rosa2012.1/container/1337382/x86_64/main/release/ added.

Updating a pre-installed library runs without problems.
Comment 12 Vladimir Potapov 2013-10-03 12:33:33 MSD
(In reply to comment #10)
> Vladimir, why are you trying to install libwxgtku2.8-2.8.12-7? This is the
> old lib which should be replaced by libs from container. If you use urpmi
> without '--auto', then select packages with '2.8.12-8' version-release.
> 
> Or just launch 'urpmi --auto audacity', I hope it should select the proper
> packages.

I try install audacity from GUI... it's inpossible. (if container http://abf-downloads.rosalinux.ru/rosa2012.1/container/1337382/x86_64/main/release/ added)
Comment 13 Andrey Bondrov 2013-10-03 12:35:22 MSD
(In reply to comment #11)
> I test on new, updated i586 system without installed libwxgtku2.8 with
> container
> http://abf-downloads.rosalinux.ru/rosa2012.1/container/1337382/x86_64/main/
> release/ added.

I see :-) You added 64 bit container to 32 bit system. Please add 32 bit container instead.
Comment 14 Vladimir Potapov 2013-10-03 12:38:03 MSD
(In reply to comment #12)

> I try install audacity from GUI... it's inpossible. (if container
> http://abf-downloads.rosalinux.ru/rosa2012.1/container/1337382/x86_64/main/
> release/ added)
sorry, if container http://abf-downloads.rosalinux.ru/rosa2012.1/container/1337381/i586/main/release/ added.
Comment 15 Andrey Bondrov 2013-10-03 12:43:24 MSD
Thanx for testing, it looks like some work on rpmdrake needs to be done.
Comment 16 Postnikov Dmitry 2013-10-03 12:48:58 MSD
For me in konsole all work:
http://pastebin.com/VF1C8Ltz
http://pastebin.com/UQ241Chm
But in rpmdrake not work. This problem in rpmdrake.
http://cdn.2safe.com/92695033757/screen-wxgtk28.avi
Comment 17 Denis Silakov 2013-10-03 13:07:53 MSD
That's right.

I have prepared a patch for rpmdrake, let's wait for ABF coming back to life (can't build new rpmdrake at the moment).
Comment 18 Denis Silakov 2013-10-10 11:35:11 MSD
Updated rpmdrake has been published, let's try again.

Advisory: "libwxgtku2.8 was split into individual library packages according to ROSA policy"

https://abf.rosalinux.ru/build_lists/1337381
https://abf.rosalinux.ru/build_lists/1337382
Comment 19 Vladimir Potapov 2013-10-10 18:47:43 MSD
libwx_baseu2.8_0-2.8.12-8-rosa2012.1
****************** Advisory **********************
ibwxgtku2.8 was split into individual library packages according to ROSA policy
**************************************************
QA Verified