Bug 2695 - Recent hplip is installed thorough updates even if user has no printers
: Recent hplip is installed thorough updates even if user has no printers
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Eugene Shatokhin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-18 14:05 MSD by Denis Silakov
Modified: 2014-09-22 16:58 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-09-18 14:05:25 MSD
From bug #2656:

I have no printer, no. But when urpmi --auto-update came hplip package and now in the system tray hanging it constantly. (in KDE and Gnome)
Earlier, when this package is updated, this was not.

===

Do you have system-config-printer installed? It is likely that we have this package installed by default; it requires hplip-model-data which now requires hplip itself.
Comment 1 Denis Silakov 2013-09-18 14:09:50 MSD
Hm, no, the latest suggestion is wrong, hplip-model-data doesn't require anything...
Comment 2 Postnikov Dmitry 2013-09-18 14:10:04 MSD
Yes system-config-printer is installed by default in the system. I.e. he is in the image and is installed by default. But when doing the update you install hplip and after the reboot hangs in the system tray.
Comment 3 Denis Silakov 2013-09-18 14:13:23 MSD
What happens if you launch "urpme hplip"?
Comment 4 Postnikov Dmitry 2013-09-18 14:17:14 MSD
Removed hplib + system-config-printer + epson, etc.
And the problem will disappear.
Comment 5 Denis Silakov 2013-09-18 14:18:32 MSD
Well, but are you able to remove hplip without removing system-config-printer? I.e., try to install system-config-printer now, will it install hplip?
Comment 6 Postnikov Dmitry 2013-09-18 14:22:58 MSD
(In reply to comment #5)
> Well, but are you able to remove hplip without removing
> system-config-printer? I.e., try to install system-config-printer now, will
> it install hplip?

==============
Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «main updates (Yandex2)»)
 hplip-model-data               3.13.8       7             rosa  2012.1 x86_64 
 system-config-printer          1.3.12       11            rosa  2012.1 x86_64 
Будет использовано 3.1МБ дополнительного дискового пространства.
Будет загружено 434КБ пакетов.
Установить 2 пакетов? (Y/n) n
[pastordi@mindlife ~]$
===============
Comment 7 Vladimir Potapov 2013-09-18 14:28:26 MSD
You system is Marathon or Fresh?
Comment 8 Postnikov Dmitry 2013-09-18 14:33:33 MSD
(In reply to comment #7)
> You system is Marathon or Fresh?

What is Marathon? :):)

certainly Fresh!
(in part log view - "rosa2012.1")
Comment 9 Vladimir Potapov 2013-09-18 14:35:38 MSD
http://bugs.rosalinux.ru/show_bug.cgi?id=2656#c9
It's marathon bug :-)
Comment 10 Denis Silakov 2013-09-18 14:40:08 MSD
(In reply to comment #6)
> (In reply to comment #5)
> > Well, but are you able to remove hplip without removing
> > system-config-printer? I.e., try to install system-config-printer now, will
> > it install hplip?
> 
> ==============
> Для удовлетворения зависимостей будут установлены следующие пакеты:
>  Пакет                          Версия       Релиз         Dist  DEpoch
> Платформа 
> (источник «main updates (Yandex2)»)
>  hplip-model-data               3.13.8       7             rosa  2012.1
> x86_64 
>  system-config-printer          1.3.12       11            rosa  2012.1
> x86_64 
> Будет использовано 3.1МБ дополнительного дискового пространства.
> Будет загружено 434КБ пакетов.
> Установить 2 пакетов? (Y/n) n
> [pastordi@mindlife ~]$
> ===============

But this is ok. It will install hplip-model-data, but not hplip itself or hplip gui. I.e., you shouldn't see HP in system tray after installing system-config-printer.
Comment 11 Postnikov Dmitry 2013-09-18 14:41:06 MSD
(In reply to comment #9)
> http://bugs.rosalinux.ru/show_bug.cgi?id=2656#c9
> It's marathon bug :-)

:) Pardon I made a mistake bug. But this bug on Fresh. And it is Fresh with this version of hplip.
Comment 12 Postnikov Dmitry 2013-09-18 14:47:51 MSD
The results:
1. Install new ISO image with KDE. (by default installed system-config-printer)
2. urpmi --auto-update (installed hplip)
3. reboot
4. View systemtray icon hplip
5. urpme hplip
6. urpmi system-config-printer (or nothing)

And no show incon hplip
Comment 13 Denis Silakov 2013-09-19 16:32:09 MSD
Ha, we have all hplip packages installed by default even in ISO.

So it is ok that you get new version hplip with updates.

However, the question remains why its gui starts automatically...
Comment 14 Denis Silakov 2013-09-19 16:39:08 MSD
Meanwhile, I have updated and rebuilt hplip with minor fix in post script - there was a typo there due to which the script failed. Maybe this was the reason, we should check...
Comment 15 Postnikov Dmitry 2013-11-10 18:25:36 MSK
Now in each iso image for some reason this hplip-gui. Can make it the default no? I have no printer, why should I?
Comment 16 Denis Silakov 2013-11-11 10:43:42 MSK
hplip-gui has been included in iso for a long time. The problem is that previously if you have no printer, hp-gui didn't start. But after one of the latest updates it began to start in all cases, either you have printer or not.
Comment 17 Aleksandr Kazantcev 2013-11-11 10:54:15 MSK
Problem in one small symbols:

See 

hplip-systray.desktop in /etx/xdg/autostart

Exec string is

Exec: hp-systray -x

that run systray always.

We need remove this from autostart desktop and use symple

Exec: hp-systray
Comment 18 Denis Silakov 2013-12-16 15:56:55 MSK
Is this bug stil valid after latest hplip updates?
Comment 19 Postnikov Dmitry 2013-12-18 12:46:29 MSK
(In reply to comment #18)
> Is this bug stil valid after latest hplip updates?

No
Comment 20 Denis Silakov 2013-12-18 12:48:54 MSK
Nice!
Comment 21 Aleksandr Kazantcev 2013-12-18 12:53:20 MSK
This bug is unresolved becaus hp-systray broken and ither distro fully dekete it fron autorun.
Comment 22 Denis Silakov 2013-12-18 12:54:26 MSK
Ok, I see.

Let's wait for future hplip versions and hope that developers will fix systray:)
Comment 23 Eugene Shatokhin 2014-09-22 16:58:03 MSD
Fixed in the recent ISO images (2014.1)