Bug 2684 - [UPDATE REQUEST] libreoffice-4.1.1
: [UPDATE REQUEST] libreoffice-4.1.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 01:21 MSD by Aleksandr Kazantcev
Modified: 2013-10-07 10:26 MSD (History)
5 users (show)

See Also:
RPM Package: libreoffce-4.1.1
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
report-LO.odt (226.22 KB, application/vnd.oasis.opendocument.text)
2013-09-17 00:00 MSD, Postnikov Dmitry
Details
too many questions (2.03 MB, video/webm)
2013-09-17 15:37 MSD, Vladimir Potapov
Details
password check for start (5.90 MB, video/webm)
2013-09-17 15:56 MSD, Vladimir Potapov
Details
hangs (4.31 MB, video/webm)
2013-09-17 17:48 MSD, Vladimir Potapov
Details
reportLO412.odt (3.00 MB, application/vnd.oasis.opendocument.text)
2013-09-26 13:25 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-09-14 01:21:00 MSD
New release
Comment 1 Aleksandr Kazantcev 2013-09-14 01:22:56 MSD
https://abf.rosalinux.ru/build_lists/1247962
https://abf.rosalinux.ru/build_lists/1247963

Advisory: New release of Libreoffice. Many bugfixes and new features. Now with ROSA vendor and build with system libs for maximum. See full changelog here:

https://wiki.documentfoundation.org/ReleaseNotes/4.1
Comment 2 Sylvainsjc 2013-09-14 13:15:15 MSD
Installed successfully on my desktop. All seems to be ok for now.
Thanks ;)
Comment 3 Vladimir Potapov 2013-09-16 05:17:34 MSD
The update route to extended testing
Comment 4 Vladimir Potapov 2013-09-16 13:58:11 MSD
on two my i586 system:

"Следующий пакет будет удалён для обновления остальных:
libreoffice-pdfimport-3.6.6-1-rosa2012.1.i586
 (из-за неудовлетворённости libreoffice-common == 1:3.6.6-1:2012.1)"
Comment 5 Aleksandr Kazantcev 2013-09-16 14:03:09 MSD
You upgrade LO with 3.6.6 to 4.1.1. And need delete ALL 3.6.6 package. Where there you find a bug?
Comment 6 Andrey Bondrov 2013-09-16 14:53:51 MSD
(In reply to comment #4)
> on two my i586 system:
> 
> "Следующий пакет будет удалён для обновления остальных:
> libreoffice-pdfimport-3.6.6-1-rosa2012.1.i586
>  (из-за неудовлетворённости libreoffice-common == 1:3.6.6-1:2012.1)"

I'll fix it to make the update smooth.
Comment 7 Vladimir Potapov 2013-09-16 15:54:05 MSD
(In reply to comment #5)
> You upgrade LO with 3.6.6 to 4.1.1. And need delete ALL 3.6.6 package. Where
> there you find a bug?
This is auto-update, not upgrade.

(In reply to comment #6)
> (In reply to comment #4)
> > on two my i586 system:
> > 
> > "Следующий пакет будет удалён для обновления остальных:
> > libreoffice-pdfimport-3.6.6-1-rosa2012.1.i586
> >  (из-за неудовлетворённости libreoffice-common == 1:3.6.6-1:2012.1)"
> 
> I'll fix it to make the update smooth.
Ok, I'll wait it.
Comment 8 Postnikov Dmitry 2013-09-17 00:00:45 MSD
Created attachment 1926 [details]
report-LO.odt

**************************
Extended testing report
*************************
Comment 9 Andrey Bondrov 2013-09-17 08:37:30 MSD
(In reply to comment #7)
> > > "Следующий пакет будет удалён для обновления остальных:
> > > libreoffice-pdfimport-3.6.6-1-rosa2012.1.i586
> > >  (из-за неудовлетворённости libreoffice-common == 1:3.6.6-1:2012.1)"
> > 
> > I'll fix it to make the update smooth.
> Ok, I'll wait it.

New build lists:

https://abf.rosalinux.ru/build_lists/1255990
https://abf.rosalinux.ru/build_lists/1255991
Comment 10 Denis Silakov 2013-09-17 09:54:31 MSD
(In reply to comment #8)
> Created attachment 1926 [details]
> report-LO.odt
> 
> **************************
> Extended testing report
> *************************

A question about "too many choices during update" - do you install update using urpmi and rpmdrake? And do you use '--auto' for urpmi and corresponding checkbox ("select dependencies automatically") in rpmdrake?
Comment 11 Postnikov Dmitry 2013-09-17 12:10:33 MSD
http://cdn.2safe.com/47784033759/scr-LO4.mov
 	
The problem bugs 2672 remained.
Comment 12 Postnikov Dmitry 2013-09-17 12:13:45 MSD
(In reply to comment #10)
> (In reply to comment #8)
> > Created attachment 1926 [details]
> > report-LO.odt
> > 
> > **************************
> > Extended testing report
> > *************************
> 
> A question about "too many choices during update" - do you install update
> using urpmi and rpmdrake? And do you use '--auto' for urpmi and
> corresponding checkbox ("select dependencies automatically") in rpmdrake?

Using urpmi without "--auto". Dangerous, whether a little that urpmi install system.
Comment 13 Denis Silakov 2013-09-17 12:18:38 MSD
(In reply to comment #12)
> > A question about "too many choices during update" - do you install update
> > using urpmi and rpmdrake? And do you use '--auto' for urpmi and
> > corresponding checkbox ("select dependencies automatically") in rpmdrake?
> 
> Using urpmi without "--auto". 

Ok, then this is expected behavior.
Comment 14 Vladimir Potapov 2013-09-17 15:37:19 MSD
Created attachment 1930 [details]
too many questions

(In reply to comment #13)
> (In reply to comment #12)
> > > A question about "too many choices during update" - do you install update
> > > using urpmi and rpmdrake? And do you use '--auto' for urpmi and
> > > corresponding checkbox ("select dependencies automatically") in rpmdrake?
> > 
> > Using urpmi without "--auto". 
> 
> Ok, then this is expected behavior.
See screencast. For rpmdrakwe too.
Comment 15 Vladimir Potapov 2013-09-17 15:56:13 MSD
Created attachment 1931 [details]
password check for start
Comment 16 Vladimir Potapov 2013-09-17 16:03:23 MSD
1) Font's problem
2) Too many quesions
3) Check password for start
4) LO Impress slides problem
*******************************
QA Denied
Comment 17 Denis Silakov 2013-09-17 16:18:07 MSD
(In reply to comment #15)
> Created attachment 1931 [details]
> password check for start

> > Ok, then this is expected behavior.
> See screencast. For rpmdrakwe too.

Ah, it's not rpmdrake, it it Mdkapplet ("MandrivaUpdate"). We have never fixed it to perform automated choice. And likely we won't fix it and work on new Software Center instead.

In any case, "too many questions" is not a bug of LibreOffice. Feel free to create a separate bug for MandrivaUpdate if you think this should be fixed.
Comment 18 Aleksandr Kazantcev 2013-09-17 17:03:37 MSD
What is 3 ? Where LO request password?
Where problem presentation with font problem?

I find only one bug with rotated text. Another not a bug. And rotated text not a stop bug.
Comment 19 Postnikov Dmitry 2013-09-17 17:17:53 MSD
Some .pptx files when you select a slide and press Shft+F5 - Impress stops the whole KDE!
=======
Sep 17 17:03:24 mindlife [9974]: Process 3533 (QThread) dumped core.
Sep 17 17:14:02 mindlife [10956]: Process 10222 (QThread) dumped core.
=======
Comment 20 Vladimir Potapov 2013-09-17 17:39:52 MSD
(In reply to comment #18)
> What is 3 ? Where LO request password?
It's regression. With old LO password don't check.
Comment 21 Postnikov Dmitry 2013-09-17 17:43:23 MSD
All .pptx files when you select "Settings demonstration" and choosing "Show Navigator" and press Shft+F5 demonstration starts NOT with selected slide. And is not displayed by the Navigator.
http://cdn.2safe.com/44345033757/scr-LO4-2.mov
Comment 22 Vladimir Potapov 2013-09-17 17:48:46 MSD
Created attachment 1932 [details]
hangs

	
If I try to open an office file from firefox, office hangs completely.
Comment 23 Andrey Bondrov 2013-09-17 17:53:38 MSD
(In reply to comment #22)
> Created attachment 1932 [details]
> hangs
> 
> 	
> If I try to open an office file from firefox, office hangs completely.

I confirm this. The workaround is to remove libreoffice-kde4 but maybe there's a chance to fix this bug, we don't know yet.
Comment 24 Aleksandr Kazantcev 2013-09-17 18:12:27 MSD
Remove libreoffice-kde4 part and try without it. Also try install libreoffice-gnome part.
Comment 25 Vladimir Potapov 2013-09-17 18:14:51 MSD
I delete libreoffice-kde4. This resolve office hung, but break menu fonts.
Comment 26 Vladimir Potapov 2013-09-17 18:42:43 MSD
(In reply to comment #17)

> In any case, "too many questions" is not a bug of LibreOffice. Feel free to
> create a separate bug for MandrivaUpdate if you think this should be fixed.
http://bugs.rosalinux.ru/show_bug.cgi?id=2692
Comment 27 Postnikov Dmitry 2013-09-18 02:12:46 MSD
After many experiments conclusion such:
1. In the standard LO4.1.1 bug 2672 manifests itself always
2. If the video card ATI then we have to apply paragraph 3.6 of http://wiki.rosalab.ru/ru/index.php/Errata_ROSA_Desktop_R1 and a bug 2672 will occur rarely. But there are artifacts 
http://savepic.org/4464770.png
http://savepic.org/4465794.png
3. If the video card ATI then we have to apply paragraph 3.6 of http://wiki.rosalab.ru/ru/index.php/Errata_ROSA_Desktop_R1 and UNinstall "libreoffice-kde4", then bug 2672 is not evident and artifacts on only one effect is manifested.

For pure test, rolled back the system to its original state. Reinstall LO and checked all of the above. Step 2 and 3 does NOT always work. 
The error is "swiming".

Everything described above is typical for computers with video ATI and free drivers (radeon).
Comment 28 Andrey Bondrov 2013-09-24 12:25:39 MSD
New build lists:

Qt4 with patch for LO:
https://abf.rosalinux.ru/build_lists/1261298
https://abf.rosalinux.ru/build_lists/1261299

LibreOffice 4.1.2.2:
https://abf.rosalinux.ru/build_lists/1281221
https://abf.rosalinux.ru/build_lists/1280868

Please make sure to add both Qt4 and LO containers otherwise LO won't work properly.
Comment 29 Postnikov Dmitry 2013-09-26 13:25:51 MSD
Created attachment 1938 [details]
reportLO412.odt

(In reply to comment #28)
> New build lists:
> 
> Qt4 with patch for LO:
> https://abf.rosalinux.ru/build_lists/1261298
> https://abf.rosalinux.ru/build_lists/1261299
> 
> LibreOffice 4.1.2.2:
> https://abf.rosalinux.ru/build_lists/1281221
> https://abf.rosalinux.ru/build_lists/1280868
> 
> Please make sure to add both Qt4 and LO containers otherwise LO won't work
> properly.

*********************
Extended testing report
*********************
Comment 30 Vladimir Potapov 2013-09-27 13:44:14 MSD
Impress and Calc crashes.
*************************
QA Denied
Comment 31 Andrey Bondrov 2013-09-28 20:15:10 MSD
(In reply to comment #30)
> Impress and Calc crashes.
> *************************
> QA Denied

Fixed Impress and Calc crashes:

https://abf.rosalinux.ru/build_lists/1336656
https://abf.rosalinux.ru/build_lists/1336657

Should be OK to approve LO now.
Comment 32 Vladimir Potapov 2013-09-29 16:56:41 MSD
The update route to extended testing
Comment 33 Andrey Bondrov 2013-09-29 19:00:39 MSD
(In reply to comment #32)
> The update route to extended testing

Meanwhile version 4.1.2.3 was released, it fixes some bugs:

1. fdo#69220 crash on open .doc file
2. fdo#69440 EDITING: Function Wizard crashes LibreOffice
3. fdo#69450 FORMATTING Format painter deletes cell content, paste special does not work

I'll post new build lists here as soon as I get 4.1.2.3 built.
Comment 34 Postnikov Dmitry 2013-09-30 21:50:07 MSD
(In reply to comment #31)
> (In reply to comment #30)
> > Impress and Calc crashes.
> > *************************
> > QA Denied
> 
> Fixed Impress and Calc crashes:
> 
> https://abf.rosalinux.ru/build_lists/1336656
> https://abf.rosalinux.ru/build_lists/1336657
> 
> Should be OK to approve LO now.

 	
1. All the same errors remain. Calc drops when the File->Сollaborative work on a 32 bit version.

2. The Menu disappears after exit full-screen mode http://cdn.2safe.com/80087033760/screen-LO412-4.avi

3. Impress not crash with insert effects.

4. In menu File->Master->Convert to Euro - no RUB in menu.
Comment 35 Postnikov Dmitry 2013-09-30 21:54:04 MSD
(In reply to comment #31)
> (In reply to comment #30)
> > Impress and Calc crashes.
> > *************************
> > QA Denied
> 
> Fixed Impress and Calc crashes:
> 
> https://abf.rosalinux.ru/build_lists/1336656
> https://abf.rosalinux.ru/build_lists/1336657
> 
> Should be OK to approve LO now.

***********************
Extended testing report
***********************
 	
1. All the same errors remain. Calc drops when the File->Сollaborative work on a 32 bit version.

2. The Menu disappears after exit full-screen mode http://cdn.2safe.com/80087033760/screen-LO412-4.avi

3. Impress not crash with insert effects.

4. In menu File->Master->Convert to Euro - no RUB in menu.
Comment 37 Vladimir Potapov 2013-10-01 17:31:34 MSD
The update route to extended testing
Comment 38 Postnikov Dmitry 2013-10-01 23:41:41 MSD
(In reply to comment #36)
> 4.1.2.3:
> https://abf.rosalinux.ru/build_lists/1337265
> https://abf.rosalinux.ru/build_lists/1337266

**************************
Extended testing report
*************************

LO 4.1.2-5
(32/64 in 5 computers)

1. The Menu disappears after exit full-screen mode

2. Impress not crash with insert effects.

3. In menu File->Master->Convert to Euro - no RUB in menu.

4. The rest is not quite critical
Comment 39 Andrey Bondrov 2013-10-02 01:43:23 MSD
I guess it's OK to publish LO now.
Comment 40 Andrey Bondrov 2013-10-02 05:09:04 MSD
(In reply to comment #38)
> LO 4.1.2-5
> (32/64 in 5 computers)
> 
> 1. The Menu disappears after exit full-screen mode

BTW, there is already upstream bug report for this bug: https://bugs.freedesktop.org/show_bug.cgi?id=69930
Comment 41 Vladimir Potapov 2013-10-02 16:01:18 MSD
libreoffice-4.1.2-5-rosa2012.1
***************** Advisory *************************
New release of Libreoffice. Many bugfixes and new features. Now with ROSA vendor and build with system libs for maximum.
****************************************************
QA Verified