Bug 2677 - [UPDATE REQUEST] broadcom-wl
: [UPDATE REQUEST] broadcom-wl
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 22:17 MSD by Eugene Shatokhin
Modified: 2013-09-27 14:26 MSD (History)
3 users (show)

See Also:
RPM Package: dkms-broadcom-wl
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-09-10 22:17:17 MSD
broadcom-wl driver was fixed to avoid crashes due to missing error handling in wl_inform_single_bss().

I observed the kernel crashes on my ASUS EEE PC 1015PED with ROSA Fresh R1 (KDE), kernel 3.8.12-nrj-netbook-atom-pae-2rosa. The problem is likely to affect other kernel flavours as well (including "nrj-desktop").

The crash occurred after the system was put to hybernation within reach of one WiFi access point and then was woken up within reach of another one.

From the kernel oops report:
------------------------
[19720.928355] BUG: unable to handle kernel NULL pointer dereference at   (null)
[19720.932177] IP: [<f4ce6dce>] cfg80211_get_bss_channel+0xae/0x100 [cfg80211]
<...>
[19720.932177] Call Trace:
[19720.932177]  [<f4ce823a>] cfg80211_inform_bss_frame+0x7a/0x270 [cfg80211]
[19720.932177]  [<f5496c9e>] wl_inform_single_bss+0x1ce/0x3c0 [wl]
[19720.932177]  [<f54972f3>] wl_notify_scan_status+0x223/0x360 [wl]
[19720.932177]  [<f549747a>] wl_event_handler+0x4a/0x1c0 [wl]
[19720.932177]  [<c0157544>] kthread+0x94/0xa0
[19720.932177]  [<c062d877>] ret_from_kernel_thread+0x1b/0x28
------------------------

The problem was in the insufficient error handling in wl_inform_single_bss() function. Should be fixed now.
Comment 1 Eugene Shatokhin 2013-09-10 22:22:03 MSD
Advisory:
The driver was fixed to avoid crashes due to missing error handling in wl_inform_single_bss().

Buildlists:
https://abf.rosalinux.ru/build_lists/1247433
https://abf.rosalinux.ru/build_lists/1247434

Hints for testing:
1. Besides the usual testing procedures, one may try to put the laptop to hybernation within reach of one WiFi access point and then was woken up within reach of another one and see if WiFi works after that.

2. The driver may issue warnings like the following one in the system log:
  ERROR @wl_inform_single_bss : cfg80211_inform_bss_frame error

This is OK, the driver now reports this error instead of passing the incorrect data further and crashing as a result. WiFi should still work even if such warnings are output.
Comment 2 Vladimir Potapov 2013-09-16 19:29:58 MSD
The update route to extended testing
Comment 3 Postnikov Dmitry 2013-09-27 13:43:35 MSD
***************************
Extended testing report
***************************
Pardon. Forgot to write. Tested with kernel 3.10.9 and 3.10.10 works perfectly. In the Gnome 64/32 and KDE 32/64
(BCM4311/BCM4312)
Comment 4 Vladimir Potapov 2013-09-27 14:21:21 MSD
dkms-broadcom-wl-5.100.82.112-14-rosa2012.1
********************* Advisory ****************
The driver was fixed to avoid crashes due to missing error handling in wl_inform_single_bss().
***********************************************
QA Verified