Bug 2638 - [UPDATE REQUEST] rpcbind 0.2.1
: [UPDATE REQUEST] rpcbind 0.2.1
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 10:38 MSD by Denis Silakov
Modified: 2013-09-13 12:59 MSD (History)
3 users (show)

See Also:
RPM Package: rpcbind
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
danila.leontiev: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2013-09-04 10:38:49 MSD
rpcbind-0.2.1 was released not long ago.
Comment 1 Denis Silakov 2013-09-04 10:42:13 MSD
Advisory:

Updated rpcbond to version 0.2.1. The new version contains several minor bug fixes and is adapted to be built with modern autotools. Detailed changelog is available here: http://sourceforge.net/projects/rpcbind/files/rpcbind/0.2.1/0.2.1-Changelog

In addition, rpcbind in ROSA was migrated to systemd.

Build lists:
https://abf.rosalinux.ru/build_lists/1242896
https://abf.rosalinux.ru/build_lists/1242897
Comment 2 Denis Silakov 2013-09-04 12:11:38 MSD
Note for testers:
rpcbind is used for NFS shares. So it is necessary to check that you can user system-config-nfs to configure your shares after this update.
Comment 3 Alexander Petryakov 2013-09-10 02:49:49 MSD
Share not changed at edit (new share created). 
Steps
1) create share (system-config-nfs) 
2) edit share (example set net host)
3) restart  system-config-nfs
4) system-config-nfs - show two share with old and new host

cat /etc/exports
# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).
/home/sasha                    192.168.1.0/24(rw,sync) 192.168.1.217(rw,sync)

also 
rpcdebug  -m nfs -s all
/proc/sys/sunrpc/nfs_debug: No such file or directory
This is as it should be?
Comment 4 Denis Silakov 2013-09-10 21:19:36 MSD
This seems to be a bug with system-config-nfs, I will digg further.

Is this behavior observe with old version of rpcbind? If yes, then this is not regression caused by rpcbind update. In this case I suggest to accept this update and create a separate bug for system-config-nfs
Comment 5 Alexander Petryakov 2013-09-11 23:38:10 MSD
rpcbind-0.2.1-1
************** Advisory **************
Updated rpcbond to version 0.2.1. The new version contains several minor bug fixes and is adapted to be built with modern autotools. Detailed changelog is available here: http://sourceforge.net/projects/rpcbind/files/rpcbind/0.2.1/0.2.1-Changelog

In addition, rpcbind in ROSA was migrated to systemd.
**************************************
QA Verified