Bug 263 - Changing system time doesn't affect hw clock
: Changing system time doesn't affect hw clock
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: High major
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 14:56 MSD by Andrew Lukoshko
Modified: 2012-12-26 13:30 MSK (History)
8 users (show)

See Also:
RPM Package: systemd-units
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Lukoshko 2012-05-22 14:56:10 MSD
Description of problem:
Changed system time stay only till reboot. After reboot system time is the same as BIOS time before.

Steps to Reproduce:
1.Change system time
2.Reboot
Comment 1 Denis Koryavov 2012-05-22 15:13:16 MSD
How do you change a system time?
Comment 2 Andrew Lukoshko 2012-05-22 19:25:24 MSD
KDE date/time dialog
Comment 3 Vladimir Potapov 2012-06-14 12:51:11 MSD
I confirm this error in two my computers.
After time change command "date" in console show changed time, after reboot time return to old value.
Comment 4 Aleksandr Kazantcev 2012-06-14 13:22:22 MSD
May BIOS attempt change time?
Comment 5 Vladimir Potapov 2012-06-14 13:55:37 MSD
Yes, I had to go into the BIOS to change the time.
This error present both original 2012 LTS in live mode and two updated systems in my harddisk.
Comment 6 Frank 2012-11-27 21:41:24 MSK
This is because upstream systemd dropped hwclock-save.service:

http://cgit.freedesktop.org/systemd/systemd/commit/?id=da2617378523e007ec0c6efe99d0cebb2be994e1

This means RTC isn't synced any more during shutdown.

Other side effect: Automatic adjustments due to DST changes get lost after reboot if your RTC is set to local time.

I think until all the other components influencing system time "get used" to this and write their changes through to RTC (as intended by the systemd developers) ROSA should undo the patch and re-add this service.
Comment 7 alexander barakin 2012-12-13 20:27:24 MSK
advisory: return hwclock-save.service; closes bug #263

https://abf.rosalinux.ru/build_lists/856420
https://abf.rosalinux.ru/build_lists/856421
Comment 8 Aleksandr Kazantcev 2012-12-13 20:29:52 MSK
MMM.

Using this workaround in 2012 Desktop affect up time more than 8 hours and broke system load with wrong time. RTC part in kernel for now not need using this service.

It's not good solution - please carefully test this... I thin this will be rejected...
Comment 9 alexander barakin 2012-12-14 11:38:23 MSK
(In reply to comment #8)
> MMM.
> 
> Using this workaround in 2012 Desktop

bug related to rosa2012lts, not rosa2012.1

> affect up time more than 8 hours and
> broke system load with wrong time. RTC part in kernel for now not need using
> this service.
> 
> It's not good solution - please carefully test this...

all works as expected with the following settings:
$ grep UTC /etc/adjtime /etc/sysconfig/clock 
/etc/adjtime:UTC
/etc/sysconfig/clock:UTC=true

> I think this will be rejected...

if you have better solution for _this_ bug, please provide it!
Comment 10 alexander barakin 2012-12-14 13:13:17 MSK
(In reply to comment #9)
> all works as expected with the following settings:
> $ grep UTC /etc/adjtime /etc/sysconfig/clock 
> /etc/adjtime:UTC
> /etc/sysconfig/clock:UTC=true

all works as expected also with the following settings:
$ grep -E 'UTC|LOCAL' /etc/adjtime /etc/sysconfig/clock 
/etc/adjtime:LOCAL
/etc/sysconfig/clock:UTC=false

i believe that the bug resolved.
of course, additional testing of the qa team is encouraged.
Comment 11 Vladimir Potapov 2012-12-14 16:04:57 MSK
In testing
Comment 12 Vladimir Potapov 2012-12-26 10:12:13 MSK
systemd-units-39-4-rosa.lts2012.0
******************* Advisory ********************
Fixed a bug with the system time (#263)
*************************************************
QA Verified