Bug 2620 - perl-URPM break system locale for drakrpm and urpmi
: perl-URPM break system locale for drakrpm and urpmi
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest major
: ---
Assigned To: Denis Silakov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 13:18 MSD by Aleksandr Kazantcev
Modified: 2013-09-04 13:17 MSD (History)
0 users

See Also:
RPM Package: perl-URPM-4.43-19
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-08-30 13:18:21 MSD
After latest update all drakrpm and urpmi programm get errors with:

perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ru_RU.UTF-8",
	LC_ALL = (unset),
	LC_MONETARY = "ru_RU.UTF-8",
	LC_SOURCED = "1",
	LC_NUMERIC = "ru_RU.UTF-8",
	LC_MESSAGES = "ru_RU.UTF-8",
	LC_COLLATE = "ru_RU.UTF-8",
	LC_CTYPE = "ru_RU.UTF-8",
	LC_TIME = "ru_RU.UTF-8",
	LANG = "ru"
    are supported and installed on your system.

And some not user system locale anymore.

I think all are result this commit: https://abf.rosalinux.ru/import/perl-URPM/diff/db48c...90f8b

How reproduce:

run drakrpm-update - lang not setting
run drakrpm, drakrpm-edit-media or urpmi - see error discribed above.
Comment 1 Denis Silakov 2013-08-30 13:40:43 MSD
Hm, this can be caused by LANG-related patches, though currently I don't see how. Will dig further...
Comment 2 Denis Silakov 2013-09-04 13:17:39 MSD
Should be fixed with latest perl-URPM (4.43-20).