Bug 262 - SimpleWelcome resets its hotkey to default after rebooting
: SimpleWelcome resets its hotkey to default after rebooting
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Ural Mullabaev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 12:41 MSD by Dmitry
Modified: 2012-07-06 12:47 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
systemsettings: ROSA Desktop Application Launcher hotkey (71.70 KB, image/png)
2012-05-22 12:41 MSD, Dmitry
Details
invalid tooltip in welcome (211.17 KB, image/png)
2012-07-04 16:35 MSD, Vladimir Potapov
Details
Can't reproduce the problem (330.99 KB, image/png)
2012-07-05 01:22 MSD, Denis Koryavov
Details
incorrect path (206.07 KB, image/png)
2012-07-05 14:22 MSD, Vladimir Potapov
Details
TimeFrame wite rectangle (193.23 KB, image/png)
2012-07-06 00:31 MSD, Postnikov Dmitry
Details
SW will not dissapear then open StackFolder (308.34 KB, image/png)
2012-07-06 00:38 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2012-05-22 12:41:06 MSD
Created attachment 169 [details]
systemsettings: ROSA Desktop Application Launcher hotkey

Description of problem:

Systemsettings allow to set hotkey for SimpleWelcome (see attached image), but after rebooting its hotkey is set to default Alt+F1.

Steps to Reproduce:
1. systemsettings -> set hotkey for "ROSA Desktop Application Launcher"
2. reboot
Comment 1 Aleksey Yermakov 2012-06-09 18:23:51 MSD
Advisory:
- Fixed bug with non-ascii names when DnD'ing Places entries from SW
- Fixed hotkey saving
- Removed own ServiceRunner in favor of system one

Buildlists:
https://abf.rosalinux.ru/build_lists/618241
https://abf.rosalinux.ru/build_lists/618239

PS: I'm not sure, that I've built rosa-launcher in right repository. There are two of them now: tigro/rosa-launcher and import/rosa-launcher. tigro/rosa-launcher failed to build, something was broken there (And it didn't have needed branches defined by the policies). import/rosa-launcher builded fine, but it's target repository isn't rosa2012lts.
Comment 2 Vladimir Potapov 2012-06-18 18:45:20 MSD
Please, rebuild your package to the official public repository instead of your private one, as specified in the "Make a proper build"
Comment 3 Aleksey Yermakov 2012-06-18 19:02:09 MSD
Vladimir, how should I do that? I've build it in import/rosa-launcher. Should I build it in tigro/rosa-launcher?

Thanks.
Comment 4 Aleksey Yermakov 2012-07-03 20:26:52 MSD
Advisory:
- Fixed bug with non-ascii names when DnD'ing Places entries from SW
- Fixed hotkey saving
- Removed own ServiceRunner in favor of system one
- Added tooltips for application buttons
- Fixed hotkey malfunction after login
- Fixed bug with TimeFrame which considered iso-image to be a video. For sure this time

Buildlists:
https://abf.rosalinux.ru/build_lists/620554
https://abf.rosalinux.ru/build_lists/620555
Comment 5 Vladimir Potapov 2012-07-04 14:12:42 MSD
How I reproduce the error with hotkey malfunction after login?
Comment 6 Aleksey Yermakov 2012-07-04 14:28:18 MSD
(In reply to comment #5)
> How I reproduce the error with hotkey malfunction after login?

1. Login to desktop.
2. Press Alt+F1 (default) to show SW.
3. Bug: it won't show until SW button on RocketBar is pressed once.
   Fix: it shows.
Comment 7 Vladimir Potapov 2012-07-04 14:50:51 MSD
By the way, if you configure KDE to save it's state, after the login SW is already open...
Comment 8 Aleksey Yermakov 2012-07-04 15:52:04 MSD
(In reply to comment #7)
> By the way, if you configure KDE to save it's state, after the login SW is
> already open...

It should be so only if you remove SW from system default exceptions list.
Comment 9 Vladimir Potapov 2012-07-04 16:33:58 MSD
(In reply to comment #8)
> (In reply to comment #7)
> > By the way, if you configure KDE to save it's state, after the login SW is
> > already open...
> 
> It should be so only if you remove SW from system default exceptions list.

But rosa-launcher present in my system default exceptions list!
Comment 10 Vladimir Potapov 2012-07-04 16:35:13 MSD
Created attachment 323 [details]
invalid tooltip in welcome
Comment 11 Aleksey Yermakov 2012-07-04 16:36:09 MSD
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > By the way, if you configure KDE to save it's state, after the login SW is
> > > already open...
> > 
> > It should be so only if you remove SW from system default exceptions list.
> 
> But rosa-launcher present in my system default exceptions list!

That's strange. Then a new bug should be opened for this issue.
Comment 12 Aleksey Yermakov 2012-07-04 16:40:40 MSD
(In reply to comment #10)
> Created attachment 323 [details]
> invalid tooltip in welcome

Hmm.. Need to fix that. But for the next update.
I won't have time to do that until next week anyway. I'm working on other project now and can spare only a small fraction of my time to SW.
Comment 13 Vladimir Potapov 2012-07-04 16:59:51 MSD
I can not allow the publication of a package with a clearly visible error. I found it in the first seconds after installation. We will wait until you have the time. 
I saw that many programs do not have the correct descriptions for tooltips. We'll have to do it in parallel.
Comment 14 Aleksey Yermakov 2012-07-04 17:05:49 MSD
(In reply to comment #13)
> I can not allow the publication of a package with a clearly visible error. I
> found it in the first seconds after installation. We will wait until you
> have the time. 
> I saw that many programs do not have the correct descriptions for tooltips.
> We'll have to do it in parallel.

It's not a error per se. There is no malfunction in application. It's an UX issue, which can be addressed later. It's surely can't be a reason for delay of other important bugfixes with this update.

About incorrect descriptions of other tooltips - for entities in applications tab, those tooltips come from .desktop files, so their correctness is not SW concern.
Comment 15 Vladimir Potapov 2012-07-04 17:23:35 MSD
> > invalid tooltip in welcome
> 
> Hmm.. Need to fix that. But for the next update.
> I won't have time to do that until next week anyway. I'm working on other
> project now and can spare only a small fraction of my time to SW.
Maybe, just disable this feature (show tooltip) in this update?
Comment 16 Denis Koryavov 2012-07-04 18:01:17 MSD
It is so hard to fix this bug?
Comment 17 Aleksey Yermakov 2012-07-04 18:19:34 MSD
(In reply to comment #16)
> It is so hard to fix this bug?

No, but I have a deadline and a demonstration for my current project tomorrow or on friday and I won't have any time for this until next week.
Comment 18 Denis Koryavov 2012-07-05 00:51:42 MSD
OK, then, please ask to Ural or Alexander.
Comment 19 Denis Koryavov 2012-07-05 01:22:38 MSD
Created attachment 335 [details]
Can't reproduce the problem

Hmm... I can't reproduce this problem! See attachment.
Comment 20 Aleksey Yermakov 2012-07-05 10:20:32 MSD
(In reply to comment #19)
> Created attachment 335 [details]
> Can't reproduce the problem
> 
> Hmm... I can't reproduce this problem! See attachment.

SW not showing file path only for recent apps.
Comment 21 Vladimir Potapov 2012-07-05 14:22:58 MSD
Created attachment 337 [details]
incorrect path

New bug  - incorrect folder tooltip for russian path (file on desktop)
Comment 22 Vladimir Potapov 2012-07-05 14:34:05 MSD
For a simple and correct solution to the problem of missing KDE applications definitions in tooltips (#478) should display not Comment [lng] as it is now a GenericName [lng] + Comment [lng]
GenericName present in all programs.
Comment 23 Aleksey Yermakov 2012-07-05 19:13:52 MSD
Advisory:
- Tooltips now have meaningful messages in all cases

Buildlists:
https://abf.rosalinux.ru/build_lists/621070
https://abf.rosalinux.ru/build_lists/621071
Comment 24 Vladimir Potapov 2012-07-05 21:18:32 MSD
rosa-launcher-0.34.18-1-rosa.lts2012.0
************** Advisory ********************
- Fixed bug with non-ascii names when DnD'ing Places entries from SW
- Fixed hotkey saving
- Added tooltips for application buttons
- Fixed hotkey malfunction after login
- Fixed bug with TimeFrame which considered iso-image to be a video. 
*********************************************
QA Verfied
Comment 25 Postnikov Dmitry 2012-07-06 00:30:37 MSD
rosa-launcher-0.34.18-1-rosa.lts2012.0
In TimeFrame by browsing "by category" on the rollover each file is highlighted in the white rectangle.
Comment 26 Postnikov Dmitry 2012-07-06 00:31:53 MSD
Created attachment 350 [details]
TimeFrame wite rectangle
Comment 27 Postnikov Dmitry 2012-07-06 00:37:21 MSD
rosa-launcher-0.34.18-1-rosa.lts2012.0
If you open SW and then open StackFolder, the SW will not disappear.
See att.
Comment 28 Postnikov Dmitry 2012-07-06 00:38:11 MSD
Created attachment 351 [details]
SW will not dissapear then open StackFolder
Comment 29 Postnikov Dmitry 2012-07-06 00:44:33 MSD
rosa-launcher-0.34.18-1-rosa.lts2012.0
In Time Frame "by category". If you hover your mouse on the Center (between the icons), and could move up and down - the scrolling does not work.
See att.
Comment 30 Ural Mullabaev 2012-07-06 10:17:07 MSD
SW doesn't dissapear because SF isn't standart popup applet, so i think, it isn't SW bug. We'll try to fix it with #341 bug. 
In any case, it would be better to open a new bug.
Comment 31 Denis Koryavov 2012-07-06 12:38:16 MSD
Dmitry, please open new bug requests for these issues.
Comment 32 Alexander Burmashev 2012-07-06 12:41:11 MSD
I would kindly ask to discuss non-critical problems in another bug next time ) It is rather confusing to see packages marked as "ready to be published" with some comment about quality afterwards :)