Bug 2606 - missing dependency on java
: missing dependency on java
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 07:49 MSD by Eugene Kanter
Modified: 2014-10-09 09:42 MSD (History)
2 users (show)

See Also:
RPM Package: java-access-bridge-1.26.2-8.src.rpm
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Kanter 2013-08-29 07:49:54 MSD
Description of problem:

java-access-bridge-1.26.2-8.src.rpm was build with and for java-1.6.0 and completely useless without it. Nevertheless there is no dependency on java.

How reproducible:

always

Steps to Reproduce:
1. install fresh desktop with default package set, verify that java-1.6.0 is not installed, if installed - remove it.
2. urpmi java-access-bridge
3. observe that java package is not added via dependencies.
Comment 1 Denis Silakov 2013-08-29 11:28:47 MSD
Advisory:
Added dependency on java-openjdk to java-access-bridge

Build lists:
https://abf.rosalinux.ru/build_lists/1222725
https://abf.rosalinux.ru/build_lists/1222726
Comment 2 Eugene Kanter 2013-08-30 06:59:56 MSD
When will updated package appear in urpmi?

Also I wonder if there is a test case for java-access-bridge package.
Comment 3 Denis Silakov 2013-08-30 15:45:41 MSD
First, our QA will check if this update breaks something - this is a formal procedure used for every package in the main repository (though this is a minor improvement, we can decide to publish the package without QA iа they are busy and can't check the package in several days).
Comment 4 Eugene Kanter 2013-08-30 17:10:36 MSD
In this case "fixed" should be replaced with something indicating that it has not yet released to the general public, for example "in progress".
Comment 5 Alexander Petryakov 2013-08-31 00:37:44 MSD
java-access-bridge
************** Advisory **************
Added dependency on java-openjdk to java-access-bridge
**************************************
QA Verified
Comment 6 Eugene Kanter 2013-08-31 07:30:52 MSD
I just found out that java-access-bridge is for GNOME 2.x and has been obsoleted.
please read https://bugzilla.redhat.com/show_bug.cgi?id=818527 and provide appropriate GNOME 3.x package....
Comment 7 Denis Silakov 2014-10-09 09:42:18 MSD
java-atk-wrapper is now used as a default accessibility provider in old Fresh R3 and new Fresh R4. All dependencies are in place.