Bug 2582 - dkms-v4l-dvb-testing failed to build against the 3.8.12-nrj-desktop-2rosa kernel
: dkms-v4l-dvb-testing failed to build against the 3.8.12-nrj-desktop-2rosa kernel
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 13:17 MSD by symbianflo
Modified: 2014-09-19 11:43 MSD (History)
1 user (show)

See Also:
RPM Package: dkms-v4l-dvb-testing-0-0.hg14014.2-rosa2012.1.x86_64.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description symbianflo 2013-08-26 13:17:53 MSD
Description of problem:
dkms-v4l-dvb-testing failed to build

Version-Release number of selected component (if applicable):
*********************************************************
┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: rpm -qi dkms-v4l-dvb-testing
Name        : dkms-v4l-dvb-testing         Relocations: (not relocatable)
Version     : 0                                 Vendor: ROSA
Release     : 0.hg14014.2                   Build Date: sab 27 ott 2012 08:18:35 CEST
Install Date: lun 26 ago 2013 10:46:15 CE   Build Host: rosabs3-build-rosa2011x64-5.rosalinux.ru
Group       : System/Kernel and hardware    Source RPM: dkms-v4l-dvb-testing-0-0.hg14014.2.src.rpm
Size        : 21782978                         License: GPLv2
Signature   : DSA/SHA1, sab 27 ott 2012 08:18:36 CEST, Key ID 37f4ff98548fdeca
URL         : http://linuxtv.org/
Summary     : Experimental version of Linux V4L/DVB subsystem
Architecture: x86_64
Description :
DKMS module package for the v4l-dvb hg development tree from
linuxtv.org. Use this package to test a new snapshot of the V4L/DVB
subsystem of the Linux kernel.




source origin:
************
┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: urpmq --sources dkms-v4l-dvb-testing
http://abf-downloads.rosalinux.ru/rosa2012.1/repository/x86_64/media/contrib/release/dkms-v4l-dvb-testing-0-0.hg14014.2-rosa2012.1.x86_64.rpm


How reproducible:
┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: sudo urpmi dkms-v4l-dvb-testing
*************************
Exit:

Building module:
cleaning build area....
make KERNELRELEASE=3.8.12-nrj-desktop-2rosa -j $(/usr/bin/getconf _NPROCESSORS_ONLN) -Cv4l all SRCDIR=/lib/modules/3.8.12-nrj-desktop-2rosa/build.....(bad exit status: 2)

Error! Bad return status for module build on kernel: 3.8.12-nrj-desktop-2rosa (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/ for more information.


Build exit from make.log
***********************
┌─[ symbianflo @ symbianflo ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: cat /var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/make.log
DKMS make.log for v4l-dvb-testing-0-0.hg14014.2 for kernel 3.8.12-nrj-desktop-2rosa (x86_64)
lun 26 ago 2013, 10.46.24, CEST
make: Entering directory `/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l'
Updating/Creating .config
./scripts/make_kconfig.pl /lib/modules/3.8.12-nrj-desktop-2rosa/build /lib/modules/3.8.12-nrj-desktop-2rosa/build
./scripts/make_myconfig.pl
perl scripts/make_config_compat.pl /lib/modules/3.8.12-nrj-desktop-2rosa/build ./.myconfig ./config-compat.h
make -C firmware prep
creating symbolic links...
make[1]: Entering directory `/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/firmware'
make[1]: Leaving directory `/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/firmware'
make -C firmware
make[1]: Entering directory `/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/firmware'
  CC  ihex2fw
Generating vicam/firmware.fw                                                                                                                                                                  
Generating dabusb/firmware.fw                                                                                                                                                                 
Generating dabusb/bitstream.bin                                                                                                                                                               
Generating ttusb-budget/dspbootcode.bin                                                                                                                                                       
Generating cpia2/stv0672_vp4.bin                                                                                                                                                              
Generating av7110/bootcode.bin                                                                                                                                                                
make[1]: Leaving directory `/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/firmware'                                                                                                   
Kernel build directory is /lib/modules/3.8.12-nrj-desktop-2rosa/build
make -C /lib/modules/3.8.12-nrj-desktop-2rosa/build SUBDIRS=/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l  modules
make[1]: Entering directory `/usr/src/linux-3.8.12-nrj-desktop-2rosa'
./scripts/make_kconfig.pl /lib/modules/3.8.12-nrj-desktop-2rosa/build /lib/modules/3.8.12-nrj-desktop-2rosa/build
make[2]: ./scripts/make_kconfig.pl: comando non trovato
  CC [M]  /var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.o
  CC [M]  /var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.o
  CC [M]  /var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.o
  CC [M]  /var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.o
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1810:1: warning: data definition has no type or storage class [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1810:1: warning: type defaults to 'int' in declaration of 'EXPORT_SYMBOL' [-Wimplicit-int]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1810:1: warning: parameter names (without types) in function declaration [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1813:1: warning: data definition has no type or storage class [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1813:1: warning: type defaults to 'int' in declaration of 'EXPORT_SYMBOL' [-Wimplicit-int]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1813:1: warning: parameter names (without types) in function declaration [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1815:20: error: expected declaration specifiers or '...' before string constant
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1816:15: error: expected declaration specifiers or '...' before string constant
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.c:1817:16: error: expected declaration specifiers or '...' before string constant
make[2]: *** [/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-types.o] Errore 1
make[2]: *** Attesa dei processi non terminati....
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.c: In function 'microtune_release':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.c:54:2: error: implicit declaration of function 'kfree' [-Werror=implicit-function-declaration]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c: In function 'free_firmware':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c:250:3: error: implicit declaration of function 'kfree' [-Werror=implicit-function-declaration]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c: In function 'load_all_firmwares':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c:312:2: error: implicit declaration of function 'kzalloc' [-Werror=implicit-function-declaration]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c:312:13: warning: assignment makes pointer from integer without a cast [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c:363:21: warning: assignment makes pointer from integer without a cast [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.c: In function 'microtune_attach':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.c:623:2: error: implicit declaration of function 'kzalloc' [-Werror=implicit-function-declaration]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.c:623:7: warning: assignment makes pointer from integer without a cast [enabled by default]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c: In function 'xc2028_attach':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.c:1266:13: warning: assignment makes pointer from integer without a cast [enabled by default]
cc1: some warnings being treated as errors
make[2]: *** [/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/mt20xx.o] Errore 1
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.c: In function 'simple_release':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.c:997:3: error: implicit declaration of function 'kfree' [-Werror=implicit-function-declaration]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.c: In function 'simple_tuner_attach':
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.c:1081:2: error: implicit declaration of function 'kzalloc' [-Werror=implicit-function-declaration]
/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.c:1081:13: warning: assignment makes pointer from integer without a cast [enabled by default]
cc1: some warnings being treated as errors
make[2]: *** [/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-xc2028.o] Errore 1
cc1: some warnings being treated as errors
make[2]: *** [/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l/tuner-simple.o] Errore 1
make[1]: *** [_module_/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l] Error 2
make[1]: Leaving directory `/usr/src/linux-3.8.12-nrj-desktop-2rosa'
make: *** [default] Errore 2
make: Leaving directory `/var/lib/dkms/v4l-dvb-testing/0-0.hg14014.2/build/v4l'

##########################
Hardware:
**********
x86_64 is affected for sure, ix86 might be as well ( just a supposition ),
Comment 1 Denis Silakov 2014-09-19 11:43:55 MSD
It looks like we don;t care about this particular package anymore and dropped it from Fresh R4 repositories.