Bug 258 - pcscd service hangs and fails to start
: pcscd service hangs and fails to start
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: alexander barakin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 20:24 MSD by Konstantin Vlasov
Modified: 2012-05-30 16:25 MSD (History)
3 users (show)

See Also:
RPM Package: pcsc-lite
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2012-05-21 20:24:37 MSD
Description of problem:
Each time I boot ROSA Marathon 2012 installed into VirtualBox, the Smart Card Service daemon (pcscd) is started but hangs, and finally after ~4-5 minutes is forcibly terminated. Extract from /var/log/messages:

  May 21 16:08:34 localhost pcscd[1866]: Starting smart card daemon: [  OK  ]
  May 21 16:08:35 localhost systemd[1]: PID file /var/run/pcscd.pid not readable (yet?) after start.
  May 21 16:13:34 localhost systemd[1]: pcscd.service operation timed out. Terminating.
  May 21 16:13:34 localhost systemd[1]: Unit pcscd.service entered failed state.
  May 21 16:13:34 localhost systemd[1]: Startup finished in 1s 5ms 994us (kernel) + 4s 114ms 466us (initrd) + 5min 9s 777ms 678us (userspace) = 5min 14s 898ms 138us.

Version-Release number of selected component (if applicable):
1.6.6.3
Comment 1 alexander barakin 2012-05-25 10:31:12 MSD
possibly related bug 60
and discussion in rosa-devel: http://lists.rosalab.ru/mailman/private/rosa-devel/2012-May/001891.html

i built version 1.8.2 (from cooker) in my repo with additon of creating proper symlink: https://abf.rosalinux.ru/sash_kan/pcsc-lite/tree/rosa2012lts
Comment 2 alexander barakin 2012-05-25 10:44:29 MSD
Advisory:
pcsc-lite-1.6.6 lack of integration with systemd.
new version 1.8.2 (from mandriva cooker) has it.
also added a symlink to start the pcscd daemon with multi-user target.
Comment 4 alexander barakin 2012-05-25 11:01:58 MSD
Advisory:
pcsc-lite-1.6.6 lack of integration with systemd.
new version 1.8.2 (from mandriva cooker) has it.
also added a symlink to start the pcscd daemon with multi-user target.
https://abf.rosalinux.ru/build_lists/575560
https://abf.rosalinux.ru/build_lists/575561
Comment 5 alexander barakin 2012-05-25 11:02:30 MSD
Advisory:
pcsc-lite-1.6.6 lack of integration with systemd.
new version 1.8.2 (from mandriva cooker) has it.
also added a symlink to start the pcscd daemon with multi-user target.
https://abf.rosalinux.ru/build_lists/575560
https://abf.rosalinux.ru/build_lists/575561
Comment 6 alexander barakin 2012-05-25 11:03:18 MSD
Advisory:
pcsc-lite-1.6.6 lack of integration with systemd.
new version 1.8.2 (from mandriva cooker) has it.
also added a symlink to start the pcscd daemon with multi-user target.
https://abf.rosalinux.ru/build_lists/575560
https://abf.rosalinux.ru/build_lists/575561
Comment 7 alexander barakin 2012-05-25 11:04:52 MSD
exсuse for spam: i find right way to make available checkbox "request for update"
Comment 8 Vladimir Potapov 2012-05-25 12:00:13 MSD
Please, rebuild your package to the official public repository instead of your
private one, as specified in the "Make a proper build"
Comment 9 alexander barakin 2012-05-25 14:09:30 MSD
(In reply to comment #8)
> Please, rebuild your package to the official public repository instead of
> your
> private one, as specified in the "Make a proper build"

https://abf.rosalinux.ru/build_lists/577750
https://abf.rosalinux.ru/build_lists/577751
Comment 10 Alexander Petryakov 2012-05-29 01:46:02 MSD
pcsc-lite-1.8.2-2-rosa.lts2012.0
Please clarify me, pcscd don't start at boot, is it correct?
but
chkconfig shows:
pcscd           0:выкл  1:выкл  2:вкл   3:вкл   4:вкл   5:вкл   6:выкл  7:выкл
also i don't see symlink under
ls -l /lib/systemd/system/multi-user.target.wants/
ls -l /etc/systemd/system/multi-user.target.wants/

p.s. if run manualy (/etc/init.d/pcscd start) in /var/log/message appears error "May 29 00:59:45 localhost pcscd[10606]: 00000000 utils.c:53:GetDaemonPid() Can't open /var/run/pcscd/pcscd.pid: No such file or directory"

Please request qa_verified if this not a bug.
Comment 11 alexander barakin 2012-05-29 15:25:07 MSD
(In reply to comment #10)
> pcsc-lite-1.8.2-2-rosa.lts2012.0
> Please clarify me, pcscd don't start at boot, is it correct?

yes, it is correct if pcscd not enabled by systemctl

> but
> chkconfig shows:
> pcscd           0:выкл  1:выкл  2:вкл   3:вкл   4:вкл   5:вкл   6:выкл 
> 7:выкл

it is not normal, but problem in systemd, not in pcsc-lite·
for example try to disable/enable (with systemctl) any of services in /etc/systemd/system/multi-user.target.wants/ — you will not see difference in chkconfig output·

> also i don't see symlink under
> ls -l /lib/systemd/system/multi-user.target.wants/
> ls -l /etc/systemd/system/multi-user.target.wants/

just enable the service:
$ sudo systemctl enable pcscd.service
ln -s '/lib/systemd/system/pcscd.service' '/etc/systemd/system/multi-user.target.wants/pcscd.service'
ln -s '/lib/systemd/system/pcscd.socket' '/etc/systemd/system/sockets.target.wants/pcscd.socket'

> p.s. if run manualy (/etc/init.d/pcscd start) in /var/log/message appears
> error "May 29 00:59:45 localhost pcscd[10606]: 00000000
> utils.c:53:GetDaemonPid() Can't open /var/run/pcscd/pcscd.pid: No such file
> or directory"

it is not a bug - pcscd is not running, hence pid file is missing

> Please request qa_verified if this not a bug.

ok
Comment 12 alexander barakin 2012-05-29 15:27:23 MSD
Advisory:
pcsc-lite-1.6.6 lack of integration with systemd.
new version 1.8.2 (from mandriva cooker) has it.
also added a symlink to start the pcscd daemon with multi-user target.

https://abf.rosalinux.ru/build_lists/577750
https://abf.rosalinux.ru/build_lists/577751
Comment 13 Alexander Petryakov 2012-05-29 23:28:03 MSD
For x86_64 i see , next error on /var/log/messages
----
pcscd[3767]: 00013440 hotplug_libusb.c:119:HPReadBundleValues() Cannot open PC/SC drivers directory: /usr/lib64/pcsc/drivers/
pcscd[3767]: 00002191 hotplug_libusb.c:120:HPReadBundleValues() Disabling USB support for pcscd.
----

In the /usr/lib64 not exists pcsc dir.

For i586 all OK
Comment 14 alexander barakin 2012-05-30 15:23:12 MSD
(In reply to comment #13)
> For x86_64 i see , next error on /var/log/messages
> ----
> pcscd[3767]: 00013440 hotplug_libusb.c:119:HPReadBundleValues() Cannot open
> PC/SC drivers directory: /usr/lib64/pcsc/drivers/
> pcscd[3767]: 00002191 hotplug_libusb.c:120:HPReadBundleValues() Disabling
> USB support for pcscd.
> ----
> 
> In the /usr/lib64 not exists pcsc dir.
> 
> For i586 all OK

i see the same lines (on the x86_64) with old version 1.6.6:
May 30 15:16:38 localhost pcscd: hotplug_libusb.c:117:HPReadBundleValues() Cannot open PC/SC drivers directory: /usr/li
b64/pcsc/drivers/
May 30 15:16:38 localhost pcscd: hotplug_libusb.c:118:HPReadBundleValues() Disabling USB support for pcscd.

that is, this is _another_ bug in pcsc-lite (not "pcscd service hangs and fails to start")·

feel free to open a new bug report·
Comment 15 Alexander Petryakov 2012-05-30 16:25:54 MSD
pcsc-lite-1.8.2-2-rosa.lts2012.0
************** Advisory **************
pcsc-lite-1.6.6 lack of integration with systemd.
new version 1.8.2 (from mandriva cooker) has it.
also added a symlink to start the pcscd daemon with multi-user target.
**************************************
QA Verified