Bug 257 - Impossible to enable/disable services
: Impossible to enable/disable services
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 20:09 MSD by Konstantin Vlasov
Modified: 2012-07-26 16:53 MSD (History)
3 users (show)

See Also:
RPM Package: system-config-services
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2012-05-21 20:09:47 MSD
Start ROSA Control Center -> System -> Manage system services. Service Configuration tool opens which contains toolbar buttons and menu commands "Enable" and "Disable" for controlling the service boot-time loading. However, these commands can only be used for cups-lpd and cvs services (when selecting one of them, the "Enable" command becomes available); for all other services these buttons remain grayed out and therefore impossible to be used.
Comment 1 Aleksandr Kazantcev 2012-05-22 01:29:28 MSD
It's normal. In Fedora this part with systemd service also not work :)
Now not pretty GUI will posible enable/disable systemd services (may be we write it?).
Comment 2 Konstantin Vlasov 2012-05-22 13:30:56 MSD
Hm... I'd understand if it was called "not our problem", but calling this behavior "normal" is out of all reason. If the application cannot perform functions it was designed to perform, it does not deserve the priviledge to be in the distribution, let alone to be the default tool for managing services. Maybe drakxservices did not have such glamour, but at least it worked...
Comment 3 Aleksandr Kazantcev 2012-05-22 13:40:33 MSD
drakxservice not see systemd anymore...

Now not instruments, that may enable/disable systemd service in GUI mode.
Comment 4 Konstantin Vlasov 2012-05-22 13:54:15 MSD
With drakxservices I could disable pcscd. With system-config-services I couldn't.
Comment 5 Aleksandr Kazantcev 2012-05-22 14:02:27 MSD
If pcsd systemd service? If not, then system-service-config has a bug with chkonfig service and this will be fix.

Another way - try using Mageia patch fix systemd detection.

Third - write new application
Comment 6 Denis Koryavov 2012-05-22 14:47:38 MSD
Is there a problem to force to work pcscd with systemd?
Comment 7 Konstantin Vlasov 2012-05-22 16:23:46 MSD
(In reply to comment #5)
> If pcsd systemd service?

How can I find this out? In the bug #258 I copied some lines from /var/log/messages which mention pcscd: they also include systemd, but does it mean that pcscd is a systemd service?
Comment 8 Aleksandr Kazantcev 2012-05-22 17:01:13 MSD
If service present in /etc/init.d it's not systemd, but manage via systemd.
Comment 9 Konstantin Vlasov 2012-05-22 19:04:46 MSD
I see. It's there, so it's not a systemd service.
Comment 10 Aleksandr Kazantcev 2012-05-22 20:23:59 MSD
pcsd is another bug. Fast search seen, that in system many doubles in systemd and init.d for one service, like shorewall and other. It's slow boot time, get some errors and need be fixing.
Comment 11 Aleksandr Kazantcev 2012-05-24 02:36:12 MSD
Try test drakxservice from this package. It's not finally (need wait update ldetect), but drakxservice now will support systemd

https://abf.rosalinux.ru/build_lists/573389
https://abf.rosalinux.ru/build_lists/573390
Comment 12 oldmanduser 2012-05-29 20:04:15 MSD
Alex Kazancev,

I tried installing the packages but still I am unable to disable many services like fedora-autorelabel etc

Please let me know how can I make it work

Regards,
Arun
Comment 13 Aleksandr Kazantcev 2012-05-29 20:16:27 MSD
Nowday no distros, that may work with systemd on 100%

You need use CLI interface and 

 systemctl enable/disable serivce_name 

and

 systemctl start/stop/restart service_name

for properly work.

Or you may try using systemadm

In drakxservice you need checkout "In startup" box for disabling service.
Comment 14 oldmanduser 2012-05-30 08:19:50 MSD
Alex Kazancev,

Thanks for the instructions.

Unfortunately only few of the services like winbind could be stopped using the CLI you had provided.

for example fedora-autorelabel is still active even though I had given the command

systemctl disable fedora-autorelabel.service

As far as drakxservices is concerned I see the "On Boot" checkbox, but then when I unselect a service and say OK and restart drakxservices it still shows as selected. I installed the packages from the link which you had provided.

Is there any other logs or CLI o/p you want me to provide for you to debug the issue more.........

Thanks again

Arun
Comment 15 Aleksandr Kazantcev 2012-05-30 08:40:18 MSD
Some other way - manually delete symlinks from /etc/systemd but...

I think if service will not stopped by CLI it's need for system and this action is deprecate...
Comment 16 oldmanduser 2012-05-30 09:30:19 MSD
Is there a way you folks can see what services are really required when booting the system and make the others as optional.

Why does fedora-relabel etc required to be started during boot?