Bug 2534 - MandrivaUpdate is refreshing only update media at startup
: MandrivaUpdate is refreshing only update media at startup
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 2535
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 16:53 MSD by Alexander Burmashev
Modified: 2013-11-18 12:11 MSK (History)
1 user (show)

See Also:
RPM Package: rpmdrake
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-08-23 16:53:00 MSD
Currently MandrivaUpdate at startup refreshes only update media, ( main/update, contrib/update and etc. All repos marked as update repos ). It may cause and causes problem if release repo was changed.

How to reproduce.
1) (in KDE ) To see that MandrivaUpdate updates only update repo,  start systemsettings from konsole ( logged in as root ), go to System Administration ( Администрирование системы ) and start System Update ( обновление системы ), check output to konsole.


2) To see the error that is caused by this problem install KDE fresh R1 i586, and run update from MandrivaUpdate.
Comment 1 Alexander Burmashev 2013-08-23 17:35:57 MSD
Here is the patch, that adresses the issue.
Thought i am not sure if it is sane enough )
https://abf.rosalinux.ru/import/rpmdrake/commit/284365103642407e34ba7d770b3f24d510134b6c
Comment 2 Alexander Burmashev 2013-08-23 17:46:14 MSD
BTW, to test mandrivaupdate behaviour it is enought to start it from /usr/sbin.
/usr/sbin/MandrivaUpdate
Comment 3 Denis Silakov 2013-11-18 12:11:48 MSK
Rpmdrake with this patch was published quite long ago.