Bug 253 - Gnucash does not start, and yields a backtrace instead
: Gnucash does not start, and yields a backtrace instead
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: Pavel Shved
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 01:04 MSD by Pavel Shved
Modified: 2013-01-10 11:07 MSK (History)
3 users (show)

See Also:
RPM Package: gnucash-2.4.6-2.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Shved 2012-05-21 01:04:04 MSD
Description of problem:

I tried to run the gnucash that comes with ROSA Marathon 2012; it didn't start, and said instead...

pavel@lonely ~/gnuca $ gnucash
Backtrace:
In unknown file:
   ?:  0* [primitive-load-path "c-interface.scm"]
In /usr/share/gnucash/scm/c-interface.scm:
  21:  1* [slib:require hash-table]
In /usr/share/guile/1.8/slib/require.scm:
 141:  2  (cond ((not feature) (set! *catalog* #f)) ((slib:provided? feature)) ...)
 145:  3  (let* ((path #)) (cond (# #) (# # #) (# # #) ...))
 145:  4* [catalog:get hash-table]
  76:  5* (if (not *catalog*) (let* ((slibcat #)) (cond (# # #)) ...))
  77:  6  (let* ((slibcat #)) (cond (# # #)) (cond (slibcat #)) ...)
  78:  7* (cond ((not #) (slib:load-source #) (set! slibcat #)))
  79:  8* [#<procedure #f (<pathname> . extra)> "/usr/share/guile/1.8/slib/mklibcat"]
 205:  9  [with-load-pathname "/usr/share/guile/1.8/slib/mklibcat" ...]
In /usr/share/guile/1.8/slib/guile.init:
    ...
 307: 10  [dynamic-wind #<procedure #f ()> #<procedure #f ()> #<procedure #f ()>]
In unknown file:
   ?: 11* [#<procedure #f ()>]
In /usr/share/guile/1.8/slib/require.scm:
 207: 12* [apply #<procedure slib:load #> #]
In unknown file:
   ?: 13  [slib:load "/usr/share/guile/1.8/slib/mklibcat"]
    ...
   ?: 14  [dynamic-wind #<procedure #f ()> #<procedure #f ()> #<procedure #f ()>]
   ?: 15* [#<procedure #f ()>]
In /usr/share/guile/1.8/slib/guile.init:
 557: 16* (let* ((errinfo #)) (if (and errinfo #) (apply throw errinfo)))
 560: 17  (if (and errinfo (catch # # #)) (apply throw errinfo))
In unknown file:
    ...
   ?: 18  [throw]

/usr/share/guile/1.8/slib/guile.init:560:10: In procedure open-file in expression (if (and errinfo #) (apply throw errinfo)):
/usr/share/guile/1.8/slib/guile.init:560:10: No such file or directory: "/usr/share/guile/1.8/slib/mklibcat"


How reproducible:

Rebooting doesn't help.

Steps to Reproduce:
1. Just run Gnucash from console to see the backtrace


P.S. Perhaps, I could take the maintainership of this?..
Comment 1 Pavel Shved 2012-05-22 01:10:52 MSD
I took a look at mandriva bug #60295 (https://qa.mandriva.com/show_bug.cgi?id=60295), scratched my head, and casted this:

pavel@lonely ~/work/gnucash/slib (rosa2012lts) $ sudo rpm -e --nodeps slib
[sudo] password for pavel: <type-type-type>
install-info: warning: no entries found for `/usr/share/info/slib.info.xz'; nothing deleted
pavel@lonely ~/work/gnucash/slib (rosa2012lts) $ sudo rpm -e --nodeps slib
error: package slib is not installed
pavel@lonely ~/work/gnucash/slib (rosa2012lts) $ sudo urpmi slib
<installed ok>

After that, gnucash started working.

I don't know what exactly should be fixed to make our distro work.  Alex, could you help with this, please?
Comment 2 Alexander Burmashev 2012-05-22 01:34:17 MSD
Looking at the behaviour it seems that slib has problems with it's postinstall scripts, and now i can understand why i was not able to reproduce it on my Free system ( it does not have gnucash + slib out of the box ).

The correct fix should contain the following
- pushing the updated slib to the updates ( and confirming that postinstall scripts are executed correctly after update )
- adding the fix to errata
- adding the fix to iso build scripts to ensure we won't have this problem in future.

It is a bit late already, so i will look at it closer and push the fix tomorrow.
Comment 3 alexander barakin 2012-12-21 23:25:41 MSK
advisory: fixed post scripts in guile and slib. gnucash now works.

guile:
https://abf.rosalinux.ru/build_lists/857957
https://abf.rosalinux.ru/build_lists/857958

slib:
https://abf.rosalinux.ru/build_lists/857959
https://abf.rosalinux.ru/build_lists/857960
Comment 4 Vladimir Potapov 2012-12-22 10:56:00 MSK
slib-3b3-2-rosa.lts2012.0
guile-1.8.8-5-rosa.lts2012.0
************** Advisory *******************
Fixed post scripts in guile and slib. 
Gnucash now works (fixed bug #253)
********************************************
QA Verified