Bug 2528 - Unable to install ROSA Fresh on a root partition with btrfs mounted with POSIX ACL support
: Unable to install ROSA Fresh on a root partition with btrfs mounted with POSI...
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 13:49 MSD by Eugene Shatokhin
Modified: 2013-08-22 14:42 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Screenshot taken when error occurred (15.95 KB, image/png)
2013-08-22 13:49 MSD, Eugene Shatokhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-08-22 13:49:06 MSD
Created attachment 1802 [details]
Screenshot taken when error occurred

Description of problem:

During installation of ROSA Fresh, I create a single partition mounted to / and formatted to Btrfs with 'acl' option (POSIX ACL support) enabled. The installation does not begin then, the following error is reported (see the attached screenshot):

---------------
An error occurred
mounting partition UUID=<...> in directory /
mnt/install failed.
---------------

Checked on the latest ISO builds for KDE and GNOME Editions (x64) at the moment.

Without setting 'acl' option, the error have not occurred so far.

How reproducible: always on my virtual machine


Steps to Reproduce:
1. Start installation of ROSA Fresh
2. When you get to the partitioning setup, choose "Custom ..."
3. Clear all existing partitions
4. Create a single partition occupying all available space, set its mount point to /, type - Btrfs (use Expert Mode), options - acl (other options may be left as they are).
5. Accept the partitioning you have created.
6. When the system complains that there is no swap, click OK.
7. See the error
Comment 1 Alexander Burmashev 2013-08-22 13:50:48 MSD
Can you please start system in live mode, start installer from terminal with draklive-install command ( from root ) and paste error output from terminal when installer fails ?
Comment 2 Eugene Shatokhin 2013-08-22 14:36:19 MSD
Console:
---------------------------
[root@localhost rosaliveuser2012.1]# draklive-install

Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated at /usr/lib/libDrakX/interactive/gtk.pm line 437.

Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated at /usr/lib/libDrakX/interactive/gtk.pm line 437.

Gtk-CRITICAL **: gtk_cell_view_set_cell_data: assertion `cell_view->priv->displayed_row != NULL' failed at /usr/lib/libDrakX/interactive/gtk.pm line 527.

umount: /dev/vda1: not mounted

WARNING! - Btrfs Btrfs v0.19 IS EXPERIMENTAL
WARNING! - see http://btrfs.wiki.kernel.org before using

fs created label (null) on /dev/vda1
        nodesize 4096 leafsize 4096 sectorsize 4096 size 60.00GB

Btrfs Btrfs v0.19
mount: wrong fs type, bad option, bad superblock on /dev/vda1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
----------------------

From the system log:

[  224.070511] device fsid ad6ea475-821a-46b9-9206-3e50ebc1c48f devid 1 transid 46 /dev/vda1
[  225.724564] device fsid 789bb9e1-2ffb-4094-bbbc-f28f8bec28c7 devid 1 transid 1 /dev/vda1
[  227.258408] device fsid 789bb9e1-2ffb-4094-bbbc-f28f8bec28c7 devid 1 transid 4 /dev/vda1
[  227.269050] device fsid 789bb9e1-2ffb-4094-bbbc-f28f8bec28c7 devid 1 transid 4 /dev/vda1
[  227.269433] btrfs: unrecognized mount option 'acl'
[  227.273026] btrfs: open_ctree failed
Comment 3 Eugene Shatokhin 2013-08-22 14:37:48 MSD
Well, it looks like Btrfs does not have 'acl' mount option at all.
https://btrfs.wiki.kernel.org/index.php/Mount_options

Perhaps, ACLs are enabled by default, not sure.
Comment 4 Eugene Shatokhin 2013-08-22 14:42:43 MSD
Just checked - yes, they are enabled by default.

Details:
https://btrfs.wiki.kernel.org/index.php/Changelog#ACL_support_.28Josef_Bacik.29