Bug 2525 - urpmi should not disabledrepositories and should be able to replace mirrors
: urpmi should not disabledrepositories and should be able to replace mirrors
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 16:39 MSD by Alexander Burmashev
Modified: 2015-08-16 12:00 MSD (History)
3 users (show)

See Also:
RPM Package: urpmi
ISO-related:
Bad POT generating:
Upstream:


Attachments
urpmi.repos created at time that update applet announces updates (3.08 KB, text/plain)
2014-01-14 18:06 MSK, Rolf Pedersen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-08-21 16:39:17 MSD
Currently we have a problem with uprmi.
Of course it should be investigated further and
1) If it can't access a repository metadata ( for example main updates ) it  disabled main updates.

It would be cool to make urpmi not to set ignore flag for the repo if it can't access it.


2) It would be cool if urpmi will search for mirrors one more time and replace current mirror, if it can't access current.
Comment 1 Denis Silakov 2013-08-28 15:52:03 MSD
As for repositories - urpmi doesn't disable them by themselves. This is done either by rpmdrake or by MandrivaUpdate applet.
Comment 2 Alexander Burmashev 2013-08-28 15:58:40 MSD
Yes, looks so, because i never use rpmdrake/mdkonline and never encountered such a problem.
Comment 3 Denis Silakov 2013-10-31 15:35:36 MSK
It would be nice to have steps to reproduce behavior concerning disabling repositories. I have tried to set wrong URL for one of the "updates" repositories in /etc/urpmi/urpm.cfg. All the programs (urpmi, urpmi.update, rpmdrake, mdkapplet, MandrivaOnline) report issue with such a repo, but they do not disable it...
Comment 4 Denis Silakov 2013-12-16 13:10:59 MSK
To investigate this problem deeper, I have added some more debug output to rpmdrake and urpmi packages (mdkapplet will be also affected, since it uses parts of rpmdrake and urpmi).

Updated rpmdrake and urpmi are available in testing repo of Desktop Fresh. Feel free to install these packages and use them for some time. If you notice that one of your repos became disabled, then take /var/log/urpmi.repos file and send it to me or attach to this bug.

Even if you don't get repositories disabled, please check from time to time to /var/log/urpmi.repos and look for "Attempt to disable repo during check" phrase. If it appears, let me know and send the log.
Comment 5 Rolf Pedersen 2014-01-13 21:48:10 MSK
Ok, I've had this bug for a long time.  At first, I think the mirrors are not synced when the applet reports updates but can't install due to something missing.  Eventually, I check the media manager in rpmdrake and main-updates has been unchecked, somehow, not by me.

This just happened, again, so I'm joining this bug.  I installed only urpmi and rpmdrake from ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/testing/

As yet, there is no /var/log/urpm* and none such in the files lists for these two programs.  Will it be generated by one of the programs?

FWIW, the record of installed rpms shows main-updates was enabled as recently as 4 days ago, when 
dracut was installed by MandrakeUpdate.

[rolf@localhost ~]$ rpm -qa --last | head -n 15
rpmdrake-5.26.12-35-rosa2012.1.noarch         Mon 13 Jan 2014 09:27:52 AM PST
urpmi-6.71-46-rosa2012.1.noarch               Mon 13 Jan 2014 09:27:49 AM PST
id3-0.78-5-rosa2012.1.x86_64                  Sun 12 Jan 2014 11:01:50 AM PST
read-edid-3.0.0-2-rosa2012.1.x86_64           Sat 11 Jan 2014 07:20:18 AM PST
perl-WWW-RobotRules-6.20.0-1-rosa2012.1.noarch Fri 10 Jan 2014 09:43:36 AM PST
perl-LWP-MediaTypes-6.20.0-1-rosa2012.1.noarch Fri 10 Jan 2014 09:43:36 AM PST
perl-IO-Socket-INET6-2.710.0-1-rosa2012.1.noarch Fri 10 Jan 2014 09:43:36 AM PST
perl-Encode-Locale-1.30.0-1-rosa2012.1.noarch Fri 10 Jan 2014 09:43:36 AM PST
perl-URI-1.600.0-1-rosa2012.1.noarch          Fri 10 Jan 2014 09:43:35 AM PST
perl-Convert-ASN1-0.260.0-1-rosa2012.1.noarch Thu 09 Jan 2014 05:10:33 PM PST
dracut-027-12-rosa2012.1.x86_64               Thu 09 Jan 2014 05:10:33 PM PST
perl-XML-Simple-2.200.0-1-rosa2012.1.noarch   Thu 09 Jan 2014 05:10:32 PM PST
perl-Image-ExifTool-9.270.0-1-rosa2012.1.noarch Thu 09 Jan 2014 05:10:32 PM PST
perl-HTTP-Negotiate-6.10.0-1-rosa2012.1.noarch Thu 09 Jan 2014 05:10:31 PM PST
perl-HTTP-Date-6.20.0-1-rosa2012.1.noarch     Thu 09 Jan 2014 05:10:31 PM PST

[rolf@localhost ~]$ urpmq --sources dracut
ftp://mirror.yandex.ru/rosa/rosa2012.1/repository/x86_64/media/main/release/dracut-024-7-rosa2012.1.x86_64.rpm

[rolf@localhost ~]$ urpmq --list-media
main
main updates
Main32
Main32 Updates
contrib
contrib updates
non-free
non-free updates
Non-free32
Non-free32 Updates
restricted
restricted updates
Restricted32
Restricted32 Updates

I will enable main-updates, reboot, and see what happens.


Thanks.
Comment 6 Denis Silakov 2014-01-13 21:51:59 MSK
(In reply to comment #5)

> As yet, there is no /var/log/urpm* and none such in the files lists for
> these two programs.  Will it be generated by one of the programs?

Yes. Just look for /var/log/urpm* after running "urpmi --auto-update" or automated update using MandrivaUpdate.
Comment 7 Rolf Pedersen 2014-01-13 22:51:39 MSK
After reboot, I let the applet do the updates.  After, I see no new file.  Then, I ran --auto-update but no change.

[root@localhost rolf]# urpmi --auto-update
medium "main" is up-to-date
medium "main updates" is up-to-date
medium "Main32" is up-to-date
medium "Main32 Updates" is up-to-date
medium "contrib" is up-to-date
medium "contrib updates" is up-to-date
medium "non-free" is up-to-date
medium "non-free updates" is up-to-date
medium "Non-free32" is up-to-date
medium "Non-free32 Updates" is up-to-date
medium "restricted" is up-to-date
medium "restricted updates" is up-to-date
medium "Restricted32" is up-to-date
medium "Restricted32 Updates" is up-to-date
Packages are up to date

[root@localhost rolf]# ls /var/log/u*
/var/log/user.log  /var/log/user.log.1  /var/log/user.log.2.gz  /var/log/user.log.3.gz  /var/log/user.log.4.gz
Comment 8 Denis Silakov 2014-01-13 22:54:45 MSK
(In reply to comment #7)
> After reboot, I let the applet do the updates.  After, I see no new file. 
> Then, I ran --auto-update but no change.
> 
> [root@localhost rolf]# ls /var/log/u*
> /var/log/user.log  /var/log/user.log.1  /var/log/user.log.2.gz 
> /var/log/user.log.3.gz  /var/log/user.log.4.gz

This means that applet haven't tried to modify urpmi.cfg. Indeed, this is the case if there are no updates. Let's wait for some time while new updates appear on mirrors and let's see if this file appear in this case.
Comment 9 Rolf Pedersen 2014-01-14 18:06:23 MSK
Created attachment 2514 [details]
urpmi.repos created at time that update applet announces updates

This morning, the applet announced updates and I saw that urpmi.repos had been created.  There seem to be two dumps.  The machine was on all night and, perhaps, there were two separate updates announced and the behavior is to append dumps to this file or, perhaps, there is some other reason but it is, otherwise, unremarkable, afaics.  In future, should I send the log only in case the repo has been disabled?
Comment 10 Denis Silakov 2014-01-14 18:24:52 MSK
(In reply to comment #9)

>  In future, should I send the log only in case the repo has been disabled?

Yes, the log will be useful if you detect disabled repo.

In addition, you can grep for "Attempt to disable repo during check" phrase in that log; let me know if this message appears.
Comment 11 Denis Silakov 2015-08-16 12:00:19 MSD
We believe that the issue with repositories being disabled was finally resolved . At least we haven't met it for a long time.

As for the mirror selection issues, a separate bug 6062 was created to track the problem.