Bug 2520 - dvdrip from repo "restricted" requires perl-Gtk2-Ex-FormFactory from "contrib"
: dvdrip from repo "restricted" requires perl-Gtk2-Ex-FormFactory from "contrib"
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 19:29 MSD by Eugene Shatokhin
Modified: 2014-10-14 10:56 MSD (History)
3 users (show)

See Also:
RPM Package: dvdrip-0.98.11-3-plf2012.1
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-08-20 19:29:12 MSD
Description of problem:
dvdrip from repo "restricted" requires perl-Gtk2-Ex-FormFactory from "contrib" and therefore cannot be installed if "contrib" is disabled.

I suppose the packages from "main", "non-free" and "restricted" are not allowed to require anything from "contrib", are they?


Version-Release number of selected component (if applicable):
dvdrip-0.98.11-3-plf2012.1

How reproducible: always


Steps to Reproduce:
# # urpmi --media main,restricted,non-free dvdrip

On my system, the output is:
---------------
A requested package cannot be installed:
dvdrip-0.98.11-3-plf2012.1.x86_64 (due to unsatisfied perl(Gtk2::Ex::FormFactory::Rules))
---------------
Comment 1 Denis Silakov 2013-08-21 10:22:44 MSD
This is not very good, though we do have such cases. Iirc, we have even decided to take contrib into account when running repoclosure on FBA for restricted and non-free repositories.

Though this particular case is easy. perl-Gtk2-Ex-FormFactory itself doesn't require anything from contrib, I think we can safely move it to the main repo.
Comment 2 Denis Silakov 2013-08-21 10:33:48 MSD
Well, the package has been moved to the main repo. This seems to be painless. But feel free to reopen the bug if this causes some issues.
Comment 3 Eugene Shatokhin 2013-08-23 11:27:01 MSD
Looks like dvdrip requires more stuff from contrib:

Installing dvdrip
Пакеты perl-5.14.2-8-rosa2012.1.x86_64, perl-Gtk2-1.244.0-4-rosa2012.1.x86_64, perl-base-5.14.2-8-rosa2012.1.x86_64 уже установлен
Не удаётся установить запрошенный пакет:
dvdrip-0.98.11-4-plf2012.1.x86_64 (из-за неудовлетворённости perl(Event::ExecFlow::Scheduler::SimpleMax))
Хоть часть пакетов и могла быть установлена, произошли ошибки.
Не удаётся установить запрошенный пакет:
dvdrip-0.98.11-4-plf2012.1.x86_64 (из-за неудовлетворённости perl(Event::ExecFlow::Scheduler::SimpleMax))
Failed to install dvdrip
urpmi returned 17
Comment 4 Alexander Burmashev 2013-08-23 11:33:51 MSD
this time it should be 
perl-Event-ExecFlow 
perl-Event-File
perl-Event
Comment 5 Alexander Burmashev 2013-08-23 11:41:18 MSD
perl-Any-Event is also required
Comment 6 Alexander Burmashev 2013-08-23 12:41:57 MSD
and perl-EV
Comment 7 Alexander Burmashev 2013-08-23 13:02:43 MSD
+perl-common-sense
Comment 8 FirstLevel 2014-10-08 14:58:11 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 9 Eugene Shatokhin 2014-10-14 10:56:22 MSD
The problem is fixed.