Bug 252 - I have no updates with GUI, but I can update with urpmi --auto-update
: I have no updates with GUI, but I can update with urpmi --auto-update
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 21:48 MSD by FirstLevel
Modified: 2012-07-06 19:20 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Sources (119.29 KB, image/png)
2012-05-20 21:49 MSD, FirstLevel
Details
I nave no updates with gui (134.30 KB, image/png)
2012-05-20 21:49 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-05-20 21:48:48 MSD
Description of problem:
If I check updates with GUI - I have no update. But if I open konsole and run urpmi --auto-update I see that many updates are appeared.
Screenshots in russian.
root@lts-64 ~]# urpmq --list-media active
main (LTS2012.0-1)
main updates (LTS2012.0-2)
non-free (LTS2012.0-5)
non-free updates (LTS2012.0-6)
restricted (LTS2012.0-7)
restricted updates (LTS2012.0-8)
[root@lts-64 ~]#  urpmq --list-url
main (LTS2012.0-1) http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/media/main/release
main updates (LTS2012.0-2) http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/media/main/updates
contrib (LTS2012.0-3) 
contrib updates (LTS2012.0-4) 
non-free (LTS2012.0-5) http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/media/non-free/release
non-free updates (LTS2012.0-6) http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/media/non-free/updates
restricted (LTS2012.0-7) http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/media/restricted/release
restricted updates (LTS2012.0-8) http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/media/restricted/updates
[root@lts-64 ~]# urpmi --auto-update
источник «main (LTS2012.0-1)» уже обновлён
источник «main updates (LTS2012.0-2)» уже обновлён
источник «non-free (LTS2012.0-5)» уже обновлён
источник «non-free updates (LTS2012.0-6)» уже обновлён
источник «restricted (LTS2012.0-7)» уже обновлён
источник «restricted updates (LTS2012.0-8)» уже обновлён
Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «main (LTS2012.0-1)»)
 busybox-static                 1.18.4       4             rosa> 2012.0 x86_64 
 kernel-headers                 3.0.28       3             rosa> 2012.0 x86_64 
 lib64blas3                     3.3.1        2             rosa> 2012.0 x86_64 
 lib64lapack3                   3.3.1        2             rosa> 2012.0 x86_64 
 lib64streamanalyzer0           0.7.6        4             rosa> 2012.0 x86_64 
 lib64streams0                  0.7.6        4             rosa> 2012.0 x86_64 
 lib64twolame0                  0.3.13       4             rosa> 2012.0 x86_64 
 strigi                         0.7.6        4             rosa> 2012.0 x86_64 
 sysvinit-tools                 2.87         15            rosa> 2012.0 x86_64 
 x11-docs                       1.6          3             rosa> 2012.0 x86_64 
(источник «restricted (LTS2012.0-7)»)
 alac_decoder                   0.2.0        1             plf   2012.0 x86_64 
 faad2                          2.7          5             plf   2012.0 x86_64 
 ffmpeg                         0.7.11       6plf          plf   2012.0 x86_64 
 gstreamer0.10-mpeg             0.10.18      4plf          plf   2012.0 x86_64 
 gstreamer0.10-plugins-ugly     0.10.18      4plf          plf   2012.0 x86_64 
 lib64avfilter1                 0.7.11       6plf          plf   2012.0 x86_64 
 lib64avformats52               0.7.11       6plf          plf   2012.0 x86_64 
 lib64avutil50                  0.7.11       6plf          plf   2012.0 x86_64 
 lib64dca0                      0.0.5        3             plf   2012.0 x86_64 
 lib64dvdcss2                   1.2.10       3             plf   2012.0 x86_64 
 lib64faac0                     1.28         4             plf   2012.0 x86_64 
 lib64faad2_2                   2.7          5             plf   2012.0 x86_64 
 lib64ffmpeg52                  0.7.11       6plf          plf   2012.0 x86_64 
 lib64lame0                     3.98.4       1             plf   2012.0 x86_64 
 lib64opencore-amr0             0.1.2        4             plf   2012.0 x86_64 
 lib64postproc51                0.7.11       6plf          plf   2012.0 x86_64 
 lib64swscaler0                 0.7.11       6plf          plf   2012.0 x86_64 
 lib64x264_120                  0.120        0.20111212.1  plf   2012.0 x86_64 
 lib64xvid4                     1.3.2        4             plf   2012.0 x86_64 
 mencoder                       1.0          10.rc4.0.r32> plf   2012.0 x86_64 
 mplayer                        1.0          10.rc4.0.r32> plf   2012.0 x86_64 
Будет использовано 5.5МБ дополнительного дискового пространства.
Будет загружено 47МБ пакетов.
Установить 31 пакетов? (Y/n) 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-05-20 21:49:28 MSD
Created attachment 161 [details]
Sources
Comment 2 FirstLevel 2012-05-20 21:49:47 MSD
Created attachment 162 [details]
I nave no updates with gui
Comment 3 Aleksandr Kazantcev 2012-05-20 21:53:29 MSD
GUI will update ONLY from update repo. It's now have not packages.
Comment 4 Denis Koryavov 2012-05-20 22:06:48 MSD
Well, it is a problem. As you can see, we have many updated packages that many users will not receive because of GUI utilities do not shows them.
Comment 5 Aleksandr Kazantcev 2012-05-20 22:13:44 MSD
Repeat. It's not a bug. Main repo will not have a update package after freezy and release distro. If user update for latest release, it's need use special update procedure. If user setup beta or RC, and then post bug about update, it's user's problem and we need drop it.

If we release check update package in not special update repo we will may many problem.

That behaviour in drakrpm from initial and we will not need change it.

Repeat again - it's not a bug.
Comment 6 Alexander Burmashev 2012-05-20 22:15:16 MSD
We have this addressed by errata.
I can also publish updated packages to updates repo to ensure everybody gets it.
Comment 7 Denis Koryavov 2012-05-20 23:15:36 MSD
Yes, It would be very good.
Comment 8 FirstLevel 2012-05-21 08:54:14 MSD
to Alexander.
I think this an error.
We have that document in our WIKI  http://wiki.rosalab.ru/en/index.php/Repo_Policy ?
"Each repository has two branches: release and updates. The release branch is frozen shortly before the release. After that, all packages for the platform are placed into the updates branch. Update policy depicts the restrictions on what can be placed into updates."

I have same situation on release

[root@lts-86 ~]# cat /etc/release
ROSA Linux release 2012.0 (LTS) for i586
[root@lts-86 ~]# cat /etc/isonumber
301
[root@lts-86 ~]#
Comment 9 FirstLevel 2012-05-21 08:56:07 MSD
Ooops.
My previoous message have a mistake.
That is a right output from x64 system.

[root@lts-86 etc]# cat release 
ROSA Linux release 2012.0 (LTS) for x86_64
[root@lts-86 etc]# cat ./isonumber 
301
[root@lts-86 etc]#
Comment 10 Aleksandr Kazantcev 2012-05-21 09:10:14 MSD
Now http://abf.rosalinux.ru/downloads/rosa2012lts/repository/i586/main/updates/ for example is empty. GUI will not see update and this is right.

CLI see all update, and it's also right, because in another way we drop testing and distro update mechanism.

What's wrong? We need drop some repo policy and use update from main repo in CLI. But in GUI it's working as needing.
Comment 11 Denis Silakov 2012-05-21 09:48:46 MSD
I agree with Alexander. Behavior of GUI tools is identical to 'urpmi --auto-update --update' (not just 'urpmi --auto-update') and this is how rpmdrake worked for years.

I agree that it is not good that we seem to have some packages in the main repos updated after release. But I think we should not modify the tools, but try to avoid such collisions in future and place all updates to the 'update' repos.
Comment 12 FirstLevel 2012-07-06 13:06:55 MSD
As I think it is Resolved-Wontfix
Comment 13 Alexander Burmashev 2012-07-06 13:07:48 MSD
Actually resolved fixed, all updates from main/release were moved to main/update