Bug 2517 - kernel was updated to 3.10.9 version [Update request]
: kernel was updated to 3.10.9 version [Update request]
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 2452 2519
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 22:21 MSD by Alexander Burmashev
Modified: 2013-09-03 19:28 MSD (History)
2 users (show)

See Also:
RPM Package: kernel
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
k3106-intel-hibernate.txt (26.99 KB, text/plain)
2013-08-20 20:46 MSD, Postnikov Dmitry
Details
report.odt (441.32 KB, application/vnd.oasis.opendocument.text)
2013-08-22 11:30 MSD, Postnikov Dmitry
Details
k3109-1.txt (28.57 KB, text/plain)
2013-08-28 17:48 MSD, Postnikov Dmitry
Details
k3109-2.txt (28.80 KB, text/plain)
2013-08-28 17:48 MSD, Postnikov Dmitry
Details
report.odt (76.67 KB, application/vnd.oasis.opendocument.text)
2013-08-28 23:27 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-08-19 22:21:35 MSD
kernel was updated to 3.10.6 version
Comment 1 Alexander Burmashev 2013-08-19 22:27:30 MSD
Advisory:
kernel was update to 3.10.6 version. This is recommended update, since 3.10 kernel is declared to be a new LTS release.
As usual 3.10 kernel provides much better hardware support, power consuming optimizations and bug fixes:

Buildlists:
i586
https://abf.rosalinux.ru/build_lists/1204368
https://abf.rosalinux.ru/build_lists/1203617

x86_64
https://abf.rosalinux.ru/build_lists/1204369
https://abf.rosalinux.ru/build_lists/1203618
Comment 2 Vladimir Potapov 2013-08-20 10:58:10 MSD
Следующие пакеты будут удалены для обновления остальных:
dkms-nvidia-long-lived-304.88-2-rosa2012.1.x86_64
 (из-за конфликтов с kernel-nrj-desktop-3.10.6-1rosa-1-1-rosa2012.1.x86_64)
dkms-nvidia173-173.14.37-3-rosa2012.1.x86_64
 (из-за конфликтов с kernel-nrj-desktop-3.10.6-1rosa-1-1-rosa2012.1.x86_64)
nvidia-long-lived-doc-html-304.88-2-rosa2012.1.x86_64
 (из-за неудовлетворённости x11-driver-video-nvidia-long-lived == 304.88-2)
nvidia173-doc-html-173.14.37-3-rosa2012.1.x86_64
 (из-за неудовлетворённости x11-driver-video-nvidia173 == 173.14.37-3)
x11-driver-video-nvidia-long-lived-304.88-2-rosa2012.1.x86_64
 (из-за неудовлетворённости kmod(nvidia-long-lived) == 304.88)
x11-driver-video-nvidia173-173.14.37-3-rosa2012.1.x86_64
 (из-за неудовлетворённости kmod(nvidia173) == 173.14.37)
Comment 3 Alexander Burmashev 2013-08-20 12:08:31 MSD
Yes, this is normal and expected. New kernels are build in a such way that packages conflict with the versions of dkms drivers that are incompatible with the current driver. Such conflict forces the user either to remove the incompatible driver, or to update it.

The problem is that we prepared updated for new kernel driver, but they were not yet published
here are the links
http://bugs.rosalinux.ru/show_bug.cgi?id=2452
Comment 5 Alexander Burmashev 2013-08-20 14:10:18 MSD
added 2452 2519 that kernel updated depends on.
Comment 6 Postnikov Dmitry 2013-08-20 20:46:07 MSD
Created attachment 1798 [details]
k3106-intel-hibernate.txt

I write (in 20:30) systemctl hibernate
and out from hibernate (in 20:35).
And in log messages trace kernel error intel driver.

In suspend mode - all ok. And on kernel 3.8.12 in hibernate mode also all ok.

systemd-194-21-rosa2012.1.x86_64
x11-driver-video-intel-2.21.6-1-rosa2012.1.x86_64

in my xorg.conf:
=================
Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    #Option "AccelMethod"  "sna"
    Option "AccelMethod"  "uxa"
EndSection
=================
Comment 7 Alexander Burmashev 2013-08-20 20:52:02 MSD
try please if
xset dpms force off
also causes such problem with intel
PLEASE NOTE that 
xset dpms force off
should put display into sleep mode
Comment 8 Postnikov Dmitry 2013-08-20 21:01:43 MSD
(In reply to comment #7)
> try please if
> xset dpms force off
> also causes such problem with intel
> PLEASE NOTE that 
> xset dpms force off
> should put display into sleep mode

xset dpms force off - without problem.
Comment 9 Postnikov Dmitry 2013-08-20 22:57:13 MSD
In my second computers also dno't work hibernate mode.
System out in hibernate, but not exit from hibernate.
part syslog:
===================
Aug 20 22:10:15 mindlife NetworkManager[1969]: <info> (eth0): bringing up device.
Aug 20 22:10:15 mindlife systemd-sleep[23806]: Hibernating system...
Aug 20 22:10:15 mindlife kernel: [ 1705.870011] PM: Marking nosave pages: [mem 0x0009d000-0x000fffff]
Aug 20 22:10:15 mindlife kernel: [ 1705.870015] PM: Marking nosave pages: [mem 0xdd983000-0xddb81fff]
Aug 20 22:10:15 mindlife kernel: [ 1705.870021] PM: Marking nosave pages: [mem 0xddc0d000-0xdedc8fff]
Aug 20 22:10:15 mindlife kernel: [ 1705.870060] PM: Marking nosave pages: [mem 0xdedca000-0xdee0cfff]
Aug 20 22:10:15 mindlife kernel: [ 1705.870062] PM: Marking nosave pages: [mem 0xdf233000-0xdf7f3fff]
Aug 20 22:10:15 mindlife kernel: [ 1705.870076] PM: Marking nosave pages: [mem 0xdf800000-0xffffffff]
Aug 20 22:15:05 mindlife kernel: imklog 5.8.12, log source = /proc/kmsg started.
Aug 20 22:15:05 mindlife rsyslogd: [origin software="rsyslogd" swVersion="5.8.12" x-pid="1879" x-info="http://www.rsyslog.com"] start
Aug 20 22:15:05 mindlife systemd[1]: Started udev Coldplug all Devices.

=================
In 22:10 i out in hibernate, in 22:15 i reboot and new boot system.
Comment 10 Postnikov Dmitry 2013-08-20 23:28:13 MSD
1. If i write "systemctl hibernate -f" all work hibernate mode.
2. If i write "systemctl hibernate" don't work hibernate mode.
Comment 11 Postnikov Dmitry 2013-08-22 11:30:01 MSD
Created attachment 1801 [details]
report.odt

***************************
Extended testing report
*************************
Report attached.
Comment 12 Vladimir Potapov 2013-08-23 11:40:15 MSD
Regressions after wake-up.
*****************
QA Denied
Comment 13 Alexander Burmashev 2013-08-28 11:21:41 MSD
Advisory:
kernel was update to 3.10.9 version. This is recommended update, since 3.10 kernel is declared to be a new LTS release.
As usual 3.10 kernel provides much better hardware support, power consuming optimizations and bug fixes:

Buildlists:
i586
https://abf.rosalinux.ru/build_lists/1221328
https://abf.rosalinux.ru/build_lists/1221330

x86_64
https://abf.rosalinux.ru/build_lists/1221329
https://abf.rosalinux.ru/build_lists/1221331
Comment 14 Postnikov Dmitry 2013-08-28 14:46:59 MSD
Take it back to work...
Comment 15 Alexander Burmashev 2013-08-28 14:50:16 MSD
First of all check please all regressions that were found in 3.10.6.
If they still can be reproduced - feel free to deny
Comment 16 Postnikov Dmitry 2013-08-28 17:48:30 MSD
Created attachment 1858 [details]
k3109-1.txt

Now a little bit better. Now, without the "-f" option goes into hibernation mode and returns. But traces kernel logs are still there. When we write "systemctl hibernate" the first screen off for 2-3 seconds, then reappears 5-6 seconds and then goes into hibernation mode. Then returns to normal.

(this attach with command "systemctl hibernate")
Comment 17 Postnikov Dmitry 2013-08-28 17:48:55 MSD
Created attachment 1859 [details]
k3109-2.txt

(this attach with command "systemctl hibernate -f")
Comment 18 Postnikov Dmitry 2013-08-28 17:50:28 MSD
Suspend mode all work without errors.
Comment 19 Postnikov Dmitry 2013-08-28 18:16:53 MSD
Wow! My camera worked! (FujiFilm FinePic AV100)
(On old kernel 3.10.6 did not work.)
Comment 20 Vladimir Potapov 2013-08-28 19:43:39 MSD
The update route to extended testing (officially :)
Comment 21 Postnikov Dmitry 2013-08-28 23:27:47 MSD
Created attachment 1862 [details]
report.odt

**************************
Extended testing report
**************************
Comment 22 Vladimir Potapov 2013-09-02 09:45:40 MSD
kernel-desktop-latest-3.10.9-1-rosa2012.1
******************** Advisory  ****************
kernel was update to 3.10.9 version. This is recommended update, since 3.10 kernel is declared to be a new LTS release.
As usual 3.10 kernel provides much better hardware support, power consuming optimizations and bug fixes.
***********************************
QA Verified