Bug 2505 - Google Earth since update with Nvidia 325.08
: Google Earth since update with Nvidia 325.08
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 19:50 MSD by Sylvainsjc
Modified: 2014-01-24 22:18 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Google Earth crashlog (405 bytes, text/plain)
2013-08-17 19:50 MSD, Sylvainsjc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2013-08-17 19:50:40 MSD
Created attachment 1789 [details]
Google Earth crashlog

Description of problem:
Since last Nvidia update, I can't use Google Earth !

Version-Release number of selected component (if applicable):
[root@Rosa2012Fresh nvidia-current]# rpm -qa | egrep -i 'google|nvidia|mesa'
mesa-demos-8.0.1-8-rosa2012.1.x86_64
mesa-9.0.1-3-rosa2012.1.x86_64
dkms-nvidia-current-325.08-9-rosa2012.1.x86_64
x11-driver-video-nvidia-current-325.08-9-rosa2012.1.x86_64
nvidia-current-doc-html-325.08-9-rosa2012.1.x86_64
google-earth-stable-7.1.1.1888-0.x86_64
[root@Rosa2012Fresh nvidia-current]# 

How reproducible:
[sylvain@Rosa2012Fresh ~]$ google-earth 
[0817/172448:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
[0817/172448:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0817/172448:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0817/172448:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0817/172448:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0817/172448:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0817/172448:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
Version mismatch detected between the NVIDIA libGL.so
and libnvidia-glcore.so. shared libraries (libGL.so version:
319.17; libnvidia-glcore.so. version: 325.08).
Please try reinstalling the NVIDIA driver.Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/sylvain/.googleearth/crashlogs/crashlog-520f95c0.txt
Comment 1 Sylvainsjc 2013-08-17 22:32:39 MSD
Finally solved, there was a lot of old libraries related to Nvidia 319.17

Not sure that the upgrade process cleans old versions perfectly ?

History of the deletion I've done before reinstall Nvidia

  459  rm -rf /usr/lib/libnvidia-glcore.so.319.17
  461  rm -rf /usr/lib/libnvidia-glcore.so.319.17
  471  rm -rf libnvidia*
  472  rm -rf libvdpau_nvidia.so 
  475  rm -rf vdpau/libvdpau_nvidia.so.319.17 
  476  rm -rf tls/libnvidia-tls.so.319.17 
  481  rm -rf libnvidia-*
  483  rm -rf libvdpau_nvidia.so 
  485  rm -rf xorg/modules/libnvidia-wfb.so.*
  486  rm -rf xorg/modules/drivers/nvidia_drv.so 
  487  rm -rf vdpau/libvdpau_nvidia.so.319.17 
  488  rm -rf directfb-1.6-0/gfxdrivers/libdirectfb_nvidia.so 
  489  rm -rf tls/libnvidia-tls.so.319.17 
  495  rm -rf nvidia*
Comment 2 Denis Silakov 2014-01-11 21:56:32 MSK
The update should happen smooth and old libs should be removed... Maybe this was a transient failure caused by rpm db corruption?

Do you experience any problems with updating to the latest 331.20?
Comment 3 Denis Silakov 2014-01-24 22:18:26 MSK
Well, marking as "worksforme" for now. Feel free to reopen if you are able to reproduce the issue with current state of repositories.