Bug 25 - Automatic update not working
: Automatic update not working
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 27 28
  Show dependency treegraph
 
Reported: 2012-04-10 20:18 MSD by ferri
Modified: 2012-04-12 15:47 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ferri 2012-04-10 20:18:53 MSD
Description of problem:
1. Automatic updating of the system is not working.
2. When I try it manually via ROSA Control Center -> Update your system, there is nothing for updating. List of updates is empty.
3. When I use "urpmi --auto-update" in console, there is lot of packages for updating.
Comment 1 Alexander Burmashev 2012-04-10 20:21:45 MSD
Can you attacj your /etc/urpmi/urpmi.cfg here ?
I think that uprmi --auto-update checks all the repositories for updates, while GUI tools checks only repos marked as update.
Comment 2 Denis Silakov 2012-04-11 11:02:57 MSD
Yes, the thing is that 'Update your system' in the Control Center looks for packages in repos marked as 'update', while 'urpmi --auto-update' scans all available repositories.

If you explicitly add 'update' word for all repos in /etc/urpmi/urpmi.cfg, Control Center will also check for new packages in all repositories. E.g.:

main\ (LTS2012.0-1) {
  downloader: wget
  update
  mirrorlist: $MIRRORLIST
  with-dir: /media/main/release
}

I think that this behavior of Control Center does make sense and should be left 'as is', since after distribution release, 'release' repositories are frozen and packages are updated only in the 'update' repos.
Comment 3 Alexander Burmashev 2012-04-12 15:47:32 MSD
I am closing the bug as it is not a bug, but expected behavior.