Bug 2486 - binutils package was updated to 2.21.53.0.2
: binutils package was updated to 2.21.53.0.2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 16:47 MSD by Alexander Burmashev
Modified: 2013-08-15 18:29 MSD (History)
1 user (show)

See Also:
RPM Package: binutils
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2013-08-12 16:47:31 MSD
binutils package was updated to 2.21.53.0.2
Comment 1 Alexander Burmashev 2013-08-12 16:47:57 MSD
Advisory:
binutils package was updated to 2.21.53.0.2
Changelog 
Changes from binutils 2.21.52.0.2:

1. Update from binutils 2011 0716.
2. Fix LTO linker bugs.  PRs 12982/12942.
3. Fix rorx support in x86 assembler/disassembler for AVX Programming
Reference (June, 2011).
4. Fix an x86-64 ELFOSABI linker regression.
5. Update ELFOSABI_GNU support.  PR 12913.
6. Fix a linker regression with prelink support.  PR 12921.
7. Add unwind info to x86 PLT section.  PR 12570.
8. Support x32 core files.
9. Support native x32 linker.
10. Fix linker --gc-sections on note sections.  PR 12851.
11. Avoid linker crash on bad input.  PR 12887.
12. Add section flags in linker script.
13. Improve elf linker -z option support.
14. Fix nm on compressed debug sections.  PR 12983.
15. Fix an ar bug.  PR 12558.
16. Fix an ia64 linker regression.  PR 12978.
17. Improve gold.
18. Improve VMS support.
19. Add TILE-Gx/TILEPro support.
20. Improve alpha support.
21. Improve avr support.
22. Improve mips support.
23. Improve arm support.
24. Improve ppc support.
25. Improve sh support.
26. Improve TIC6X support.
References:
http://sourceware.org/ml/libc-alpha/2011-08/msg00016.html
Buildlists:
https://abf.rosalinux.ru/build_lists/1202533
https://abf.rosalinux.ru/build_lists/1202547
Comment 2 Alexander Burmashev 2013-08-13 17:08:02 MSD
It is particularly neede because currently with old binutils some builds fail, for example https://abf.rosalinux.ru/nicco/Kernel-3.10.5-1 fails on x86_64
Comment 3 Vladimir Potapov 2013-08-14 15:30:52 MSD
binutils-2.21.53.0.2-1-rosa.lts2012.0
****************** Advisory ***************
binutils package was updated to 2.21.53.0.2. It is particularly neede because currently with old binutils some builds fail, for example Kernel-3.10.5-1 fails on x86_64
******************* ChangeLog ********************
1. Update from binutils 2011 0716.
2. Fix LTO linker bugs.  PRs 12982/12942.
3. Fix rorx support in x86 assembler/disassembler for AVX Programming
Reference (June, 2011).
4. Fix an x86-64 ELFOSABI linker regression.
5. Update ELFOSABI_GNU support.  PR 12913.
6. Fix a linker regression with prelink support.  PR 12921.
7. Add unwind info to x86 PLT section.  PR 12570.
8. Support x32 core files.
9. Support native x32 linker.
10. Fix linker --gc-sections on note sections.  PR 12851.
11. Avoid linker crash on bad input.  PR 12887.
12. Add section flags in linker script.
13. Improve elf linker -z option support.
14. Fix nm on compressed debug sections.  PR 12983.
15. Fix an ar bug.  PR 12558.
16. Fix an ia64 linker regression.  PR 12978.
17. Improve gold.
18. Improve VMS support.
19. Add TILE-Gx/TILEPro support.
20. Improve alpha support.
21. Improve avr support.
22. Improve mips support.
23. Improve arm support.
24. Improve ppc support.
25. Improve sh support.
26. Improve TIC6X support.
************************************************
QA Verified