Bug 2453 - [UPDATE REQUESR] New network stack for ROSA Fresh
: [UPDATE REQUESR] New network stack for ROSA Fresh
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 12:04 MSD by Aleksandr Kazantcev
Modified: 2013-10-12 01:07 MSD (History)
2 users (show)

See Also:
RPM Package: initscript-9.34-9 systemd-194.22
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-08-07 12:04:27 MSD
New network stack
Comment 1 Aleksandr Kazantcev 2013-08-07 12:06:29 MSD
initscript
https://abf.rosalinux.ru/build_lists/1200611
https://abf.rosalinux.ru/build_lists/1200612

systemd
https://abf.rosalinux.ru/build_lists/1200402
https://abf.rosalinux.ru/build_lists/1200403

Advisory: As we done early full remove drakx-net components brought some network problem, like non-working ifup/ifdown, speed reduce with interface change and etc, because we missed change udev rules ans network scripts. For that reason we improved network stack:

1. Full drop old Mandriva NM workarounds
2. Use upstream code for compatibility with NM
3. Really disable non-plugged and non-working networks
4. Ifup/ifdown works for NM connections too.

Also may be you will need manually delete files (if not deleted in automate mode).

/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-wlan0

and may be another ifcgf-ethX and wlanX
Comment 2 Postnikov Dmitry 2013-08-07 12:36:48 MSD
I took the advanced testing yesterday.
Comment 3 Vladimir Potapov 2013-08-07 19:08:46 MSD
After update (i586) systemctl| grep failed I see regression:
network.service       loaded failed failed        LSB: Bring up/down networking
Comment 4 Vladimir Potapov 2013-08-07 19:13:38 MSD
The package route to extended testing. Officially.
Comment 5 Aleksandr Kazantcev 2013-08-07 19:32:23 MSD
> network.service       loaded failed failed        LSB: Bring up/down networking

You need delete all old ifcfg-X parts (leave ifcfg-lo only) and setup for new.

And this is not regress - before all NM interface been ignored, now they may say about error if cable not pluged and etc. This is normal for current implimentation.
Comment 6 Postnikov Dmitry 2013-08-08 00:18:27 MSD
Postponed until 12.08.2013 new packages will be.
Comment 7 Vladimir Potapov 2013-08-08 13:09:05 MSD
Request rejected by the results of additional testing. After correction can again make a request here.
Comment 8 Aleksandr Kazantcev 2013-10-12 01:07:35 MSD
Close