Bug 2444 - [PACKAGE REQUEST] New package yaml-cpp-0.5.1
: [PACKAGE REQUEST] New package yaml-cpp-0.5.1
Status: RESOLVED WONTFIX
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 09:52 MSD by Dmitry
Modified: 2013-12-10 23:39 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2013-08-06 09:52:54 MSD
Hello!

Please, build and add yaml-cpp 0.5.1 (http://code.google.com/p/yaml-cpp/) to official repository.

Thank you!
Comment 1 Denis Silakov 2013-08-19 12:46:35 MSD
So current yaml-cpp (0.3.0) is not enough for you?

It's easy to build to 0.5.1, but this version is incompatible with 0.3.0, and e.g. OpenColorIO fails to build with yaml-cpp-0.5.1.

So likely we should really create a separate package.
Comment 2 Dmitry 2013-08-19 12:53:57 MSD
0.3.0 is old version, but developers of YAML C++ haven't separated versions, so, 0.5.1 replaces 0.3.0 and it is really difficult to make them presented together on the same system. Theoretically it should be possible to have both versions, but URPM will think that 0.5.1 is an update, but I don't know can pkgconfig distinguish 2 versions.
Comment 3 Denis Silakov 2013-08-19 13:05:47 MSD
0.3.0 and 0.5.1 have different sonames, so you can have both libraries themselves installed in your system. I will create necessary packages soon.

Surely, you can't install -devel packages for both versions at the same time, but this is a normal situation. If you want to build with yaml-cpp-0.5.1, you should require "pkgconfig(yaml-cpp) = 0.5.1" (or "pkgconfig(yaml-cpp) >= 0.5.0", if you want to build with yaml-cpp-0.3.0 - "pkgconfig(yaml-cpp) = 0.3.0".
Comment 4 Denis Silakov 2013-08-19 13:10:57 MSD
Advisory:
A new package with yaml-cpp-0.5.1. We can't update current yaml-cpp (0.3.0) since some packages fail to build with newer version.

Build lists:
https://abf.rosalinux.ru/build_lists/1217553
https://abf.rosalinux.ru/build_lists/1217552
Comment 5 Dmitry 2013-08-19 13:26:03 MSD
> Surely, you can't install -devel packages for both versions at the same
> time, but this is a normal situation. 

Is is NOT a normal situation. I've seen some spec from other well-known distrib, where maintainer of Qt5 has written:

Conflicts: qt4-devel

So, because of popularity of yaml-cpp is isn't a problem, but in case of qt5 it is  real problem, because it should be possible to port application from Qt4 to Qt5 (i.e. have qt4-devel and qt5-devel installed both).
Comment 6 Denis Silakov 2013-08-19 13:46:32 MSD
(In reply to comment #5)
> > Surely, you can't install -devel packages for both versions at the same
> > time, but this is a normal situation. 
> 
> Is is NOT a normal situation. I've seen some spec from other well-known
> distrib, where maintainer of Qt5 has written:
> 
> Conflicts: qt4-devel

Well, again - it is *ok* that you can't install devel packages of different versions of a same package. This is not needed for most users; for them, it is enough to be able to install qt4 and qt5 in parallel, as well as yaml-cpp-0.3.0 and yaml-cpp-0.5.1.

If you want to build something with qt4, install qt4-devel. If you want to build something with qt5, remove qt4-devel and install qt5-devel. We have a lot of such examples in our repositories and I really can't understand what's the problem here. It is not ideal for developers, but if you build packages in ABF or using mock-urpm it is not a problem at all.
Comment 7 Dmitry 2013-08-19 16:03:36 MSD
If You want to develop some app based on qt4 and some app based on qt5 at the same time, you CAN'T do this. Or CHANGE YOUR DISTRIB. It is simplier to change OS.
Comment 8 Denis Silakov 2013-08-19 16:19:36 MSD
I doubt that many of our users are developing something; ROSA Desktop is targeted to desktop users, not developers. We solve users' issues at the first time and we don't have enough resources to saatisfy every developer.

But feel free to provide an ideal solution for yaml-cpp. Talk is cheap, show me the code (c) :)
Comment 9 Dmitry 2013-08-19 16:40:11 MSD
(In reply to comment #8)
> I doubt that many of our users are developing something; ROSA Desktop is
> targeted to desktop users, not developers. We solve users' issues at the
> first time and we don't have enough resources to saatisfy every developer.
> 
> But feel free to provide an ideal solution for yaml-cpp. Talk is cheap, show
> me the code (c) :)

We have decided that we won't create package for yaml-cpp 0.5.1.
Comment 10 Denis Silakov 2013-08-20 10:15:03 MSD
Ok. What currently prevents us from updating yasml-cpp to 0.5.1 is opencolorio. This is an important package and it fails to build with yaml-cpp 0.5.1. This issue is reported upstream, let's wait for the resolution:

https://github.com/imageworks/OpenColorIO/issues/318

Another package which uses yaml cpp - openxcom - is already updated upstream to be compatible with yaml-cpp 0.5.x.
Comment 11 Denis Silakov 2013-12-10 23:39:24 MSK
Ok, we won't publish yaml-0.5 to Desktop Fresh if you don't want this to happen:)

In the next Fresh we will have yaml-0.5 by default and probably yaml-0.3 as a separate package if OpenColorIO developers don't switch to new API.

Meanwhile, a recent comment from OpenColorIO bug:

"I started looking at this - yaml-cpp 0.5 now requires Boost, which is tedious - https://code.google.com/p/yaml-cpp/issues/detail?id=205
Plus the old 0.3 API is still being maintained. The old API will continue to be supported, and will still receive bugfixes! The 0.3.x and 0.4.x versions will be old API releases, and 0.5.x and above will all be new API releases."