Bug 2443 - gnome-games fails to install but urpmi reports no error
: gnome-games fails to install but urpmi reports no error
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 18:51 MSD by Eugene Shatokhin
Modified: 2015-01-22 21:26 MSK (History)
2 users (show)

See Also:
RPM Package: gnome-games-3.6.1-5-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
Install log for "gnome-games" (7.74 KB, application/octet-stream)
2013-08-05 18:51 MSD, Eugene Shatokhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2013-08-05 18:51:52 MSD
Created attachment 1732 [details]
Install log for "gnome-games"

Description of problem:

When I try to install "gnome-games" package, its prerequisites install OK but the package itself is not installed (see "18/19" in the attached log).

Strangely, urpmi exits with code 0 in this case as if it has installed everything successfully.

'rpm -qa | grep gnome-games' shows "gnome-games-common" only.

This happens on the recent builds of both GNOME and KDE editions of ROSA Fresh.


How reproducible: always


Steps to Reproduce:

1. urpmi --auto --no-suggests gnome-games
See the output.

2. rpm -qa | grep gnome-games
Comment 1 Eugene Shatokhin 2013-08-05 18:54:11 MSD
Forgot to add: when I re-run 'urpmi --auto --no-suggests gnome-games' after that, it does install "gnome-games" package as it should.
Comment 2 Eugene Shatokhin 2013-08-22 11:45:54 MSD
Got similar problem with glchess and kbattleship packages from "main updates" and "main". The packages are present in the repositories but 'urpmi glchess' and 'urpmi kbattleship' seem to do nothing.

No error output, exit code is 0 but no package installed.
Comment 3 Alexander Burmashev 2013-08-22 12:16:52 MSD
Well, spent some time checking it and found the reason.
kbattleship can't be installed because we have knavalbattle that provides it.
For some reason urpmi finds that there is knavalbattle in repo ( that provides newer kbatlleship), but does not install it.

Skipping kbattleship-4.9.4-2-rosa2012.1.x86_64 since newer version of the package exists in repositories
no packages match kbattleship (it is either in skip.list or already rejected)

same with glchess, it can't be installed because it is replaced by gnome-chess

 Not sure if we broke smth, or urpmi does not resolve it correctly. Would be cool if Denis Silakov will have a look at it.
Comment 4 Denis Silakov 2013-08-22 14:04:46 MSD
I've filed a separate bug #2529 that should fix issue with glchess and kbattleship.

However, that fix doesn't resolve issue with gnome-games, so I am not closing this bug, will investigate it further.
Comment 5 Denis Silakov 2013-08-22 17:40:35 MSD
Ok, the reason is like the following: gnome-games requires 'gnotravex'; gnotravex package is superseded by gnome-tetravex (which provides gnotravex, as well), so urpmi selects this package. However, gnome-tetravex obsoletes gnome-games, so urpmi deselects gnome-games. Since no packages depend on gnome-games, we have no errors, all games are installed, but not the gnome-games itself.

So I'd say that current structure of packages is not very good, though urpmi output could be more informative, as well.
Comment 6 Eugene Shatokhin 2015-01-22 21:26:33 MSK
Too old and not a big deal anyway.