Bug 244 - Problem with sound level
: Problem with sound level
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 13:08 MSD by Sylvainsjc
Modified: 2012-05-19 22:37 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2012-05-19 13:08:35 MSD
Description of problem:
On my desktop, the level of the output sound is very very low. Even if I settles it to 100%, the level is still too low.

My card : [
root@rosa2012 ~]# lspcidrake -v | fgrep -i AUDIO
snd_hda_intel   : nVidia Corporation|MCP61 High Definition Audio [MULTIMEDIA_AUDIO_DEV] (vendor:10de device:03f0 subv:1849 subd:0397) (rev: a2)

In the terminal, using the tool "alsamixer -c 0" I found the master front level is set to 21

Setting up the value to 100 solves the problem but... At the reboot, the value is not restored, even if I stores it using "alsactl store" command so,

- How to have a default setting with higher values ?
- Why the system do not restore the setting ?


How reproducible:
all time
Comment 1 Aleksandr Kazantcev 2012-05-19 13:16:03 MSD
From root found in /usr/share/kde4/env/kde4-firstsetup.sh

 	 ####workaround for sound on some machines####
	 alsactl restore
	 amixer set Master 33%

and delete amixer line (or set it for 100%). This will fix you error.
Comment 2 Sylvainsjc 2012-05-19 13:37:34 MSD
I've made the change in /usr/share/kde4/env/kde4-firstsetup.sh

I kept the line amixer like this :
amixer set Master 100%

I restarted the computer but the sound level is still the same

Look here : http://pix.toile-libre.org/?img=1337419606.jpg

and here : http://pix.toile-libre.org/?img=1337419812.jpg
Comment 3 Sylvainsjc 2012-05-19 22:37:58 MSD
Well, as I was not sure if I had installed from the RC or from the official release, I reinstalled official ROSA Marathon this afternoon and the sound level is now better initially.

I still was forced to increase the level with alsamixer because it was below the level of my other distribution opensuse.